Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Thu Feb 15, 2018 5:28 pm

Hello i have a wierd problem. I have an laptop that is equipped with an Nvidia GTX 850M and an Intel Core i5 with an integreated graphics chip. The Nvidia Driver works fine until i plug out the charger of my laptop then the frame rates drop from 3000 to less then 50. i tested that a few times with glxgears if i put the charger back in the frame rate stays still low. I never had expericend such an issue before and i dont know what to do. I tried using the old drivers (nvidia 340 but after a reinstalling of linux mint they dont work anymore)

Code: Select all

System:    Host: HomeOS Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.6.7  Distro: Linux Mint 18.3 Sylvia
Machine:   System: Micro-Star product: GE70 2PC v: REV:1.0
           Mobo: Micro-Star model: MS-1759 v: REV:0.B
           Bios: American Megatrends v: E1759IMS.62D date: 04/13/2015
CPU:       Dual core Intel Core i5-4210H (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3500 MHz 1: 2893 MHz 2: 2893 MHz 3: 2893 MHz
           4: 2893 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GM107M [GeForce GTX 850M]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.01hz, 1280x720@60.00hz
           GLX Renderer: N/A GLX Version: N/A
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx
           IF: enp4s0 state: down mac: 44:8a:5b:ed:d9:b4
           Card-2: Intel Wireless 3160 driver: iwlwifi
           IF: wlp5s0 state: up mac: 30:3a:64:f4:72:75
Drives:    HDD Total Size: 1016.2GB (0.9% used)
           ID-1: USB /dev/sda model: Mobile_Line size: 16.0GB
           ID-2: /dev/sdb model: WDC_WD10S21X size: 1000.2GB
Partition: ID-1: / size: 100G used: 7.3G (8%) fs: btrfs dev: /dev/sdb3
           ID-2: /home size: 832G used: 857M (1%) fs: btrfs dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 243 Uptime: 5 min Memory: 950.6/11929.5MB
           Client: Shell (bash) inxi: 2.2.35 
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
ClixTrix
Level 5
Level 5
Posts: 770
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by ClixTrix » Thu Feb 15, 2018 5:50 pm

Did you install Bumblebee? That's the open source version of Optimus for Linux.
Linux Mint 19 x64 Cinnamon 4.15.0-42-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 250GB + Toshiba OCZ VX500 512GB

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Thu Feb 15, 2018 6:05 pm

Yep and i ran into the same problem.
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
ClixTrix
Level 5
Level 5
Posts: 770
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by ClixTrix » Thu Feb 15, 2018 6:21 pm

Well, I see the open source nouveau driver (failed), but I don't see the nvidia proprietary driver that's required to work with Bumblebee.

Did you install the proprietary nvidia driver from Driver Manager. ( Menu - Administration - Driver Manager )
Linux Mint 19 x64 Cinnamon 4.15.0-42-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 250GB + Toshiba OCZ VX500 512GB

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Thu Feb 15, 2018 6:35 pm

Yes I have but sometimes the Nvidia Driver refuses to start.
https://imgur.com/a/Fe5Cz
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
ClixTrix
Level 5
Level 5
Posts: 770
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by ClixTrix » Thu Feb 15, 2018 6:44 pm

OK, I see you did try 340. It might simply be a specific version needed to get it working with Bumblebee.

Any chance you have a BIOS setting that specifically sets use only of the nVidia discreet processor?

Edit: I was just checking the GE70 and Bumblebee. I see a lot of old problems getting the discreet GPU to work. Don't know where that currently stands. :?
Linux Mint 19 x64 Cinnamon 4.15.0-42-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 250GB + Toshiba OCZ VX500 512GB

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Thu Feb 15, 2018 6:49 pm

Sadly Not. The MSI Bios is shit. You have not many settings to choose and you cant enable or disable the integrated graphics card or select the dedicate. Btw if i try to run bumblebee with the new driver i get

Code: Select all

 ERROR]Cannot access secondary GPU, secondary X is not active
. i tried to google it but i didnt found a solution to that either. I buyed this laptop before i came into linux else i wouldnt have buyed an laptop with an nvidia xD
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
ClixTrix
Level 5
Level 5
Posts: 770
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by ClixTrix » Thu Feb 15, 2018 7:28 pm

Yeah, I think that's the error I saw in a bug report at Bumblebee. I'll spend some time over coffee in the morning - looking for anyone who's got this laptop working. Sadly, that's the problem with vendors not supporting Linux. Optimus only got full Windows support from nVidia.
Linux Mint 19 x64 Cinnamon 4.15.0-42-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 250GB + Toshiba OCZ VX500 512GB

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Thu Feb 15, 2018 8:36 pm

Well. Wierd that its working until i plug the charger. Somehow the nvidia turns off. Anyway i played a bit around with nvidia drivers and ended up in recovery mode. Tomrrow morning im gonna do an fresh install of mint and see what happens if i pick the old driver and use bumblebee then. If nothing works im gonna take the nouveau driver. Thank your for your support so far :)

https://youtu.be/IVpOyKCNZYw
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Fri Feb 16, 2018 7:37 am

Well I have news. The Nvidia 340 Driver Working with the kernel 4.13 I can pull the ac adapter without getting lags the frame rate stays the same. But when i upgrade the kernel to 4.15 the 340. Drivers dont work anymore. Since Linux Mint 19 will probaly take a newer kernel im afraid i cant use the nvidia 340 driver anymore then :/
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

User avatar
ClixTrix
Level 5
Level 5
Posts: 770
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by ClixTrix » Fri Feb 16, 2018 9:13 am

HellDragon wrote:
Fri Feb 16, 2018 7:37 am
Well I have news. The Nvidia 340 Driver Working with the kernel 4.13 I can pull the ac adapter without getting lags the frame rate stays the same. But when i upgrade the kernel to 4.15 the 340. Drivers dont work anymore. Since Linux Mint 19 will probaly take a newer kernel im afraid i cant use the nvidia 340 driver anymore then :/
Well, that's progress. Yeah, I would not have advised trying the 4.15 Kernel yet.

I'm only finding old bug reports and no solid advise. I do see there were apparently multiple models of your laptop with different GPUs. The only semi-relevant post in the forum is for older Mint 17.

viewtopic.php?f=49&t=203234&p=1056350&h ... 0#p1056350

This is an interesting post on the Turkey Forum including install set. It lists the other pieces of the Bumblebee install with config advise.

https://forum.linuxmint.net.tr/index.php?topic=6258.0 (need use browser with translation to read)
Linux Mint 19 x64 Cinnamon 4.15.0-42-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 250GB + Toshiba OCZ VX500 512GB

User avatar
HellDragon
Level 1
Level 1
Posts: 16
Joined: Wed Feb 14, 2018 10:19 am
Location: somewhere on your disk in /root hueheheh :3

Re: Frame Rate Drops when pulling charger. 18.3 X64 Cinnamon

Post by HellDragon » Fri Feb 16, 2018 10:22 am

Thank You for your help. I will stick to the 4.13 Kernel for now. I hope when Tara comes out the patches will be integrated into that kernel that arent in the mainline kernel yet.
Bye Bye Linuxmintusers.de :3 Welcome forums.linuxmint.com

Post Reply

Return to “Hardware Support”