How do I prevent my Microsoft LifeCam webcam from continuously autofocusing?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
jameskga
Level 3
Level 3
Posts: 190
Joined: Sat Jun 04, 2016 8:23 pm

How do I prevent my Microsoft LifeCam webcam from continuously autofocusing?

Post by jameskga » Tue Feb 20, 2018 3:47 am

The camera repeatedly, continuously autofocuses. Like it's never good enough! I just need it to autofocus once, and turn the feature off thereafter. I only use the webcam on Skype with my friend, who says the camera's built-in microphone pics up a frog-like sound every time the camera tries to refocus.

So it's annoying for both of us.

Anyone ever run into this problem before? I googled a fix, but could only find someone talking about Java. Basically Skype is the only thing I installed on this PC besides vanilla Linux Mint.
LMDE 2 Cinnamon (64-bit)
I am out there

User avatar
absque fenestris
Level 5
Level 5
Posts: 563
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: How do I prevent my Microsoft LifeCam webcam from continuously autofocusing?

Post by absque fenestris » Tue Feb 20, 2018 4:41 am

Excuse me!
But if you look like your avatar, Microsoft is trying the best possible :mrgreen:
Linux Mint 18.3 Sylvia (Mate) 32-bit - Acer D250 Netbook (Intel Atom N270, 2 GB RAM, 120 GB SSD)

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: How do I prevent my Microsoft LifeCam webcam from continuously autofocusing?

Post by Lucap » Tue Feb 20, 2018 4:47 am

Image

I know it doesn't fix the autofocus issue but have you looked through the sound settings to see if you can change the odd sound it is making?

Just a random idea unless someone has a specific fix.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: How do I prevent my Microsoft LifeCam webcam from continuously autofocusing?

Post by ClixTrix » Tue Feb 20, 2018 9:53 am

Try installing guvcview and see if there are any controls for autofocus from that app.

https://bbs.archlinux.org/viewtopic.php?id=211413
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-33-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Post Reply

Return to “Hardware Support”