trackpad not really off!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
bodhidharma
Level 1
Level 1
Posts: 11
Joined: Thu Aug 25, 2011 9:34 pm

trackpad not really off!

Post by bodhidharma » Thu Mar 01, 2018 4:20 pm

Does anyone know how to kill the trackpad *completely*?
I have a ThinkPad T450s, always run the latest Linux Mint.
I "turn off" the trackpad in Systems->Preferences->Hardware->Mouse .
Then it doesn't control the pointing at all.

BUT it's not completely off! When part of my hand is touching the trackpad, and I click the mouse button (between the space bar and trackpad), it often seems to take the click as a "click-and hold," not just a click. I say "often" because it seems to be hard to reproduce, it sometimes happens, sometimes not, seemingly dependent upon exactly how much of my hand is touching the trackpad.

Does anyone have any idea how to make sure the trackpad is completely, irrevocably *OFF*? I'm getting really frustrated, I think about prying the whole thing off with a screwdriver and cutting whatever wires I see....

thanks in advance!

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: trackpad not really off!

Post by all41 » Thu Mar 01, 2018 9:11 pm

how to make sure the trackpad is completely, irrevocably *OFF
You can probably do this using xinput.
In a terminal enter:

Code: Select all

xinput --list
In those results find your touchpad--it will have an ID number associated with it. Make a note of that number.
Then in a terminal:
xinput disable x
where x is the id number from the xinput --list results. Example: xinput disable 7
Try this out to see for certain it alleviates the interaction. This setting will get reset at next login, but a small script can
perform the disable command at startup. If you want to do this at every start you will use the actual xinput name of the touchpad as
opposed to it's id#.
If at any time you wish to revert the command you can enter in a terminal:

Code: Select all

xinput enable x
Proud to be a supporter and monthly contributor to Mint.

bodhidharma
Level 1
Level 1
Posts: 11
Joined: Thu Aug 25, 2011 9:34 pm

Re: trackpad not really off!

Post by bodhidharma » Thu Mar 01, 2018 10:30 pm

Thank you for taking the time to think about this!

Yeah, I've tried the xinput disable. It has no effect.
I've also tried turning it off in the BIOS. No effect.
I've also tried turning it off with Systems->Preferences->Hardware->Mouse. No effect.

That is, doing any one of those things make the trackpad not move the pointer, so I use the "trackpoint" (I guess that's what that little red rubber thingy between the g, h, and b keys is called.)

But with any of the above off settings, I *still* get the behavior that certain configurations of parts of my palm touching the trackpad make any click behave as if it were a "click and hold."
E.g., if I push the trackpoint around randomly in a block of text, randomly tapping on the mouse buttons (the actual buttons, between the space bar and the trackpad), with nothing touching the trackpad, the cursor just jumps to where the pointer is, each time. With just a bit of my left palm touching the trackpad, same behavior. With just the right amount of both palms touching the trackpad, as I move the trackpoint and click, sometimes randomly it starts highlighting large blocks of text, as if I were doing a click and hold.
I wonder if this drive has some weird bug to do with multitouch?

Anyway, thanks for the suggestion.

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: trackpad not really off!

Post by all41 » Thu Mar 01, 2018 11:40 pm

I just experimentally removed the touchpad driver (Synaptics in my case) using the package manager.
Ater log out/in the touchpad is totally disabled.
Note that this is a desktop using an external Logitech trackpad.
Not sure if this would be the same driver for your trackpoint knob though.
I used to hate a touchpad on a laptop--but finally came to grips with it.
But I really like using the Logitech as a poining device, it has a 5"x5" glass surface and is very accurate
and customizable.
Proud to be a supporter and monthly contributor to Mint.

bodhidharma
Level 1
Level 1
Posts: 11
Joined: Thu Aug 25, 2011 9:34 pm

Re: trackpad not really off!

Post by bodhidharma » Fri Mar 02, 2018 12:06 am

Hmm, interesting idea. Wouldn't that disable the buttons, too?

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: trackpad not really off!

Post by all41 » Fri Mar 02, 2018 12:20 pm

bodhidharma wrote:
Fri Mar 02, 2018 12:06 am
Hmm, interesting idea. Wouldn't that disable the buttons, too?
A good question--and one I did not test, so I repeated the driver removal again this morning--surprisingly the answer is no, in my case the buttons still function.
Proud to be a supporter and monthly contributor to Mint.

bodhidharma
Level 1
Level 1
Posts: 11
Joined: Thu Aug 25, 2011 9:34 pm

Re: trackpad not really off!

Post by bodhidharma » Fri Mar 02, 2018 12:47 pm

Thanks, I will definitely try this! I do worry about almost-bricking my machine, though, in the sense that without a working mouse button (which your evidence shows might not be an issue!), I might not be able to get focus into a useful window to reinstall the driver.

Presumably, though, an external (USB) mouse will still work, buttons and all, so I could reinstall using that.

... The issue that prompted me to start this thread is so intermittent and problematic that it is very frustrating. I think I wrote above that it doesn't happen unless there is some multitouch thing going on. But I don't know if that is exactly it, either! I'm wondering a little if it has to do with some trackpads have particular special functions along the edges, like scrollbars, etc. Perhaps I am inadvertently activating one of those, somehow? I notice the behavior very often when I'm typing in a text window on a website and suddenly a block of text gets highlighted because it has magically detected a click, or a click I did do has somehow been interpreted as a click-and-hold, so that moving the mouse highlighted all the text... then the next character I type gets interpreted as if I wanted to replace that whole highlighted block with that single character. It's horrible!

This is, anyway, definitely a "bug" in the driver, because when someone deactivates the trackpad in software, they definitely do not want any of the behavior I am experiencing.

Thanks again for your help, BTW!

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: trackpad not really off!

Post by all41 » Fri Mar 02, 2018 9:29 pm

I'm sure you are aware that you will have to log out and back in for the changes to be effective.
Proud to be a supporter and monthly contributor to Mint.

Post Reply

Return to “Hardware Support”