Page 1 of 1

Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Fri Mar 02, 2018 11:26 pm
by mantis8
I have an ancient Gigabyte motherboard GA-MA78GM-S2H (rev. 1.0) . It works fine with an AMD Athlon 64 x2 cpu 4200+ [2.2ghz]. I recently replaced the 4 gb of ram to four 2gb sticks of ram for 8gb total ram and that helped out a bit. I also wiped off my hdd and did a clean install of LM 18.3 64bit cinnamon & all the updates installed. I also upgraded the built-in video card to a cheapie $30 asus card that works fine too. So far, so good.

But the cpu is too slow, so I upgraded to the obsolete but still much faster AMD Phenom X4 9750 socket AM2+ CPU HD9750WCJ4BGH 2.4 GHz quad core 95W. I read through the mb manual and online and found that the cpu is fully supported. However, it wouldn't boot up; got past POST fine, but no video, so I figured that my current 500w PSU was too weak after all the upgrades, so I upgraded to a brand new corsair 750w power supply with artic silver thermo paste and brand new fancy cpu cooler rated at 150w, well over the new amd cpu TDP.

Strangely, the new PSU seems to make the whole computer run slow: all the fans seem to run slower and my video card temp went from 150 degrees with the old PSU down to 100 after installing a small fan on it [it was a silent fanless type] using the new PSU. I don't see how putting a small fan on it could drop the temp 50 degrees. Something seems wrong. On the new PSU, although the 24-pin connector installs ok on the mb, the wire colours aren't the same and where a gray wire is on the old PSU, its missing on the new PSU connector, so I'm suspicious that something isn't quite right.

When I first installed the new PSU, it has a 6-pin molex connector for the cpu, but my old cpu only has a 4-pin molex connector to match the 4-pin connector on the MB. I just used the 6-pin anyways, using only 4 out of the 6 pins, but my entire computer was dead when I tried to boot up. After checking it out, it turns out that the black & yellow wires are reversed from the 4 pin connector on the old PSU, but I didn't see that until it was too late. Apparently, the reverse polarity of the 12vdc fried my first AMD Phenom X4 9750 [a used one from ebay that was guaranteed not DOA], so I bought another used one off of ebay exactly the same.

Using the new PSU, I installed my old cpu back into the GB mb and it works fine, so apparently, the MB is ok . Then I installed the second amd phenom cpu. When I boot up, POST is fine, but once it tries to boot into LM, it gets stuck on the black screen with the flashing cursor. When I reinstall the older AMD cpu again, it works fine again.

I read online that maybe I need to update the BIOS on the mb, but not sure how. I removed the new phenom cpu and double-checked it: no bent pins, damage, etc.

Any help is greatly appreciated.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Sat Mar 03, 2018 9:44 am
by ClixTrix
I actually ran that board's later edition GA-MA78GM-S2HP (Rev. 2.0) as my office system until last month when I replaced it with the one in my sig. Built it back in early 2009. Ran Mint 17.3 for last 2 years.

Which BIOS release are you running? The chart on processor support says you need at least F3 BIOS. ... upport-cpu

Did you try running Memtest86+ with the new memory? The board can be a little picky with all 4 DIMM slots in use.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Sat Mar 03, 2018 3:49 pm
by mantis8
I did run a memtest, but it was only able to run on one 2gb bank for some reason. I will run a different test when I get a chance.

My bios is version 6. Support for the amd phenom didn't appear until version 10. I'm working on getting it flashed, but running into a lot of different issues. Because of my work schedule and *life*, not sure when I will be able to get back to it, but the old BIOS version does seem to be the issue.

I will give you an update when available. I would love to just chuck all my hardware out and replace it with semi-modern stuff, but on an extreme budget.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Mon Mar 05, 2018 2:56 pm
by mantis8

I got a brand new 16GB flash drive, formatted it to FAT and downloaded the latest non-beta bios update on the gigabyte website [f11] on my windows 10 box. Then I extracted the file to the flash drive - file name is: mb_bios_ga-ma78gm-s2h.f11 in the downloads folder, but in the flash drive after extraction, its ma78gs2h.f11

I also downloaded the exact same file on my linux box, extracted it to the same flash drive [ma78gs2h.bin].

I did double check to make sure this is the correct file for my motherboard.

I went into the bios, then the q flash utility and tried to update the bios. With the windows file, I get a "bios id check error" and on the linux version, I get "file incorrect size" error.

I'm not sure what to do next.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Tue Mar 06, 2018 9:38 am
by ClixTrix
ma78gs2h.f11 would be the file to load from Q-Flash.

When updating BIOS to add processor support, it's normally necessary to use a currently supported processor (not always but it can be a problem).

The Q-Flash guide is here. ... qflash.pdf

It's always best to reset and/or load Optimzed Defaults and Save BIOS before you flash. That's to avoid overclock or setting conflicts.

"bios id check error" suggests the BIOS is incorrect for the board.

Could you please run the following command from Terminal and post back the results.

Code: Select all

inxi -Fxz

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Tue Mar 06, 2018 1:53 pm
by mantis8
I ran that neat little command and found my problem on the very first line: I only had generic info before, but now this revealed a "u" in the mb model # that I didn't know before. So I downloaded the new bios file and it worked like a charm.

The only problem was that when I put in my quad core cpu, the computer wouldn't boot, so I removed it and found 4 bent pins, so I fixed them, dropped it back in, but then it still didn't boot up. After I put in the known good dual core cpu, my computer still didn't boot up, so somehow my mobo may have been fried, I don't know.

Looks like I will have to save up some money and just replace all the main components and start over.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Tue Mar 06, 2018 5:21 pm
by ClixTrix
Did you clear CMOS with power plug plugged when you swapped processors? If not, do that now and test.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Wed Mar 07, 2018 4:09 pm
by mantis8
I cleared the CMOS according to the GB user manual: ... us2h_e.pdf

* Always turn off your computer and unplug the power cord from the power outlet before
clearing the CMOS values.
• After clearing the CMOS values and before turning on your computer, be sure to remove
the jumper cap from the jumper. Failure to do so may cause damage to the motherboard.
• After system restart, go to BIOS Setup to load factory defaults (select Load Optimized
Defaults) or manually configure the BIOS settings (refer to Chapter 2, "BIOS Setup," for
BIOS configurations).

I even replaced the battery.

Still DOA.

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Wed Mar 07, 2018 4:22 pm
by ClixTrix
Try reverting to backup BIOS restore. ... therboards

Re: Cant boot with amd phenom cpu on legacy Gigabyte mb

Posted: Thu Mar 08, 2018 10:11 pm
by mantis8
I tried method # 1, but the computer never shut off, so I had to turn it off using the power switch on the back of the PSU, but it still never booted up again.

This computer doesn't have a reset button, so I can't use method #2.

I haven't gotten to method # 3 yet.