Monitor issues with Lenovo ThinkPad W540

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Boris
Level 1
Level 1
Posts: 21
Joined: Wed Mar 07, 2018 10:58 am

Monitor issues with Lenovo ThinkPad W540

Post by Boris » Wed Mar 07, 2018 12:17 pm

Hello all,

As my main computer I use Lenovo ThinkPad W540 (Nvidia Quadro K1100M, Intel® Core™ i7-4810MQ, 32GB of RAM, 512 SSD) and it's stock dock. I also have 2 external monitors attached Samsung U28E590D (3840x2160 pixels) and LG 29UM58 - P (2560x1080 pixels). The laptop stays on the table on the dock all the time. The laptop lid is closed always. As my primary screen I use Samsung monitor because it's 4k and I enable LG as need arises. Samsung is attached to display port on the dock. I would connect LG to the HDMI port on the dock also, but I can't get decryption screen (before login) to show unless on monitor attached to the laptop directly (Thunderbolt port). It's not setting of start screen in BIOS, I tried it. It's PITA but I can live with this. However, the exercise when I'm enabling and disabling the secondary monitor is becoming very annoying. The laptop lid is closed and the laptop screen is off, main/primary screen is Samsung 28" and in physical world it's right in front of my face, LG is secondary and off most of the time and it's mounted above Samsung because it's easier to me to move my eyes and look up and down than to have monitors inline and move my entire head left and right. So, when I need to use the secondary screen (LG), I go into "Displays" to enable it. For some reason the system never remember the previous settings and the secondary screen is always to the right from the primary rather than on the top. If I use Mint-Y-Dark theme, me moving LG above the primary and trying to position it is going to leave a trail of trajectory. Image This makes things much harder, so I decided to use the default system theme even that makes my work harder for my eyes, but there is problem too. Many times after placing the top monitor into the position and clicking on "Apply" system puts the top display (LG) inside the primary display (Samsung), and it does that over and over, sometimes 5 times in a row. Also, laptop's screen, which is off, jumps around and blocks me from positioning the secondary monitor in the place without playing around and arranging them as a toy. To me (Linux layman person as I am) it looks that the system is building (composing) the image (GUI) from the top left corner and that is the reason for all of these screen-arrangements troubles. Is there any way to make it happen from the bottom right? Maybe I'm wrong. Any help would be appreciated.

Lenovo ThinkPad W540 with it's dock
Nvidia Quadro K1100M
Intel® Core™ i7-4810MQ
32GB of RAM
512 SSD
Samsung U28E590D connected to the DP on the dock
LG 29UM58 - P connected to the thunderbolt on the laptop itself
Linux Mint 18.3 Sylvia 64-bit
Kernel Linux 4.13.0-36-generic x86_64
MATE 1.18.0
NVIDIA Driver Version: 384.111
Intel (R) Core (TM) i7-4810MQ intel-microcode version 3.20180108.0+really20170707ubuntu16.04.1

PS I was Windows fan since forever and knew my ways around. Couple months ago I switched to Linux, guess that makes me newbie. If you decide to jump in and help, please give step by step instruction, because I won't be able to make it work otherwise.

Thanks in advance.

Post Reply

Return to “Hardware Support”