Mouse clicks not detected on first boot

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
nECrOMaNCeD
Level 1
Level 1
Posts: 1
Joined: Fri Mar 09, 2018 10:41 pm

Mouse clicks not detected on first boot

Post by nECrOMaNCeD » Tue Mar 13, 2018 11:27 pm

Hello all. I searched quite awhile and didn't find a thread covering my issue. My apologies if I missed one.

I recently installed KDE 18.3. system specs and config are below. When I first boot into the desktop my mouse clicks, right or left, are not detected. Occasionally clicks will be detected for a couple seconds that drop off. Oddly, If I use the keyboard to log off and back on everything works fine. It's been many years since I've used Linux and haven't used Mint at all until now. I was hoping some kind soul had some insight before I start digging into drivers and such. Thanks in advance for any help provided.

Specs

AMD Ryzen 5 1600
Gigabyte GA-Gaming 3 B350 Mobo
16 GB Corsair DDR4 3200
Sapphire AMD R9 285 GPU
Corsair AX750 750W PSU
256Gb Western Digital NVME SSD (Windows boot drive)
Micron M500 2.5" SSD (Mint boot drive)
Grub boot loader

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Mouse clicks not detected on first boot

Post by ClixTrix » Wed Mar 14, 2018 7:56 am

Are you using PS/2 or USB Mouse? Same question for keyboard.

If USB, are you using the rear USB 2.0 port (black), or one of the USB 3.1 (blue Gen 1/red Gen 2)? Also, is the Mouse wireless?

If you're using the USB 2.0 port, does the mouse work in BIOS Setup?

Which BIOS version are you running? I've seen some bug problems reported with F22b, which is beta.
Last edited by ClixTrix on Wed Mar 14, 2018 8:12 am, edited 2 times in total.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-33-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Mouse clicks not detected on first boot

Post by Cosmo. » Wed Mar 14, 2018 8:01 am

Any chance to try another mouse? Do mouse moves get detected?

Post Reply

Return to “Hardware Support”