[SOLVED] Bluetooth pairs but sound plays through laptop

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
hotdog789
Level 1
Level 1
Posts: 7
Joined: Tue Mar 27, 2018 10:50 am
Location: USA

[SOLVED] Bluetooth pairs but sound plays through laptop

Post by hotdog789 »

OS version: Mint Mate 18.3 Sylvia 64 bit
Type of Bluetooth = Blueman Bluetooth Manager newest version 5.37-0ubuntu5.1
rfkill is the newest version (0.5-lumuntu3)
bluez-tools is the newest version (0.2.2 20140808-5)

I can pair my bluetooth headset "successfully" and hear a message that it's been connected. I can see it as being paired in the list of bluetooth devices in the blueman applet GUI. However, when I go to play audio the sound continues to come out of the laptop speakers. My laptop is dual boot and if I go in through Windows the headset works just fine so I know it's not the headset. The headset is a PLT_BBTPRO. Any ideas on how to resolve this?
Last edited by hotdog789 on Sat Mar 31, 2018 10:49 pm, edited 1 time in total.
User avatar
phd21
Level 19
Level 19
Posts: 9933
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Bluetooth pairs but sound plays through laptop

Post by phd21 »

Hi hotdog789,

Welcome to the wonderful world of Linux Mint and its excellent forum!

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

When I connect my Bluetooth in my Linux Mint KDE systems, I have to use the system volume control icon (click or right-click), or sound settings, or pulse audio volume control, to select which applications are using which sound devices, pick the application I want to listen to and tell it to use the Bluetooth device. I have to do this every time, even if I select the Bluetooth as the default device, but it is easy to do.

FYI: My ancient Bluetooth headset (one of the first) a Motorola HT820 with a microphone has 2 modes, Headset Unit HSP/HFP where microphone shows up (sound is good), and High fidelity Playback A2DP SInk with no microphone (sound is better than HSP/HFP?).


Hope this helps ...
KDE 18.3 Bluetooth
KDE 18.3 Bluetooth
KDE 18.3 Bluetooth
KDE 18.3 Bluetooth
KDE 18.3 Bluetooth
KDE 18.3 Bluetooth
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
hotdog789
Level 1
Level 1
Posts: 7
Joined: Tue Mar 27, 2018 10:50 am
Location: USA

Re: Bluetooth pairs but sound plays through laptop

Post by hotdog789 »

Thanks for the reply phd21,

Here are the screenshots. I don't think that I have the same sound controller as you --do.

--Original screenshots deleted--
Attachments
Soundcontrolmenu.png
Soundcontrolmenu.png (27.43 KiB) Viewed 430 times
Last edited by hotdog789 on Sat Mar 31, 2018 10:51 pm, edited 2 times in total.
User avatar
phd21
Level 19
Level 19
Posts: 9933
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Bluetooth pairs but sound plays through laptop

Post by phd21 »

Hi hotdog789,

You are welcome...

You are using Linux Mint Mate edition version 18.x, whereas I am using Linux Mint KDE 18.x, so there are some differences but it is close enough.

FYI-1: Normally, you would just highlight the results from the console terminal commands and then copy and paste those results back into the forum vs screenshots. But, the screenshots will work too.

On your Sound Preferences (Sound Settings) options, it would help to have screenshots of the other tabs, Hardware (Configuration), Input (microphone(s), etc...), Output (Speakers, Bluetooth, headset,etc...), Applications; Resize the windows if necessary to include all their options (the vertical scrollbar would usually disappear).

You will not see options in the Applications tab unless you are running applications that are playing sound, like a music application, browser, etc... In the one screenshot I had Audacious music player playing, and by default, it was using the default system sound board, so under the Application Tab I had to tell it to use the now available Bluetooth device.

If you look for (or install) Pulse Audio Volume Control, it will allow you to do this under its Playback (Applications) Tabs, if your Mate Sound Settings will not.

Tip: When taking screenshots, if you want to include list box or drop down menu items, you will want to set a time "delay" of around 7 seconds or more before the screenshot is taken to give you time to get to whatever it is you want a screenshot of and click any options; works for mouse-over pop-ups too. I highly recommend the "Ksnip" screenshot application.


Hope this helps ...
KDE Sound Settings
KDE Sound Settings
Pulse Audio Volume Control
Pulse Audio Volume Control
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
hotdog789
Level 1
Level 1
Posts: 7
Joined: Tue Mar 27, 2018 10:50 am
Location: USA

Re: Bluetooth pairs but sound plays through laptop

Post by hotdog789 »

Problem solved the easy way. I was curious about KDE so I installed it on my laptop and the Bluetooth works just fine right away after following your screenshots. Now I have Mate on my desktop and KDE on my laptop. Thanks!
User avatar
phd21
Level 19
Level 19
Posts: 9933
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Bluetooth pairs but sound plays through laptop

Post by phd21 »

Hi hotdog789,

I just wanted you to know, and any other Linux Mate users too, that I was able to easily connect my Bluetooth headset. It connects and works very similar to other Linux distros.

I was curious to see why you were having issues with Bluetooth, so I fully installed Linux Mint Mate 18.3 to a USB stick and with a couple minor differences, my Bluetooth headset worked almost like it does in KDE.

After putting any Bluetooth device like a headset into "pairing mode", then you click the Bluetooth icon in the system tray panel (or right-click that and open open Bluetooth manager), give it a moment to see your Bluetooth device, click that entry, and the settings pop-up dialog window comes up, just click the Connection Button to connect (might have to do it twice).

Under Sound Settings, Select Hardware Tab resize to see all, click your Bluetooth device like a headset and its profile mode, click Output Tab, click the Bluetooth device, and if it has a microphone you want click Input Tab and select that, close the Sound Settings Window.

In Mate, any sound applications I started after making the Bluetooth connection automatically worked with my Bluetooth selections under Sound Settings, whereas in KDE I had to select them per application.

Hope this Helps...
Mate Bluetooth
Mate Bluetooth
Mate Bluetooth
Mate Bluetooth
Mate Bluetooth
Mate Bluetooth
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
Post Reply

Return to “Hardware Support”