[SOLVED] Lenovo Yoga 720 - kernel 4.13.0-3X breaks touchpad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
JackD313
Level 1
Level 1
Posts: 7
Joined: Mon Feb 12, 2018 8:45 pm
Location: Ridley Park, PA USA

[SOLVED] Lenovo Yoga 720 - kernel 4.13.0-3X breaks touchpad

Post by JackD313 » Sat Apr 21, 2018 9:29 pm

Hello, all!
After initial install (18.3, Cinnamon) on a Lenovo Yoga 720 15-IKB, all is good - everything works great, including the touch pad.
I do the first set of (two) Mint updates, and then Update Manager presents the rest of the available updates. I run those, the touch pad still works, but then after a restart the touch pad doesn't work at all. Mouse and touch screen work fine, but nothing at all from the touch pad. I checked the touch pad settings, and it's switched on. I changed some touch pad settings (speed and sensitivity) to see if that did anything, but still nothing.

I reinstall from live USB and the touch pad works great again...until I run the updates and restart.

UPDATE: after a lot of troubleshooting (and a really valuable learning experience :D ) I figured out how to boot into a previous kernel (4.10). With the previous kernel, the touch pad works great. 4.13 breaks it. Not sure if there's something that can get around that, so uninstalled 4.13.0-38 and 4.13.0-39.


Hoping this can be fixed somehow so future kernel updates don't break it again.

-Jack

from inxi -Fxz
System: Host: lisa-lenovo-yoga Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: LENOVO product: 80X7 v: Lenovo YOGA 720-15IKB
Mobo: LENOVO model: Lenovo YOGA 720-15IKB v: SDK0J40709 WIN
Bios: LENOVO v: 4MCN22WW(V1.07) date: 06/22/2017
CPU: Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
clock speeds: max: 3800 MHz 1: 2833 MHz 2: 1700 MHz 3: 2714 MHz
4: 3039 MHz 5: 3148 MHz 6: 3198 MHz 7: 3284 MHz 8: 3194 MHz
Graphics: Card: Intel Device 591b bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.01hz
GLX Renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network: Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
driver: ath10k_pci bus-ID: 01:00.0
IF: wlp1s0 state: up mac: <filter>
Card-2: Atheros usb-ID: 001-002
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives: HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
Partition: ID-1: / size: 227G used: 7.9G (4%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: swap-1 size: 8.31GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 236 Uptime: 2 min Memory: 847.6/7708.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Post Reply

Return to “Hardware Support”