Mouse keys stops working after some time. Disabling and enabling brings it back

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
naven
Level 1
Level 1
Posts: 21
Joined: Fri Sep 30, 2016 6:24 am

Mouse keys stops working after some time. Disabling and enabling brings it back

Post by naven » Mon May 14, 2018 6:30 am

Hi,

I am using mouse keys to control my mouse with a keyboard sometimes. Turning it off and enabling again fixes the issue.

From time to time it stops working. I am not able to reproduce this issue .
This was also an issue in previous versions of LM.

Can you help me troubleshoot, please? What could be the issue here? What more information can I provide?
Also I'm not too sure if this is the right section, it kind of impacts hardware (mouse/keyboard)

Code: Select all

GE62-6QC naven # inxi -Fx
System:    Host: GE62-6QC Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Micro-Star product: GE62 6QC v: REV:1.0 serial: 9S716J532020ZFB000211
           Mobo: Micro-Star model: MS-16J5 v: REV:0.A serial: BSS-0123456789
           Bios: American Megatrends v: E16J5IMS.114 date: 04/29/2016
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20736
           clock speeds: max: 3500 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz 5: 800 MHz 6: 800 MHz
           7: 800 MHz 8: 800 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 960M] bus-ID: 01:00.0
           Display Server: X.org 1.18.4 driver: nvidia tty size: 238x69 Advanced Data: N/A for root
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: e0:94:67:14:06:0e
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 44:8a:5b:6f:eb:25
Drives:    HDD Total Size: 1275.3GB (11.6% used) ID-1: /dev/sda model: Crucial_CT275MX3 size: 275.1GB temp: 53C
           ID-2: /dev/sdb model: HGST_HTS721010A9 size: 1000.2GB temp: 43C
Partition: ID-1: / size: 236G used: 26G (12%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 472M used: 414M (93%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 17.05GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 63.0C mobo: 27.8C gpu: 0.0:54C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 324 Uptime: 5:26 Memory: 3708.9/15917.5MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

uname -a
Linux GE62-6QC 4.13.0-39-generic #44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Lin

naven
Level 1
Level 1
Posts: 21
Joined: Fri Sep 30, 2016 6:24 am

Re: Mouse keys stops working after some time. Disabling and enabling brings it back

Post by naven » Sat Jun 09, 2018 2:44 am

It seems to stop working after some of the reboots. Not every time though.

User avatar
wallyUSA
Level 4
Level 4
Posts: 460
Joined: Thu Jun 08, 2017 2:31 pm
Location: S.E. USA

Re: Mouse keys stops working after some time. Disabling and enabling brings it back

Post by wallyUSA » Sat Jun 09, 2018 5:58 am

naven wrote:
Sat Jun 09, 2018 2:44 am
It seems to stop working after some of the reboots. Not every time though.
Perhaps weak batteries (assuming it is wireless)?
Can you try a different mouse just to try to eliminate that device?
Tara Cinnamon 3.8.9 Kernel 4.15.0-39 (64 bit)
Please, if your query has been resolved, edit your first post and add [SOLVED] to the beginning of the subject line. This may help others find solutions.

naven
Level 1
Level 1
Posts: 21
Joined: Fri Sep 30, 2016 6:24 am

Re: Mouse keys stops working after some time. Disabling and enabling brings it back

Post by naven » Wed Jun 13, 2018 10:56 am

Mouse keys is not using a mouse. The whole point of mouse keys is to control mouse using your keyboard (see https://en.wikipedia.org/wiki/Mouse_keys). I am always using a wired keyboard.

Post Reply

Return to “Hardware Support”