Sound problem on one side of the laptop speakers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
synster
Level 1
Level 1
Posts: 1
Joined: Tue May 15, 2018 4:36 pm

Sound problem on one side of the laptop speakers

Post by synster » Tue May 15, 2018 4:45 pm

Hello all!

I've been installing few Linux OS but I never managed to make my audio hardware work well, in casual sound settings I'm able to do the beep test very well, I can hear fine on the left side of my laptop's built-in speakers, but whenever I play something be it Youtube or Twitch or whatever, the sound from left side speakers are muuuuch lower than right side

My laptop runs Linux Mint-Cinnamon 64 bit
This situation wasn't around when I was using Windows, it showed up right after I installed my very first Linux OS

here's inxi -A result:

Code: Select all

Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
and if it helps, I've got my aplay -l here:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC283 Digital [ALC283 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I tried alsamixer on Konsole and tried to volume up every bar, didn't help
I tried pavucontrol and fiddled with it, nope didn't help
I also tried to install Realtek drivers but the one page I found on internet wasn't helpful enough, besides, I had few issues with compiler so that didn't work either

Thanks!

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound problem on one side of the laptop speakers

Post by MrEen » Tue May 15, 2018 10:02 pm

Hi synster, and welcome to the forum.

Considering this seems to be happening in all Linux installs, it may very well be a hardware issue that just happened to coincide with the change. However we may be able to improve things some.

Open alsamixer again, make sure you're selecting the right sound card with F6, then make sure Master is all the way up. Now, use the right arrow to move to Speaker, then try a combination of hitting the q a bunch of times (to try raising the left volume) or hitting c a bunch (to lower the right volume) until you like the balance. It will help to have some music playing while you do this.

Hope this helps.

Post Reply

Return to “Hardware Support”