running of software rendering mode cinnamon is currently running without video hardware acceleration

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
jojopara
Level 3
Level 3
Posts: 175
Joined: Fri Jan 24, 2014 4:43 pm

running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by jojopara » Sun May 20, 2018 5:52 am

Hi,

Intel CPU Core i7 8700K
ASUS ROG MAXIMUS X HERO
be quiet! DARK ROCK PRO 4 BK022
CORSAIR 4x16GB 3000MHz DDR4
Samsung SSD 960 EVO NVMe 1tb

be quiet! SILENT BASE 600 Black with Window
be quiet! STRAIGHT POWER 11 750W

BenQ GW2765HT
Pure Wings 2 140mm x 2

Cinnamon DE. Message: 'running of software rendering mode cinnamon is currently running without video hardware acceleration ...'
It seems the fault is with Cinnamon as I have installed in Virtualbox Debian and Manjaro with Cinnamon and they both give this message. Ubuntu Mate is OK.

Please help!

Thank you.

User avatar
kc1di
Level 12
Level 12
Posts: 4372
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by kc1di » Sun May 20, 2018 6:26 am

please post the output of this terminal command

Code: Select all

inxi -Fxz
it will help us to help you.
post the output in code tags please </>
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
ClixTrix
Level 5
Level 5
Posts: 697
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by ClixTrix » Sun May 20, 2018 6:55 am

jojopara wrote:
Sun May 20, 2018 5:52 am
Cinnamon DE. Message: 'running of software rendering mode cinnamon is currently running without video hardware acceleration ...'
It seems the fault is with Cinnamon as I have installed in Virtualbox Debian and Manjaro with Cinnamon and they both give this message. Ubuntu Mate is OK.
You've mentioned VirtualBox. If you're running those Distros as Guests (including Mint) with Cinnamon, do you have 3D Acceleration Enabled in Display Settings for the Guest machines (in VB Manager). Also, did you install the Guest Addition after base install of the Virtual Machine, which is required for 3D Acceleration?

https://blogs.oracle.com/scoter/3d-acce ... -guests-v2
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-23-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

jojopara
Level 3
Level 3
Posts: 175
Joined: Fri Jan 24, 2014 4:43 pm

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by jojopara » Sun May 20, 2018 7:23 am

kc1di wrote:
Sun May 20, 2018 6:26 am
please post the output of this terminal command

Code: Select all

inxi -Fxz
it will help us to help you.
post the output in code tags please </>
Host: new Kernel: 4.13.0-41-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: ASUSTeK model: ROG MAXIMUS X HERO v: Rev 1.xx
Bios: American Megatrends v: 1003 date: 12/21/2017
CPU: Hexa core Intel Core i7-8700K (-HT-MCP-) cache: 12288 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 44352
clock speeds: max: 4700 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
4: 800 MHz 5: 799 MHz 6: 800 MHz 7: 800 MHz 8: 800 MHz 9: 800 MHz
10: 800 MHz 11: 800 MHz 12: 799 MHz
Graphics: Card: Intel Device 3e92 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
Resolution: 2560x1440@93.00hz
GLX Renderer: llvmpipe (LLVM 5.0, 256 bits)
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel Device a2f0 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.13.0-41-generic
Network: Card: Intel Ethernet Connection (2) I219-V
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 6001.2GB (98.2% used)
ID-1: /dev/nvme0n1 model: N/A size: 1000.2GB
ID-2: USB /dev/sda model: Transcend size: 2000.4GB
ID-3: USB /dev/sdb model: Transcend size: 2000.4GB
ID-4: USB /dev/sdc model: Transcend size: 2000.4GB
Partition: ID-1: / size: 193G used: 7.0G (4%) fs: ext4 dev: /dev/nvme0n1p1
ID-2: /home size: 193G used: 15G (9%) fs: ext4 dev: /dev/nvme0n1p3
ID-3: swap-1 size: 68.16GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 261 Uptime: 16 min Memory: 1436.8/64278.5MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

jojopara
Level 3
Level 3
Posts: 175
Joined: Fri Jan 24, 2014 4:43 pm

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by jojopara » Sun May 20, 2018 7:25 am

ClixTrix wrote:
Sun May 20, 2018 6:55 am
jojopara wrote:
Sun May 20, 2018 5:52 am
Cinnamon DE. Message: 'running of software rendering mode cinnamon is currently running without video hardware acceleration ...'
It seems the fault is with Cinnamon as I have installed in Virtualbox Debian and Manjaro with Cinnamon and they both give this message. Ubuntu Mate is OK.
You've mentioned VirtualBox. If you're running those Distros as Guests (including Mint) with Cinnamon, do you have 3D Acceleration Enabled in Display Settings for the Guest machines (in VB Manager). Also, did you install the Guest Addition after base install of the Virtual Machine, which is required for 3D Acceleration?

https://blogs.oracle.com/scoter/3d-acce ... -guests-v2

I use Linux Mint with Cinnamon DE. All others I have tried in VirtualBox.

User avatar
ClixTrix
Level 5
Level 5
Posts: 697
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by ClixTrix » Sun May 20, 2018 7:34 am

I see you're running the 4.13 kernel with Coffee Lake GPU. I would update to the 4.15 kernel in Update Manager or use the kernel parm per article.

https://www.phoronix.com/scan.php?page= ... L-No-Alpha
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-23-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

jojopara
Level 3
Level 3
Posts: 175
Joined: Fri Jan 24, 2014 4:43 pm

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by jojopara » Sun May 20, 2018 9:11 am

ClixTrix wrote:
Sun May 20, 2018 7:34 am
I see you're running the 4.13 kernel with Coffee Lake GPU. I would update to the 4.15 kernel in Update Manager or use the kernel parm per article.

https://www.phoronix.com/scan.php?page= ... L-No-Alpha

I updated to kernel 4.15.0.20 and cannot start Linux. I am trying to repair it; if there is no easy way, I will reinstall it. But the issue will remain.

Hoser Rob
Level 11
Level 11
Posts: 3853
Joined: Sat Dec 15, 2012 8:57 am

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by Hoser Rob » Sun May 20, 2018 9:20 am

It's not that hard to revert to a previous kernel. Actually, you should not update the kernel without knowing how to do this at CLI level unless something like this happens. It's not that unusual.

If you do a restart and hold down the Shift key (I read somewhere that it should be the left one and while I'm not 100% sure that's reliable it won;t hurt).. The Linux grub boot menu will appear. Just scroll to the previous one and continue booting.

To make the change permanent see:

viewtopic.php?t=262391

User avatar
ClixTrix
Level 5
Level 5
Posts: 697
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by ClixTrix » Sun May 20, 2018 9:25 am

There was a problem with the 4.15.0-20 kernel install that was resolved with service update to Mint Update. It's due to Ubuntu repackaging the kernel and will continue with all newer kernels.

That problem was a few weeks ago. Are you up to date with Mint service in Update Manager?

If that's not the problem and the 4.15.0-20 kernel won't work, you could try passing the parameter from Grub using Grub's edit feature for a test with the 4.13 kernel.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-23-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

jojopara
Level 3
Level 3
Posts: 175
Joined: Fri Jan 24, 2014 4:43 pm

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by jojopara » Sun May 20, 2018 10:53 am

Clixtrix,

What is this and how to do it? 'If that's not the problem and the 4.15.0-20 kernel won't work, you could try passing the parameter from Grub using Grub's edit feature for a test with the 4.13 kernel.'

I see you are with Cinnamon too and kernel 4.15.0.20. How does your system not crash?

Thank you!

User avatar
ClixTrix
Level 5
Level 5
Posts: 697
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by ClixTrix » Sun May 20, 2018 11:21 am

The only problem I'm aware of in install of the 4.15.0-20 kernel is due to the repackaging change from prior kernels and not having the latest edition of Mint Update installed from Update Manager to accommodate that change. Here's at least one thread on the problem from a few weeks back with Clem's comments at the end.

viewtopic.php?f=49&t=269028

It's always possible you're having other than that problem with your system. I was completely up to date with service when I installed the 4.15.0-20 kernel, including that fix to Mint Update.

If you want to try adding the i915.alpha_support=1 kernel parameter at boot for a test...... Use the "e" key from the Grub boot manager on a selection for kernel of choice and add that parameter in the line after "quiet splash". Much the same method as doing the nomodeset override, if you've ever used that trick. Here's a good guide.

http://linuxmint-installation-guide.rea ... tions.html
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-23-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung EVO 960 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
smurphos
Level 5
Level 5
Posts: 697
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: running of software rendering mode cinnamon is currently running without video hardware acceleration

Post by smurphos » Wed May 23, 2018 12:33 am

See viewtopic.php?f=59&t=261389

I wonder if it would help with kernel 4.15 to install the rest of the hwe graphics stack via apt install xserver-xorg-hwe-16.04 xserver-xorg-input-all-hwe-16.04. Several posters in the linked thread identified it as a necessary step to get the alpha support working with kernel 4.13.x

Post Reply

Return to “Hardware Support”