No sound from Logitech S-150 USB 2.0 Speakers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Siv
Level 1
Level 1
Posts: 5
Joined: Mon Jan 08, 2018 9:05 am

No sound from Logitech S-150 USB 2.0 Speakers

Post by Siv » Sun May 20, 2018 8:01 pm

Hi,

I have a friend who I have installed Linux Mint 18.3 Sylvia onto his Dell Precision 380 midi tower PC.

He has a Logitech S150 USB 2.0 speaker set that plugs in via the USB port. The audio seems to come in directly through the USB A port as there is no audio jack with them.

Strangely when I press the buttons on the front of the device to increase or decrease the volume an on-screen graphic comes up showing a volume bar so it appears the speakers are being seen by the system? however no sound comes out of them. I downloaded the Qasmixer application as in the past I have found the audio appears to be not working and when you install Qasmixer you find that the front speakers are turned off and you can use the sliders to get the volume up.

However on this system I can see two audio devices i.e. the inbuilt Dell audio and a USB Audio device but when I select it, it only offers me a master volume control and moving that does nothing.

Can anyone explain what is going wrong and what I need to do to fix it?

Siv

User avatar
MrEen
Level 6
Level 6
Posts: 1023
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound from Logitech S-150 USB 2.0 Speakers

Post by MrEen » Sun May 20, 2018 9:35 pm

Hi Siv. I just looked at those speakers on Amazon and saw this:
Review:
Works great in Windows and Linux.
I dual boot Windows7 and Linux Ubuntu. I couldn’t get them working in Linux, so I booted windows and they went right to work. Went back to Linux and tried again and they worked fine. No complaints, and they sound better than I expected for the price.
Sounds silly, but worth a shot.

Also, I've never used Qasmixer, but if you run alsamixer, select the sound card (USB Audio I'm guessing), you could see if anything there is muted (will show MM under the bar.)

Hope that helps.

Post Reply

Return to “Hardware Support”