I am unable to get nvidia drivers that work with the 120Hz

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Mon May 21, 2018 2:27 pm

Hi, everyone. :) I am on Linux Mint 18.3 Cinnamon, I have a laptop with a screen that is 1080p and 120hz. With a processor "Intel Core i7-7700HQ CPU @2.80Hz x 4" and a Geforce GTX 1050.
And I succeeded to have a nvidia drivers that can work with it, on Windows 10, but not on linux mint (I am on dual boot). The games I play have no limit of framerate because of that, on linux mint (on W10 they run normally, at 120fps). I tried to install several version of the Nvidia drivers (the latest was 396.24) but the result is always the same. I tried to follow guides that suggest to do stuff in the nvidia x server settings, like that :
https://cowboyprogrammer.org/2016/03/nv ... -on-linux/
But I don't have the same settings as them. I don't have the VBlank, Flipping and GSync options. I don't understand why. :( I tried to disable a lots of option with the windows since it seem important but it changes nothing.

deepakdeshp
Level 10
Level 10
Posts: 3362
Joined: Sun Aug 09, 2015 10:00 am

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by deepakdeshp » Tue May 22, 2018 11:43 am

A good link ... worth browsing full site.
https://sites.google.com/site/easylinuxtipsproject/12
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18.3 Cinnamon 64 bit with AMD processor . Memory 8GB

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Tue May 22, 2018 5:53 pm

Thanks for your answer deepakdeshp. But it seems that I have a problem that exceeds that simple tutorial. :/
When I install the 396 or even the 390 nvidia drivers and reboot, the screen stays black. And it's not like my screen is displaying a black screen, it is more like my screen is not lit up after linux mint has boot up. I searched what to do when I face a black screen after a reboot, on the site you posted. They said to update the grub file to put "nomodeset" on it. When I do that, the screen is not black anymore, my OS is displaying, but... every window takes like 1 second to show. As far as i understand all this, it is the X server that isn't starting when it should.
And besides, one of the reason why I am here at the start is because of a problem with VLC too :
https://forum.videolan.org/viewtopic.php?f=13&t=143707
VLC was sometimes crashing the graphical display of my OS from time to time. And the log clearly shows that the problem comes from the X server.
SO WHAT IS WRONG WITH THAT X SERVER ??? :cry: I don't get it at all. :(
I don't think reinstalling linux mint entirely would change anything since I had those two problems (the one with VLC, and the absence of framerate limitation on games), at the start of each of my previous reinstallations. I rather think it has to do with my component, especially that 120hz screen and maybe my processor ("Intel Core i7-7700HQ CPU @2.80Hz x 4", it is a "kaby lake" processor and it is supposed to be incompatible with any iterations of Windows other than Windows 10, so maybe it causes trouble with Linux distros too...). Like I said everything seems to be working fine on Windows 10, but I DON'T WANT to use that OS. :/
Edit : I finally reinstalled Linux Mint 18.3 Mate, aaaaaaand the result is the same. Black screen after a reboot, right after I install the 396 nvidia drivers.

Hoser Rob
Level 11
Level 11
Posts: 3842
Joined: Sat Dec 15, 2012 8:57 am

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by Hoser Rob » Wed May 23, 2018 8:18 am

You haven't posted enough system info, copy/paste this to the terminal and copy/paste the text output here:

Code: Select all

inxi -Fxz
And where do you get those drivers from?

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Wed May 23, 2018 9:38 am

Here is the output of the command you said, Hoser Rob :

Code: Select all

System:    Host: muleet-GP72M-7RDX Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: Micro-Star model: MS-1799 v: REV:1.0
           Bios: American Megatrends v: E1799IMS.321 date: 02/22/2018
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 899 MHz 2: 899 MHz 3: 899 MHz
           4: 1491 MHz 5: 899 MHz 6: 899 MHz 7: 899 MHz 8: 899 MHz
Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
           Card-2: NVIDIA Device 1c8d bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1920x1080@120.00hz
           GLX Renderer: GeForce GTX 1050/PCIe/SSE2
           GLX Version: 4.6.0 NVIDIA 396.24 Direct Rendering: Yes
Audio:     Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Intel Device 24fb driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 896.2GB (8.0% used)
           ID-1: /dev/sda model: TOSHIBA_THNSNJ25 size: 256.1GB
           ID-2: /dev/sdb model: TOSHIBA_MK6475GS size: 640.1GB
Partition: ID-1: / size: 23G used: 6.9G (32%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 126G used: 55G (46%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 5.74GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: 27.8C gpu: 0.0:36C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 240 Uptime: 3 min Memory: 1247.0/7899.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
And for your question, the way I get my drivers is the same as described in deepakdeshp's link. At least that's what I did for every of my last attempts. (I use the command line to get them from the PPA.)
I have reinstalled the nvidia drivers labelled 396.24, and this time it worked, I have no more blackscreen (and therefore I didn't had to use the nomodeset option). (I have no idea why it worked this time and not the others, but nevermind.) So I am back to where I started : I can't have drivers that deals with my 120Hz screen (the vlc problem and the framerate problem in games, are still there). The nvidia settings aren't showing Gsync as an option.
Last edited by Moem on Thu May 24, 2018 9:00 am, edited 1 time in total.
Reason: Swapped the quote tags out for code tags; the code tags retain some formatting that make your output easier to read.

User avatar
roblm
Level 8
Level 8
Posts: 2420
Joined: Sun Feb 24, 2013 2:41 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by roblm » Wed May 23, 2018 4:35 pm

Use these commands in the Terminal to see if the Vblank and GSYNC attributes are supported and accessible through the nvidia-settings command line:

nvidia-settings -q AllowGSYNC

nvidia-settings -q SyncToVBlank

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Wed May 23, 2018 8:56 pm

I tried those two commands, and here is the result :
Image
I don't know if it means that it worked or not. I tried to launch a game that has my framerate problem, and the problem was still there.
Last edited by Moem on Thu May 24, 2018 9:01 am, edited 1 time in total.
Reason: Adding the [rimg] tags (for remote images) makes your image appear directly inside the post.

User avatar
roblm
Level 8
Level 8
Posts: 2420
Joined: Sun Feb 24, 2013 2:41 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by roblm » Thu May 24, 2018 8:58 am

Those commands are not supposed to do anything but give info on whether your graphics card supports G-SYNC and Vblank. For example, if Vblank is supported and the nvidia-settings program is installed, then you should a message similar to this:
Attribute 'SyncToVBlank' (GF210-cin18.3:0.0): 1.
'SyncToVBlank' is a boolean attribute; valid values are: 1 (on/true) and 0
(off/false).
'SyncToVBlank' can use the following target types: X Screen.
However, your laptop has Hybrid Graphics (Integrated Intel and separate Nvidia card), so those attributes will probably not work, so they are not showing up in the Nvidia Settings utility.

Is there an option in the BIOS to select the Nvidia graphics instead of Hybrid Graphics?
Also, I think on some laptops those attributes may work when using an external monitor on the HDMI port, if available.

You can do a Google search to read articles on this matter, by typing something like: No G-Sync on laptop with hybrid graphics.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5705
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by Spearmint2 » Thu May 24, 2018 8:36 pm

what does this show?

Code: Select all

xrandr
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Fri May 25, 2018 11:47 am

Is there an option in the BIOS to select the Nvidia graphics instead of Hybrid Graphics?
I don't see one, here is all I have in the advanced settings, in case I missed something :
Image
Also, I think on some laptops those attributes may work when using an external monitor on the HDMI port, if available.
But the screen of my laptop really is a 120Hz. That would be weird if the drivers were inherently unable to use it. It would make no sense. Besides, on Windows 10 my games are running 120fps normally.
... Oh and I should add that the only way I had to make it work was to install a specific MSI software about the model of my computer itself (called GP72M 7RDX Leopard). The drivers of Nvidia alone were causing the same troubles I have on linux (framerate way too high on games). It was with a specific software called "MSI Dragon Center", only available on Windows 10 (and no other iterations of Windows). (As far as I understand, that's bad news for me... There may be no drivers at all for my case, available on linux.)
Thanks for you suggestion of research, by the way.

Spearmint2 > Here is the result of that command :

Code: Select all

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 381mm x 214mm
   1920x1080    120.00*+  59.93  
   1680x1050     84.94    74.89    69.88    59.95    59.88  
   1600x1024     60.17  
   1400x1050     85.00    74.76    70.00    59.98  
   1280x1024     85.02    75.02    60.02  
   1440x900      59.89  
   1280x960      85.00    60.00  
   1360x768      59.80    59.96  
   1152x864     100.00    85.06    85.00    75.00    75.00    70.00    60.00  
   1024x768      85.00    75.05    60.04    85.00    75.03    70.07    60.00  
   1024x768i     86.96  
   960x720       85.00    75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   960x600       60.00  
   832x624       74.55  
   960x540       59.99  
   800x600       85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25  
   840x525       85.02    74.96    69.88    60.01    59.88  
   800x512       60.17  
   700x525       85.08    74.76    70.06    59.98  
   640x512       85.02    75.02    60.02  
   720x450       59.89  
   640x480       85.09    60.00    85.01    72.81    75.00    59.94  
   720x400       85.04  
   680x384       59.80    59.96  
   640x400       85.08  
   576x432      100.11    85.15    85.09    75.00    75.00    70.00    60.06  
   640x350       85.08  
   512x384       85.00    75.03    70.07    60.00  
   512x384i      87.06  
   416x312       74.66  
   400x300       85.27    72.19    75.12    60.32    56.34  
   320x240       85.18    72.81    75.00    60.05  
   360x200       85.04  
   320x200       85.27  
   320x175       85.27  
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-2 disconnected (normal left inverted right x axis y axis)

User avatar
Spearmint2
Level 15
Level 15
Posts: 5705
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by Spearmint2 » Fri May 25, 2018 12:37 pm

Here you go, all the possible resolutions you could use with the HDMI ports, and plenty of refresh rates. Copy and past into a text file and then name it .xprofile and save to your user's name folder. Reboot then and should have all these available in Monitor GUI program.

Code: Select all

xrandr --newmode "1280x720_70.01"   88.25  1280 1352 1480 1680  720 723 728 752 -hsync +vsync
xrandr --addmode HDMI-1-1 1280x720_70.01
xrandr --newmode "1360x768_60.01"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
xrandr --addmode HDMI-1-1 1360x768_60.01
xrandr --newmode "1600x900_60.01"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-1-1 1600x900_60.01
xrandr --newmode "1920x1080_60.01"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode HDMI-1-1 1920x1080_60.01
xrandr --newmode "2560x1440_60.01"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
xrandr --addmode HDMI-1-1 2560x1440_60.01
xrandr --newmode "1280x720_75.01"   95.75  1280 1360 1488 1696  720 723 728 755 -hsync +vsync
xrandr --addmode HDMI-1-1 1280x720_75.01
xrandr --newmode "1360x768_75.01"  109.00  1360 1448 1584 1808  768 771 781 805 -hsync +vsync
xrandr --addmode HDMI-1-1 1360x768_75.01
xrandr --newmode "1600x900_75.01"  151.25  1600 1704 1872 2144  900 903 908 942 -hsync +vsync
xrandr --addmode HDMI-1-1 1600x900_75.01
xrandr --newmode "1920x1080_75.01"  220.75  1920 2064 2264 2608  1080 1083 1088 1130 -hsync +vsync
xrandr --addmode HDMI-1-1 1920x1080_75.01
xrandr --newmode "2560x1440_75.01"  397.25  2560 2760 3040 3520  1440 1443 1448 1506 -hsync +vsync
xrandr --addmode HDMI-1-1 2560x1440_75.01
xrandr --newmode "1280x720_100.01"  132.00  1280 1368 1504 1728  720 723 728 766 -hsync +vsync
xrandr --addmode HDMI-1-1 1280x720_100.01
xrandr --newmode "1360x768_100.01"  150.00  1360 1456 1600 1840  768 771 781 816 -hsync +vsync
xrandr --addmode HDMI-1-1 1360x768_100.01
xrandr --newmode "1600x900_100.01"  207.75  1600 1720 1888 2176  900 903 908 956 -hsync +vsync
xrandr --addmode HDMI-1-1 1600x900_100.01
xrandr --newmode "1920x1080_100.01"  302.50  1920 2072 2280 2640  1080 1083 1088 1147 -hsync +vsync
xrandr --addmode HDMI-1-1 1920x1080_100.01
xrandr --newmode "2560x1440_100.01"  542.25  2560 2776 3056 3552  1440 1443 1448 1527 -hsync +vsync
xrandr --addmode HDMI-1-1 2560x1440_100.01
xrandr --newmode "1280x720_120.01"  162.00  1280 1376 1512 1744  720 723 728 775 -hsync +vsync
xrandr --addmode HDMI-1-1 1280x720_120.01
xrandr --newmode "1360x768_120.01"  183.75  1360 1464 1608 1856  768 771 781 826 -hsync +vsync
xrandr --addmode HDMI-1-1 1360x768_120.01
xrandr --newmode "1600x900_120.01"  254.25  1600 1728 1896 2192  900 903 908 967 -hsync +vsync
xrandr --addmode HDMI-1-1 1600x900_120.01
xrandr --newmode "1920x1080_120.01"  369.50  1920 2080 2288 2656  1080 1083 1088 1160 -hsync +vsync
xrandr --addmode HDMI-1-1 1920x1080_120.01
xrandr --newmode "1280x720_70.01"   88.25  1280 1352 1480 1680  720 723 728 752 -hsync +vsync
xrandr --addmode HDMI-1-2 1280x720_70.01
xrandr --newmode "1360x768_60.01"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync
xrandr --addmode HDMI-1-2 1360x768_60.01
xrandr --newmode "1600x900_60.01"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode HDMI-1-2 1600x900_60.01
xrandr --newmode "1920x1080_60.01"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode HDMI-1-2 1920x1080_60.01
xrandr --newmode "2560x1440_60.01"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
xrandr --addmode HDMI-1-2 2560x1440_60.01
xrandr --newmode "1280x720_75.01"   95.75  1280 1360 1488 1696  720 723 728 755 -hsync +vsync
xrandr --addmode HDMI-1-2 1280x720_75.01
xrandr --newmode "1360x768_75.01"  109.00  1360 1448 1584 1808  768 771 781 805 -hsync +vsync
xrandr --addmode HDMI-1-2 1360x768_75.01
xrandr --newmode "1600x900_75.01"  151.25  1600 1704 1872 2144  900 903 908 942 -hsync +vsync
xrandr --addmode HDMI-1-2 1600x900_75.01
xrandr --newmode "1920x1080_75.01"  220.75  1920 2064 2264 2608  1080 1083 1088 1130 -hsync +vsync
xrandr --addmode HDMI-1-2 1920x1080_75.01
xrandr --newmode "2560x1440_75.01"  397.25  2560 2760 3040 3520  1440 1443 1448 1506 -hsync +vsync
xrandr --addmode HDMI-1-2 2560x1440_75.01
xrandr --newmode "1280x720_100.01"  132.00  1280 1368 1504 1728  720 723 728 766 -hsync +vsync
xrandr --addmode HDMI-1-2 1280x720_100.01
xrandr --newmode "1360x768_100.01"  150.00  1360 1456 1600 1840  768 771 781 816 -hsync +vsync
xrandr --addmode HDMI-1-2 1360x768_100.01
xrandr --newmode "1600x900_100.01"  207.75  1600 1720 1888 2176  900 903 908 956 -hsync +vsync
xrandr --addmode HDMI-1-2 1600x900_100.01
xrandr --newmode "1920x1080_100.01"  302.50  1920 2072 2280 2640  1080 1083 1088 1147 -hsync +vsync
xrandr --addmode HDMI-1-2 1920x1080_100.01
xrandr --newmode "2560x1440_100.01"  542.25  2560 2776 3056 3552  1440 1443 1448 1527 -hsync +vsync
xrandr --addmode HDMI-1-2 2560x1440_100.01
xrandr --newmode "1280x720_120.01"  162.00  1280 1376 1512 1744  720 723 728 775 -hsync +vsync
xrandr --addmode HDMI-1-2 1280x720_120.01
xrandr --newmode "1360x768_120.01"  183.75  1360 1464 1608 1856  768 771 781 826 -hsync +vsync
xrandr --addmode HDMI-1-2 1360x768_120.01
xrandr --newmode "1600x900_120.01"  254.25  1600 1728 1896 2192  900 903 908 967 -hsync +vsync
xrandr --addmode HDMI-1-2 1600x900_120.01
xrandr --newmode "1920x1080_120.01"  369.50  1920 2080 2288 2656  1080 1083 1088 1160 -hsync +vsync
xrandr --addmode HDMI-1-2 1920x1080_120.01
http://ezequielm.com/blog/xrandr-nvidia ... esolution/
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Sat May 26, 2018 12:19 pm

https://i.imgur.com/DOKBKFs.jpg
I did what you said and here's what I got right after the reboot (before the desktop was loaded).

User avatar
Spearmint2
Level 15
Level 15
Posts: 5705
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by Spearmint2 » Sat May 26, 2018 2:39 pm

That happens, means it saw it, will hopefully should settle down by next reboot. Did you finish the reboot, go into the Monitor settings area and see what resolutions you had available? Were they there or not? Did you choose one of them if there? Did you set it as the default? It's possible it needs a section for the eDP made and added to the .xprofile too.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Sat May 26, 2018 3:59 pm

Spearmint2 > I rebooted several times since I created that file you said and that error was always there.
And I have to say that I don't really understand what is the purpose of that file, I already have access to every resolutions I want for my display (and it is selected as 1920x1080p + 120Hz (even though sometimes I try to put it at 60Hz to see if my games can run at 60fps, which is not the case)). So I don't get what should be new with that file. My problem is not to be able to have 1920x1080p +120Hz, it is to have it AND that VLC doesn't crash my graphical display (because of the X server, like it was said in a log that can be found the VLC thread that I posted earlier) and that my games are running at 120fps (or even 60, but not 300 to 5000 like right now). So, to answer your question, yes the resolution are available, but like I said, they already were.
And thanks for you answer.

User avatar
roblm
Level 8
Level 8
Posts: 2420
Joined: Sun Feb 24, 2013 2:41 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by roblm » Sat May 26, 2018 4:37 pm

muleet wrote:But the screen of my laptop really is a 120Hz. That would be weird if the drivers were inherently unable to use it.
It's not a question of whether the laptop's screen supports a 120 Hz refresh rate, but how the video image is processed. When the Nvidia GPU is selected in your hybrid graphics (Optimus) system, it does the initial processing (rendering) of the image. This data is sent to the Intel GPU because it is physically connected to the laptop's internal panel, which then displays the image onto the screen. So even though the GeForce GTX 1050 GPU does support G-SYNC technology, the Intel GPU does not and it has the final control over the displayed image. Evidently some higher end or gaming laptops allow the Nvidia GPU more control over the final image. Or the Nvidia GPU may have more final image control over an HDMI or DisplayPort output which is internally physically connected to it.

An alternative solution would be a frame limiter program, as described in this link, but I have no experience with it:
https://github.com/torkel104/libstrangle
Last edited by roblm on Sat May 26, 2018 10:01 pm, edited 1 time in total.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5705
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by Spearmint2 » Sat May 26, 2018 9:25 pm

muleet wrote:
Sat May 26, 2018 3:59 pm
Spearmint2 > I rebooted several times since I created that file you said and that error was always there.
And I have to say that I don't really understand what is the purpose of that file, I already have access to every resolutions I want for my display (and it is selected as 1920x1080p + 120Hz (even though sometimes I try to put it at 60Hz to see if my games can run at 60fps, which is not the case)). So I don't get what should be new with that file. My problem is not to be able to have 1920x1080p +120Hz, it is to have it AND that VLC doesn't crash my graphical display (because of the X server, like it was said in a log that can be found the VLC thread that I posted earlier) and that my games are running at 120fps (or even 60, but not 300 to 5000 like right now). So, to answer your question, yes the resolution are available, but like I said, they already were.
And thanks for you answer.
I misunderstood then. You can rename the file, or add an extension, save for any future need.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Mon Jun 04, 2018 2:31 pm

I realized that I can't use a frame limiter either : the fans of my components tends to go too high on linux even when nothing is launched, simply because the drivers aren't able to manage the fans as they are made. While on Windows 10 the fans are perfectly silent most of the time when I simply use a browser or watch a video. I really can't use linux without good drivers adapted to my components. :( I searched on the web with your suggestion, roblm, but nothing was relevant to my problem (as far as I understood it). If anybody has another idea I'm listening.

User avatar
roblm
Level 8
Level 8
Posts: 2420
Joined: Sun Feb 24, 2013 2:41 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by roblm » Wed Jun 06, 2018 8:06 am

Try this method. Use this command to create a 20-intel.conf file in /usr/share/X11/xorg.conf.d:

Code: Select all

gksudo xed /usr/share/X11/xorg.conf.d/20-intel.conf
In the opened empty file, add these lines:

Code: Select all

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "TearFree"    "true"
EndSection
Log out and back in.

If that doesn’t help, then use this command and check the FPS: glxgears

Then see if the FPS is affected by using these commands, one at a time, followed by glxgears:

Code: Select all

export VBLANK_MODE=0
export VBLANK_MODE=1
export VBLANK_MODE=2
For the VLC problem, open the program and go to Tools > Preferences > Video. Next to Output will be a drop-down menu. You can test these options, starting with X11 video output. Some of the other options require the Accelerated video output setting be disabled. I forgot which ones, so they will have to be tested both with and without Accelerated video output enabled.

muleet
Level 1
Level 1
Posts: 14
Joined: Wed Mar 07, 2018 1:38 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by muleet » Wed Jun 06, 2018 1:59 pm

Thanks again for your answer roblm.

During your first method, I was unable to log out, the screen was black with a "_" at the top left corner. I rebooted with a ctrl+alt+F3, and my OS couldn't start normally the screen was again black with the "_" in the top left corner. So I went in the recovery mode to suppress the file and then I rebooted normally, and was able to get back. (Note that the file also changed the position of the panel bar, it moved it from the bottom to the top of the screen.)

For your second method, the glxgears allowed me to know that my computer runs at 8000fps. That's not very reassuring for the health of my computer...
Here is the result :

Code: Select all

muleet@muleet-GP72M-7RDX ~ $ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
40213 frames in 5.0 seconds = 8042.588 FPS
muleet@muleet-GP72M-7RDX ~ $ export VBLANK_MODE=0
muleet@muleet-GP72M-7RDX ~ $ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
38555 frames in 5.0 seconds = 7710.986 FPS
muleet@muleet-GP72M-7RDX ~ $ export VBLANK_MODE=1
muleet@muleet-GP72M-7RDX ~ $ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
39988 frames in 5.0 seconds = 7997.542 FPS
muleet@muleet-GP72M-7RDX ~ $ export VBLANK_MODE=2
muleet@muleet-GP72M-7RDX ~ $ glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
40947 frames in 5.0 seconds = 8189.141 FPS
Thanks for your suggestion for VLC, though I don't know the exact reasons of the graphical freeze so I'm not able to test it now. I'll just have to wait and see if I have another freeze.

User avatar
roblm
Level 8
Level 8
Posts: 2420
Joined: Sun Feb 24, 2013 2:41 pm

Re: I am unable to get nvidia drivers that work with the 120Hz

Post by roblm » Wed Jun 06, 2018 2:59 pm

muleet wrote:
Wed Jun 06, 2018 1:59 pm
During your first method, I was unable to log out, the screen was black with a "_" at the top left corner.
I don’t remember reading that happening to other users, but they may all have been using Mint 17.x. It’s a common fix for screen tearing when using the Intel driver. That’s why I didn’t include any recovery instructions.

muleet wrote:
Wed Jun 06, 2018 1:59 pm
For your second method, the glxgears allowed me to know that my computer runs at 8000fps.
That high FPS is due to rendering a very simple 3D animation in a small window. If you switch to full screen, then the FPS will drop significantly.

Try these commands:

Code: Select all

vblank_mode=0 glxgears		
vblank_mode=2 glxgears
If those have no effect on the FPS, then try these, followed by running glxgears:

Code: Select all

export __GL_SYNC_TO_VBLANK=0	
export __GL_SYNC_TO_VBLANK=1
Last edited by roblm on Wed Jun 06, 2018 6:51 pm, edited 1 time in total.

Post Reply

Return to “Hardware Support”