Toshiba Satellite M645: Headphone Jack and Bluetooth

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
cc0713
Level 1
Level 1
Posts: 5
Joined: Sat May 26, 2018 12:00 pm

Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by cc0713 » Sat May 26, 2018 12:05 pm

I've got a Toshiba Satellite M645 with a fresh Mint install. Laptop speakers work but the headphone jack doesn't. Bluetooth is not working. Any help getting these going would be greatly appreciated.

JeremyB
Level 19
Level 19
Posts: 9044
Joined: Fri Feb 21, 2014 8:17 am

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by JeremyB » Sat May 26, 2018 12:22 pm

Post results from terminal for

Code: Select all

inxi -Fxz; lsusb; dmesg | egrep -i 'blue|firm'; lspci -nnk | egrep -i 'net|audio|sound'
I have a M645 but it didn't come with bluetooth and the headphone jack works fine

cc0713
Level 1
Level 1
Posts: 5
Joined: Sat May 26, 2018 12:00 pm

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by cc0713 » Sat May 26, 2018 1:27 pm

Thanks for the reply. The laptop is new to me. It dawned on me when I read your reply that it may not have Bluetooth. I did not use it before installing Mint so I have no idea what was working under windows.

The laptop speakers work but when I plug something into the headphone jack, the laptop speakers do not mute and there is no sound in the headphones. I guess there is a chance the jack is shorted but I was hoping that I just need to install a driver.
Host: box-13 Kernel: 4.13.0-43-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: TOSHIBA product: Satellite M645 v: PSMPBU-009001
Mobo: TOSHIBA model: NBQAA v: 1.00
Bios: TOSHIBA v: 1.30 date: 07/05/10
CPU: Dual core Intel Core i3 M 350 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9046
clock speeds: max: 2266 MHz 1: 1183 MHz 2: 1158 MHz 3: 1114 MHz
4: 1147 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile
GLX Version: 2.1 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 7000 bus-ID: 01:00.0
IF: enp1s0 state: down mac: <filter>
Card-2: Realtek RTL8191SEvB Wireless LAN Controller
driver: rtl8192se port: 5000 bus-ID: 06:00.0
IF: wlp6s0 state: up mac: <filter>
Drives: HDD Total Size: 500.1GB (3.0% used)
ID-1: /dev/sda model: Hitachi_HTS54505 size: 500.1GB
Partition: ID-1: / size: 455G used: 11G (3%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.08GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 65.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 195 Uptime: 4:00 Memory: 870.7/3741.7MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b1d6 Chicony Electronics Co., Ltd CNF9055 Toshiba Webcam
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[ 0.081238] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[ 1.604432] [Firmware Bug]: battery: (dis)charge rate invalid.
Loading firmware rtlwifi/rtl8192sefw.bin
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
Subsystem: Toshiba America Info Systems 5 Series/3400 Series Chipset High Definition Audio [1179:fd80]
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 05)
Subsystem: Toshiba America Info Systems RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [1179:fd80]
06:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172] (rev 10)

JeremyB
Level 19
Level 19
Posts: 9044
Joined: Fri Feb 21, 2014 8:17 am

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by JeremyB » Sat May 26, 2018 2:51 pm

There doesn't appear to be a bluetooth chipset in the laptop. Go into Sound Settings/Output and see if the headphones are shown after plugging in

cc0713
Level 1
Level 1
Posts: 5
Joined: Sat May 26, 2018 12:00 pm

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by cc0713 » Sat May 26, 2018 6:24 pm

JeremyB wrote:
Sat May 26, 2018 2:51 pm
There doesn't appear to be a bluetooth chipset in the laptop. Go into Sound Settings/Output and see if the headphones are shown after plugging in
I can live without Bluetooth.

When I plug headphones in, they do not show up in the sound settings output. Only the speakers show up.

The headphone jack isn't dead though. When I plug it in it makes the normal amount of "noise" on the laptop speakers, e.g. a small amount of very light static noise.

JeremyB
Level 19
Level 19
Posts: 9044
Joined: Fri Feb 21, 2014 8:17 am

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by JeremyB » Sun May 27, 2018 9:31 am

I only hear noise on my speakers if I plug the headphones into the microphone jack. The headphone jack on mine is the one closer to the front of the laptop

cc0713
Level 1
Level 1
Posts: 5
Joined: Sat May 26, 2018 12:00 pm

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by cc0713 » Sun May 27, 2018 8:32 pm

JeremyB wrote:
Sun May 27, 2018 9:31 am
I only hear noise on my speakers if I plug the headphones into the microphone jack. The headphone jack on mine is the one closer to the front of the laptop
Same here. Headphone jack on the right front.

When I plug headphones in, I get a little noise on the laptop speakers.

Thanks for the help BTW.

cc0713
Level 1
Level 1
Posts: 5
Joined: Sat May 26, 2018 12:00 pm

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by cc0713 » Mon May 28, 2018 12:30 pm

One other thing that isn't 100% with the sound is that the volume on the laptop speakers isn't loud enough and the master volume control and the Media Player volume control are the same.

JeremyB
Level 19
Level 19
Posts: 9044
Joined: Fri Feb 21, 2014 8:17 am

Re: Toshiba Satellite M645: Headphone Jack and Bluetooth

Post by JeremyB » Mon May 28, 2018 12:35 pm

Check alsamixer settings in terminal and see if the headphones are ignored or muted in those settings. I think the only time I had any issues with sound on mine in Linux Mint is when I installed a pulseaudio mixer program

Post Reply

Return to “Hardware Support”