No sound on Linux Mint 18.3

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Wed Jun 20, 2018 11:44 am

All done, to no avail. No changes. Soooo weird...

User avatar
trytip
Level 7
Level 7
Posts: 1657
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound on Linux Mint 18.3

Post by trytip » Wed Jun 20, 2018 12:20 pm

delete the .cache folder entirely then create a new .cache folder and reboot. after reboot run find $HOME ! -user $USER again
Image

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Wed Jun 20, 2018 12:41 pm

trytip wrote:
Wed Jun 20, 2018 12:20 pm
delete the .cache folder entirely then create a new .cache folder and reboot. after reboot run find $HOME ! -user $USER again
Done, no change - but thank you.

Currently going to run a live session of LM 19 beta to see if that improves anything...

User avatar
trytip
Level 7
Level 7
Posts: 1657
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound on Linux Mint 18.3

Post by trytip » Wed Jun 20, 2018 1:12 pm

not sure why cinnamon still has this issue find: ‘/home/rob/.cache/dconf’: Permission denied maybe try a different desktop
Image

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Wed Jun 20, 2018 1:30 pm

trytip wrote:
Wed Jun 20, 2018 1:12 pm
not sure why cinnamon still has this issue find: ‘/home/rob/.cache/dconf’: Permission denied maybe try a different desktop
Interesting you say that - going to live boot MATE

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Wed Jun 20, 2018 5:46 pm

At this point my soundcard isn't detected by any version of LM I try...so shall I assume it's just unsupported at this point?

User avatar
MrEen
Level 5
Level 5
Posts: 822
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Wed Jun 20, 2018 8:10 pm

Try this first. In pavucontrol Configuration tab select Analog Stereo Duplex (unplugged) then in the Output Devices tab select headphones (unplugged) or speakers as appropriate.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Thu Jun 21, 2018 9:42 am

MrEen wrote:
Wed Jun 20, 2018 8:10 pm
Try this first. In pavucontrol Configuration tab select Analog Stereo Duplex (unplugged) then in the Output Devices tab select headphones (unplugged) or speakers as appropriate.
Unfortunately, the configuration tab shows "no cards available for configuration."

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Thu Jun 21, 2018 12:43 pm

Further complicating things, aplay -l now shows No soundcards found...

User avatar
MrEen
Level 5
Level 5
Posts: 822
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Thu Jun 21, 2018 5:40 pm

Damn. We went in the wrong direction. See if this gets the card recognized again:

Code: Select all

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Fri Jun 22, 2018 6:21 am

MrEen wrote:
Thu Jun 21, 2018 5:40 pm
Damn. We went in the wrong direction. See if this gets the card recognized again:

Code: Select all

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload
Done. Now, aplay -l reflects what it did previously:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
However, still no devices in the configuration tab of pavucontrol. Same "dummy output" as normal.

In addition, in alsa-base.conf, we've added the line options snd-hda-intel model=auto at the end. However, snd-hda-intel isn't "indexed" anywhere in the file. Not sure if this matters or not!

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto

User avatar
MrEen
Level 5
Level 5
Posts: 822
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Fri Jun 22, 2018 6:52 am

Try changing that last line to

Code: Select all

options snd-hda-intel probe_mask=1 model=hp
I should have had you try hp sooner, and the probe_mask may help.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Fri Jun 22, 2018 6:58 am

MrEen wrote:
Fri Jun 22, 2018 6:52 am
Try changing that last line to

Code: Select all

options snd-hda-intel probe_mask=1 model=hp
I should have had you try hp sooner, and the probe_mask may help.
Done; no change, but aplay -l once again shows no soundcards found. Reverting....

User avatar
MrEen
Level 5
Level 5
Posts: 822
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Fri Jun 22, 2018 7:06 am

Crap! Sorry, I'm basically out of ideas. The only option I can think of is upgrading alsa

If you decide to try this, when following the directions, get the .deb for Artful if you're using a 4.13 kernel (xenial only works with a 4.4 kernel and there's nothing there yet for kernels newer than 4.13.)

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Fri Jun 22, 2018 7:15 am

MrEen wrote:
Fri Jun 22, 2018 7:06 am
Crap! Sorry, I'm basically out of ideas. The only option I can think of is upgrading alsa

If you decide to try this, when following the directions, get the .deb for Artful if you're using a 4.13 kernel (xenial only works with a 4.4 kernel and there's nothing there yet for kernels newer than 4.13.)
You know, I had done this previously, but assumed I would need to use Xenial. Purged and tried Artful, no change.

I'm still digging in! Frustrating as nearly everything else is running wonderfully!

User avatar
trytip
Level 7
Level 7
Posts: 1657
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound on Linux Mint 18.3

Post by trytip » Fri Jun 22, 2018 9:37 am

you say there is no sound at all in any live linux mint? have you tested with other live distros? antergos xfce is pretty much the best you can get these days as out of the box complete and recent software/hardware support. see if that will detect your card
Last edited by trytip on Fri Jun 22, 2018 10:18 am, edited 1 time in total.
Image

CaptainChaos
Level 1
Level 1
Posts: 7
Joined: Tue Jul 14, 2015 4:42 am

Re: No sound on Linux Mint 18.3

Post by CaptainChaos » Fri Jun 22, 2018 10:13 am

robluck82 wrote:
Fri Jun 22, 2018 7:15 am
I'm still digging in! Frustrating as nearly everything else is running wonderfully!
You're not the only one with sound issues...

Please keep us up-to-date on anything you discover.

Meanwhile, I suppose that I'll just have to carry on playin' War Thunder in silence. :(

Regards,

Mark.

User avatar
MrEen
Level 5
Level 5
Posts: 822
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on Linux Mint 18.3

Post by MrEen » Fri Jun 22, 2018 4:34 pm

I've never used this, so I don't know if it can offer any help whatsoever, but maybe give this a shot. Download alsa-tools-gui via Software Manager or apt install alsa-tools-gui, then run hdajackretask and see if anything in there might help.

EDIT: Also,
MrEen wrote:
Fri Jun 22, 2018 5:01 pm
Have you tried shutting the computer down completely (not reboot?)

Also, if this is a dual boot with Windows, and I know this will sound stupid, boot to Windows and make sure sound isn't muted there, then shut down completely, then power on and boot back into Mint. If still nothing, then reboot Mint.

Good luck.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 23, 2018 9:13 am

UPDATE!!! We're so close everyone!

OK, messed around with some Jack settings, none of which appeared to have any effect.

Booted into Windows (thanks Mr. Een, I was about to feel really stupid if for some reason I muted Windows volume). Volume in Windows was NOT muted...but I double checked some settings and on a whim enabled "Spatial sound" or virtual 7.1 surround sound. Exited Winblows and booted into LM.

OK - NOW I have something. Sound settings now shows "Speakers Built-in Audio" AND I even have an output profile of "Analog Stereo Output" sound tests still show no sound.

PAVUCONTROL now shows "Built-in Analog Stereo" Port: Speakers under OUTPUT DEVICES. It also shows under port "Headphones (unplugged) On the configuration tab, I now have FOUR profiles from which to choose:
  • Analog Stereo Duplex
  • Analog Stereo Output
  • Analog Stereo Input
  • Off
I also have a working MICROPHONE...so we are getting somewhere! As of right now I still don't have audible sound, but we are SO CLOSE. I hesitate to touch anything because I know it's one dumb setting somewhere....
.

EDIT: Running alsamixer -c 1 WORKS but nothing is muted...
Last edited by robluck82 on Sat Jun 23, 2018 11:08 am, edited 3 times in total.

robluck82
Level 1
Level 1
Posts: 21
Joined: Thu Jun 14, 2018 5:55 pm

Re: No sound on Linux Mint 18.3

Post by robluck82 » Sat Jun 23, 2018 9:20 am

Also, while in Windows, I noticed the audio driver was for "Conexant HD Audio." That being said, I also see that aplay -l now shows:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: CX20753/4 Analog [CX20753/4 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
So I assume that my CHIPSET is "CX20753/4 Analog". So, I then found this link: https://www.linuxant.com/alsa-driver/. However, it appears pretty old so I'm going to hold off for now.

Post Reply

Return to “Hardware Support”