[SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

[SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Sun Jun 17, 2018 1:48 pm

HI,
I have a laptop Mint/VB/Win7-64B.
All works very well. The only issue is that I'm not able to install the correct driver in that W7 part. In Mint all is OK.
In (VirtualBox)Windows I'm running now a W7 standard driver. But the software I did install in W7 needs the correct driver to run smoothly.
This machine HP Probook 470 G0 there are 3 drivers available on HP's site. Non of them works, different error messages.

Strange thing is that when installing only W7 on that laptop, these same drivers can be installed effortless. How is that possible..?

Chris
Last edited by Chriske on Tue Jun 19, 2018 2:30 am, edited 1 time in total.

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Sun Jun 17, 2018 3:40 pm

The correct driver for video in a VirtualBox Guest is installed using Guest Additions. VB provides its own driver.

https://www.virtualbox.org/manual/ch04. ... ns-windows
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Sun Jun 17, 2018 4:19 pm

You're saying there's nothing I can do, or is there away to solve this problem...??

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Sun Jun 17, 2018 4:37 pm

I'm saying that installation of the Guest Additions which is bundled in VirtualBox is the solution. A virtual machine talks to the real machine host hardware with special drivers, in general.

You should see the Guest Additions CD as insert-able from the Devices drop-down menu at the top of the running guest machine. It's part of the normal install for all guest machines in VirtualBox. Treat the inserted CD processes like you just loaded a real CD with drivers from a real machine and respond to running the setup. The setup with CD should autostart.
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Sun Jun 17, 2018 6:40 pm

Problem is I do not have the original software that comes with this laptop. The original disk with the recovery partition is gone. This is another HD in my laptop.
So how do I proceed to get that correct driver into that W7..?

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Sun Jun 17, 2018 7:39 pm

How about a video that shows how to install the Guest Additions for a Windows 7 guest on VB?

https://www.youtube.com/watch?v=vi53zKcvgXU
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
jimallyn
Level 18
Level 18
Posts: 8469
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by jimallyn » Sun Jun 17, 2018 9:05 pm

Chriske, when you run an OS in a virtual machine, it is just that - virtual. The guest OS can't see the computer's real hardware at all. All it sees is the virtual hardware that the host presents to it. So, the drivers on the original disk are useless to you, as are any drivers you might download from HP. The drivers that will be useful to you are the ones in the Guest Additions provided by VirtualBox.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Mon Jun 18, 2018 3:11 am

That is probably the reason why I got this error messages during driver install in virtual-W7.
So I'm stuck...dam...

I'd rather not work with a dual boot. It's most helpful to me to switch between Mint and W7 on the fly.
There' always the possibility to work with a second laptop and use TeamViewer.

User avatar
catweazel
Level 17
Level 17
Posts: 7756
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by catweazel » Mon Jun 18, 2018 3:23 am

Chriske wrote:
Mon Jun 18, 2018 3:11 am
So I'm stuck...dam...
You've been told several times now that you need to install the guest additions.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Mon Jun 18, 2018 4:09 am

Well, now I did, sorry but I'm not an expert (yet.. :wink: ) I'm new to Linux. It's only two weeks now I'm experimenting adn trying. Most of the PC's I installed Linux so far were rather straightforward. This one is the first Laptop with VB installed. Didn't know what to expect.
Anyway after downloading and installing Guest Additions something changed. Colour-scheme got better, but I'm not in Direct3D graphics modus yet.
I tried to add Direct3D during Guest Additions install but I need to boot W7 in safe modus to allow installing Direct3D.
I'll do that first, Ill think I'm on the right track, thanks to you all...!

About that Guest Additions install, it was only when I saw that youtube movie that it all got clear in my mind... :lol:
Maybe, just maybe I'm getting to old for this stuff...
Sorry again for my ignorance guys... :oops:

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Mon Jun 18, 2018 4:07 pm

Ran Guest Additions. After that resolution got a little better(resolution) but still no Direct3D. During attempt to install Direct3D VB advised me to do so in safe modus.
After reboot in Safe modus Guest Additions refused to run.
After that I discovered that the '3D acceleration' in the VirtualBox settings itself was not enabled. Enabled and also slided the video memory to a max 256Mb.
My 3D-CAD software in W7 works far better but it still gives me error messages about 3D-Grapics hardware.

And another thing I think to have installed the latest VB version. During attempt to install I was told Direct3D was experimental.

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Tue Jun 19, 2018 7:37 am

If you had stated at the being that you were trying to do 3D CAD on Windows 7 as a Virtual Guest Machine in VirtualBox, I would have advised that you were going to encounter problems and restrictions. Most CAD packages have close ties to the graphics hardware / driver, so you're better off installing Windows 7 in a dual-boot with Linux.

There is a CAD package called FreeCAD that runs under Linux and is available from Mint Software Manager.

https://www.freecadweb.org/
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Tue Jun 19, 2018 11:50 am

I already tested Freecad a few days ago, but it cannot import Inventor files.
I drew LOTS of parts and projects in Autodesk Inventor these last 10 to 15 years. I cannot start all over again redrawing them. My Inventor map is about 70(!)Gb

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Tue Jun 19, 2018 12:29 pm

If there is no common Export file format from Autodesk Inventor to use with FreeCAD, then you're stuck with Windows. :cry:
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Tue Jun 19, 2018 1:52 pm

Yep, there is indeed.
I could export all my ipt files to STP format. STP can be imported in FreeCAD. But it would not be feasible to convert all these files to STP. I'm talking here literal thousands of files.
As W7/Inventor is running very fast right now in VirtualBox I'm happy with it. As a matter of fact I see no difference in workingspeed between the original W7 install and the combined install as it is now. Booting W7 is rather slow, but working in Inventor is surprisingly fast.

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Tue Jun 19, 2018 2:00 pm

EOL on Windows 7 is January 14, 2020. That gives you plenty of time to think about it and test-stage a migration.

DO YOU REALLY WANT TO MOVE TO WINDOWS 10? :roll:
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Tue Jun 19, 2018 2:10 pm

Don't think so... :evil:

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Tue Jun 19, 2018 2:13 pm

As matter of fact W10 is precisely the reason why I started all these make-overs for all my PC's and laptops.
Need some more Linux fine-tuning on all my machines and I'm done..!

User avatar
ClixTrix
Level 5
Level 5
Posts: 749
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by ClixTrix » Tue Jun 19, 2018 2:37 pm

Chriske wrote:
Tue Jun 19, 2018 2:10 pm
Don't think so... :evil:
:lol:
Linux Mint 18.3 x64 Cinnamon 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Chriske
Level 3
Level 3
Posts: 126
Joined: Wed Jun 06, 2018 3:21 am

Re: [SOLVED -partially-] Correct video driver not working in VirtualBox/W7 on HP Probook 407 G0

Post by Chriske » Tue Jun 19, 2018 2:39 pm

Amongst friends here we call it 'Wintendo'.... :mrgreen:

Post Reply

Return to “Hardware Support”