Touchpad stopped working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
swanfgc
Level 1
Level 1
Posts: 2
Joined: Fri Mar 30, 2018 5:45 am

Touchpad stopped working

Post by swanfgc » Thu Jun 21, 2018 4:58 pm

Hi,

After rebooting touchpad stopped working (ELAN 1200), no response at all.

Code: Select all

System:    Host: ettore-nb Kernel: 4.17.2 x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: UX310UA v: 1.0
           Mobo: ASUSTeK model: UX310UA v: 1.0
           Bios: American Megatrends v: UX310UA.202 date: 05/18/2016
CPU:       Dual core Intel Core i3-6100U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9216
           clock speeds: max: 2300 MHz 1: 500 MHz 2: 500 MHz 3: 500 MHz
           4: 500 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.21hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.17.2
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: 10:02:b5:ad:07:1e
Drives:    HDD Total Size: 500.1GB (5.5% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB temp: 35C
Partition: ID-1: / size: 230G used: 26G (12%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 35.5C mobo: N/A
           Fan Speeds (in rpm): cpu: 3100
Info:      Processes: 184 Uptime: 15 min Memory: 498.5/3806.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Touchpad stopped working

Post by gm10 » Thu Jun 21, 2018 5:45 pm

Did you accidentally hit the Fn key combo to disable it? You can check in settings whether the touchpad is enabled. Or in a terminal type

Code: Select all

xinput 
and see if it's listed as a core pointer device at all, and if it is then with the listed id:

Code: Select all

xinput enable [id]
There's also a setting to automatically disable it while typing, if the above did not help then toggling that seems an idea to start your troubleshooting.

swanfgc
Level 1
Level 1
Posts: 2
Joined: Fri Mar 30, 2018 5:45 am

Re: Touchpad stopped working

Post by swanfgc » Fri Jun 22, 2018 5:27 am

thanks for your reply.
for some reason after rebooting few times it started working again.
gm10 wrote:
Thu Jun 21, 2018 5:45 pm
Did you accidentally hit the Fn key combo to disable it? You can check in settings whether the touchpad is enabled. Or in a terminal type

Code: Select all

xinput 
no, i didn't.
now that it works i can see the touchpad record, before i wasn't able to see it.

i don't know what could it be happened... :?:

ps: touchpad wasn't working either on windows partiton.

gm10
Level 13
Level 13
Posts: 4566
Joined: Thu Jun 21, 2018 5:11 pm

Re: Touchpad stopped working

Post by gm10 » Fri Jun 22, 2018 5:57 am

swanfgc wrote:
Fri Jun 22, 2018 5:27 am
now that it works i can see the touchpad record, before i wasn't able to see it.

i don't know what could it be happened... :?:

ps: touchpad wasn't working either on windows partiton.
If both Linux and Windows didn't detect it and you didn't change anything in the meantime (e.g. in the BIOS) then you're nearly certainly looking at a hardware issue, could be anything from a loose connector to an actual defect. Best keep an external mouse around in case it fails again.

Post Reply

Return to “Hardware Support”