SOLVED - LM 19 - how to get SDD to activate at startup so bookmarks work?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

SOLVED - LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

Hi,

I am loving the new LM19, Cinnamon.

I have some bookmarks from my SDD in Nemo.

These don't work without me first having to click on the SDD at initial startup.

Is there a way that when I start LM19 I can go straight to my bookmarks without first having to click on the SDD to kinda activate it?

Thanks. :)
Last edited by MintyMorkyMindy on Sun Jul 15, 2018 8:42 am, edited 1 time in total.
Linux Mint since 5 October 2014 :D
User avatar
catweazel
Level 19
Level 19
Posts: 9883
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by catweazel »

MintyMorkyMindy wrote:
Tue Jul 10, 2018 7:43 pm
Is there a way that when I start LM19 I can go straight to my bookmarks without first having to click on the SDD to kinda activate it?
Please post the output of this terminal command:

Code: Select all

lsblk
Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

Do the same for this command: sudo blkid

In your reply, identify the SSD from the output I've asked for.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

These are the problem drives. Two new SDD that replaced my old two HDD.

Identical problem.

They work fine. Just that my Nemo bookmarks won't work until I click on the drive to activate them.

Code: Select all

sdb      8:16   0 465.8G  0 disk 
└─sdb1   8:17   0 465.8G  0 part /media/username/drive name
sdc      8:32   0 465.8G  0 disk 
└─sdc1   8:33   0 465.8G  0 part /media/username/drive name
Linux Mint since 5 October 2014 :D
User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by Sir Charles »

Are they auto-mounted at boot via /etc/fstab?
Please post:

Code: Select all

cat /etc/fstab
and

Code: Select all

sudo blkid -o list
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

No they don't appear to be mounted at boot. I need to click on them.

sudo blkid -o list

Code: Select all

device     fs_type label    mount point    UUID
-------------------------------------------------------------------------------
/dev/sdb1  ext4    ABC  (not mounted) e5968d20-556b-4fe0-8e84-85dfcf19d6ae
/dev/sdc1  ntfs    ABC  (not mounted)  2EBAC943BAC90873
Linux Mint since 5 October 2014 :D
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

This is at boot without activating the SDD by clicking on them.

sudo cat /etc/fstab

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdd2 during installation
UUID=369e2b7e-4c86-45a5-bb5e-58400672c9df /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdd1 during installation
UUID=090D-BD7B  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
Linux Mint since 5 October 2014 :D
User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by Sir Charles »

Alright, with your drives unmounted, perform the following steps:

1.
Make a directory (mount point) for each one of your drives:

Code: Select all

sudo mkdir /media/$USER/DRIVE
replace DRIVE with the actual name of the drives.

2.
Edit /etc/fstab in order for the devices to be mounted at boot:

Code: Select all

xed admin:///etc/fstab
type in your password followed by enter. Copy and paste the following content at the end of the file, replacing DRIVE1, DRIVE2 and USER by their actual names:

Code: Select all

# Mounting DRIVE1 under /media/USER/DRIVE1
UUID=e5968d20-556b-4fe0-8e84-85dfcf19d6ae /media/USER/DRIVE1     ext4  defaults,noatime,nofail 0  2
# Mounting DRIVE2 under /media/USER/DRIVE2
UUID=2EBAC943BAC90873 /media/USER/DRIVE2     ntfs-3g defaults,nofail 0  0
save and close the file.

3.

Code: Select all

sudo mount -a
Now your drives should show up among devices in the left pane of the file manager.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

Thanks for the replies.

I reinstalled LM19.

The SDDs mount. I have bookmarks from within one SDD using Nemo.

These bookmarks show within Nemo but are not click accessible until I click on the SDD first. Then the bookmarks all work.

I want to be able to click on the Nemo bookmarks and go to the SDD, without first having to click the SDD.

Is there an easy way, to fix this, preferably a gui?

Configuring the fstab is too complex for me. Would this work with "Start Up Applications"?

Thanks again.
Linux Mint since 5 October 2014 :D
User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by Sir Charles »

Hi MintyMorkyMindy,
If you're hesitant to manually edit the /etc/fstab or you just prefer a GUI tool for admin tasks, let GNOME Disks take care of the editing of disk mount point options. Just make sure to test your changes before rebooting, otherwise you could find yourself in a bit of a pickle.
How to edit Linux drive mount point options using a GUI
Good Luck!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: SOLVED - LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

The problem and how it was solved.

Problem: I bookmarked folders from a SDD with Nemo. After reboot, the bookmarks did not work, because the SDD was not auto mounted.

Solution: Deselect the "User Session Defaults" per,
Menu / Preferences / Disks / Additional Partition Options / Edit Mount Options

Both of these are now not greyed out, Mount at system start-up and Show in user interface are selected.
Linux Mint since 5 October 2014 :D
User avatar
MintyMorkyMindy
Level 3
Level 3
Posts: 156
Joined: Sun Oct 05, 2014 3:53 am

Re: SOLVED - LM 19 - how to get SDD to activate at startup so bookmarks work?

Post by MintyMorkyMindy »

Setting the User Setting Defaults per the image has fixed the problem. Now the SDDs mount at boot and their folders are working with Nemo.

Image

Thanks to everyone who replied above and tried to help ... much appreciated.

Thank you.
Linux Mint since 5 October 2014 :D
Post Reply

Return to “Hardware Support”