Random black screens with a dual monitor configuration on MacPro6,1

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Lumio
Level 1
Level 1
Posts: 3
Joined: Fri Sep 11, 2009 9:50 am

Random black screens with a dual monitor configuration on MacPro6,1

Post by Lumio » Wed Jul 11, 2018 7:05 am

Hello everyone. I switched to Linux Mint on my dev environment at work (currently using the Mac Pro from 2013... you know... the one which looks like a trash bin). It works great so far, using i3 and updating X on the fly (I have one monitor rotated and setting its rotation with xrandr)

However I get random black outs where my graphics card crashes and my monitors go black leaving the following error in the syslog:

Code: Select all

Jul 11 12:29:38 xxii kernel: [ 8328.133767] pciehp 0000:00:03.0:pcie004: Slot(5-3): Link Down
Jul 11 12:29:38 xxii kernel: [ 8328.135296] pcieport 0000:00:03.0: AER: Multiple Uncorrected (Fatal) error received: id=0018
Jul 11 12:29:38 xxii kernel: [ 8328.135307] pcieport 0000:00:03.0: PCIe Bus Error: severity=Uncorrected (Fatal), type=Transaction Layer, id=0018(Requester ID)
Jul 11 12:29:38 xxii kernel: [ 8328.135313] pcieport 0000:00:03.0:   device [8086:0e08] error status/mask=00004020/00000000
Jul 11 12:29:38 xxii kernel: [ 8328.135317] pcieport 0000:00:03.0:    [ 5] Surprise Down Error    (First)
Jul 11 12:29:38 xxii kernel: [ 8328.135320] pcieport 0000:00:03.0:    [14] Completion Timeout∙∙∙∙
Jul 11 12:29:38 xxii kernel: [ 8328.135325] pcieport 0000:00:03.0: broadcast error_detected message
Jul 11 12:29:38 xxii kernel: [ 8328.135327] radeon 0000:06:00.0: device has no AER-aware driver
Jul 11 12:29:38 xxii kernel: [ 8328.143941] pciehp 0000:00:03.0:pcie004: Slot(5-3): Link Up
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 7
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 6
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 21
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 20
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 19
Jul 11 12:29:38 xxii acpid: input device has been disconnected, fd 18
Jul 11 12:29:38 xxii kernel: [ 8328.303060] pci 0000:06:00.1: device has no driver
Jul 11 12:29:38 xxii kernel: [ 8328.303079] pciehp 0000:00:03.0:pcie004: Slot(5-3): Link Down
Jul 11 12:29:38 xxii kernel: [ 8328.334469] pciehp 0000:00:03.0:pcie004: Slot(5-3): Link Up
Jul 11 12:29:39 xxii kernel: [ 8329.350824] pcieport 0000:00:03.0: Root Port link has been reset
Jul 11 12:29:39 xxii kernel: [ 8329.350829] pcieport 0000:00:03.0: AER: Device recovery failed
Jul 11 12:29:43 xxii kernel: [ 8333.307030] [drm:atom_op_jump [radeon]] *ERROR* atombios stuck in loop for more than 5secs aborting
Jul 11 12:29:43 xxii kernel: [ 8333.307058] [drm:atom_execute_table_locked [radeon]] *ERROR* atombios stuck executing D362 (len 75, WS 0, PS 0) @ 0xD391
I found the following question here however, doing so, will of course limit my workstation with one working monitor.

glxinfo | grep Device will say that I got a AMD TAHITI (DRM 2.50.0 / 4.15.0-20-generic, LLVM 6.0.0) (0x6798)
I'm running the latest stable Linux Mint version and I haven't altered the current installed graphics driver.

Does anyone know how to fix that or has an idea what I could try?

//edit:
I'm not the only one having this problem with my MacPro6,1 as found here
But it seems it might be a kernal bug... so here is my kernel version: 4.15.0-20-generic :)

Lumio
Level 1
Level 1
Posts: 3
Joined: Fri Sep 11, 2009 9:50 am

Re: Random black screens with a dual monitor configuration on MacPro6,1

Post by Lumio » Sun Jul 15, 2018 7:22 am

Just wanted to push this topic - maybe someone might have a workaround to this. Do you think an external graphics card could solve this problem, considering, that I need to connect it over thunderbolt (or might USB be better here for 2 different monitors)

Post Reply

Return to “Hardware Support”