Boot very slow after upgrade from 18.3 to 19

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
flanna
Level 3
Level 3
Posts: 102
Joined: Sun Sep 18, 2011 11:10 am

Boot very slow after upgrade from 18.3 to 19

Post by flanna » Wed Jul 18, 2018 11:18 am

I have upgraded from 18.3 to 19 First I ran the live cd, it worked well. Then I used the upgrade tool and followed the instructions in the page about upgrading.

The upgrade completed although there were quite a number of skipped files. Mint 19 runs well on my laptop (Lenovo X240)

The only real problem I have is that it takes ages to boot. With 18.3 the boot was very fast!

Any ideas what might be wrong?

User avatar
xenopeek
Level 24
Level 24
Posts: 22961
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Boot very slow after upgrade from 18.3 to 19

Post by xenopeek » Wed Jul 18, 2018 11:37 am

This is a known issue with the kernel version 4.15.0-24. Possibly you got that through Update Manager. You can confirm your kernel version for example by running the command inxi -S on the terminal.

If you have that version see if a newer version (4.15.0-NN, with NN higher than 24) is available in Update Manager if you open its View > Linux kernels menu. If so, install that and it should likely fix this issue.

You can otherwise also revert to the the original 4.15.0-20 kernel that Linux Mint 19 came with. To do so reboot your computer and hold down the shift key to make GRUB boot menu appear. From there select advanced and pick a lower version kernel to boot. If that went fine you can now remove the 4.15.0-24 kernel from View > Linux kernels menu in Update Manager to avoid booting with that again.
Image

iveycole
Level 1
Level 1
Posts: 3
Joined: Wed Aug 31, 2011 10:12 pm
Location: Coleman County, Texas

Re: Boot very slow after upgrade from 18.3 to 19

Post by iveycole » Wed Jul 18, 2018 10:32 pm

I'm having this problem after upgrading from 18.3 to 19. It's taking about 4 to 5 minutes to boot. Looking at the messages it spends most of this time trying to read the floppy disk. I don't have a flopply drive installed. I looked at my BIOS settings to see if there is a setting to disable the floppy controller but didn't find one. It tries many times to read sector zero with a long time for each try. I started with 4.15.0-20 then tried 4.15.0-23 and 4.15.20-26. Anyone have any idea as to how I can tell 19 to not look at the non-existent floppy drive?

iveycole
Level 1
Level 1
Posts: 3
Joined: Wed Aug 31, 2011 10:12 pm
Location: Coleman County, Texas

Re: Boot very slow after upgrade from 18.3 to 19

Post by iveycole » Wed Jul 18, 2018 11:02 pm

Been a long time since I used a floppy and was looking in the wrong place in BIOS setup. Found the setting and set no floppy drive and now 19 boots approximately the same speed as 18.3. Don't know why the floppy was set in BIOS, maybe default as I've never had a floppy installed on this motherboard. Anyway I'm a happy camper or whatever now.

Post Reply

Return to “Hardware Support”