[SOLVED] Thinkpad trackpoint button problem after upgrade to LM19

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
captainpotato
Level 1
Level 1
Posts: 7
Joined: Thu Feb 14, 2008 7:35 am

[SOLVED] Thinkpad trackpoint button problem after upgrade to LM19

Post by captainpotato » Thu Jul 19, 2018 6:33 am

Hello,

I'm having an issue with the trackpoint buttons on my Thinkpad E470 since updating from LM18.1 (via 18.3) to LM19. I've previously had the buttons switched for the pointer si the right one is the main one, but under LM19 the "left handed (mouse buttons inverted)" configuration in the "Mouse and Touchpad" is ignored - i.e. - whether it's selected or not, the main button is the left one. Both work fine and are recognised, but just not the way I wish them to be.

I have a vague recollection that I may have had to change the setting in 18.1 via a config file but cannot find anything that reminds me whether I did (and if so, what I changed), or whether I've just imagined it.

Any suggestions would be great, please!
Last edited by Moem on Thu Jul 26, 2018 8:34 am, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!

User avatar
captainpotato
Level 1
Level 1
Posts: 7
Joined: Thu Feb 14, 2008 7:35 am

Re: Thinkpad trackpoint button problem after upgrade to LM19

Post by captainpotato » Thu Jul 26, 2018 8:23 am

In case anybody wonders, this is how I fixed the issue (not least me for when it happens after the next upgrade):

1. open a terminal window.
2. type: echo xmodmap -e \"pointer = 3 2 1\" 2\> /dev/null >> ~/.xprofile

Problem solved!

Post Reply

Return to “Hardware Support”