kernel 4.15.0-29-generic

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
krustybaguette
Level 3
Level 3
Posts: 151
Joined: Thu Mar 31, 2011 8:24 am

kernel 4.15.0-29-generic

Post by krustybaguette »

Currently running the kernel cited in Subject line on Lenovo T-520 Thinkpad. I have noted a couple of wonky problems that may be kernel related based upon comments I¨ve seem in other threads. These problems are recent since I accepted kernel updates for the first time with 4.15.0-13 or 4.15.0-15 or thereabouts.
  • single quote and double quote marks do not register unless I press key twice
  • tilde does not register unless I press shift key + tilde twice
  • I¨ve noticed that my wired internet connection has quit working
There may be other keys affected but I´m wondering if I should revert to an older kernel or accept the current update that is offered in Update Manager.
Or perhaps should I switch to something in the 4.4 or 4.8 families????
User avatar
Pjotr
Level 22
Level 22
Posts: 15217
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: kernel 4.15.0-29-generic

Post by Pjotr »

Upgrade your kernel: the 4.15.0-30 should be available as an update.
Tip: 10 things to do after installing Linux Mint 20 Ulyana
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
User avatar
AZgl1500
Level 13
Level 13
Posts: 4864
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: kernel 4.15.0-29-generic

Post by AZgl1500 »

and here I thought I was getting to be a sloppy typist, or the kybd is going bad?
Linux Mint 19.3 Cinnamon
rene
Level 16
Level 16
Posts: 6613
Joined: Sun Mar 27, 2016 6:58 pm

Re: kernel 4.15.0-29-generic

Post by rene »

krustybaguette wrote:
Tue Aug 07, 2018 3:53 pm
  • single quote and double quote marks do not register unless I press key twice
  • tilde does not register unless I press shift key + tilde twice
Very much doubt this was due to a kernel upgrade; you appear to have selected a keyboard layout with so-called "dead keys". Check your layout in (for Cinnamon) Menu -> Preferences -> Layouts. If you now have e.g. "English (US, international with dead keys)" I advise "English (international AltGr dead keys)" if you do want to keep access to special symbols.
Post Reply

Return to “Hardware Support”