Change folder for incoming bluetooth files (Blueman)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
kyrawertho
Level 1
Level 1
Posts: 18
Joined: Wed Oct 08, 2014 10:46 am

Change folder for incoming bluetooth files (Blueman)

Post by kyrawertho » Wed Aug 15, 2018 6:07 am

Hello,

When I start Blueman, it tells me 'Configured directory for incoming files does not exist' and I am unable to receive files over Bluetooth.

I googled a bit and although it seems to be a known issue, I can't find any solution. I found out that the shared-path should be set in blueman-services, but the Apply button stays greyed out so I cannot save it.

Likewise, I can see the setting is blank with

Code: Select all

gsettings get org.blueman.transfer shared-path
and should change it with

Code: Select all

gsettings set org.blueman.transfer shared-path '/home/me'
, which only tells me 'The key is not writable'.

Now, when I run blueman-services or gsettings as root, it does work: the folder is set to /root/Downloads – but this doesn't help me because when I run the bluetooth-applet as root, I can't send any files over bluetooth at all, they fail straight away. When I run it as my own user, at least the files are sent successfully but then just disappear somewhere.

So it seems I need to be root but I want to change my own settings, not root. How can I do this?

I also tried:
- Permissions from root to me recursively on:
/usr/share/blueman
/usr/lib/python3/dist-packages/blueman
/usr/bin/blueman-*
- Checked permissions on ~/.config/dconf
- In /usr/lib/python3/dist-packages/blueman/plugins/services/Transfer.py
if key == "shared-path":
self.Builder.get_object(key).set_current_folder(value)
-> changed value to /home/user/Downloads
- sudo dpkg-reconfigure blueman
- sudo service bluetooth restart
- apt-get remove + reinstall
- apt-get purge + reinstall
- added myself to a bunch of groups (bluetooth, lp, audio, video, netdev, scanner)
- sudo -u me gsettings set org.blueman.transfer shared-path '/home/me' gives: /home/me/.cache/dconf/user': Access denied. dconf will not work properly – so I did chown -R on this dconf folder as well. Running it with sudo -u now doesn't say the key is not writable anymore, but it still changes it for root, not for me
- Manually changed shared-path setting in /usr/share/glib-2.0/schemas/org.blueman.gschema.xml

Sometimes, I can't select a folder because everything is greyed out and other times, only the Apply button is greyed out. This seems random.

Post Reply

Return to “Hardware Support”