Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Avi8tor
Level 1
Level 1
Posts: 3
Joined: Thu Aug 16, 2018 6:12 pm

Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by Avi8tor » Thu Aug 16, 2018 6:25 pm

I am a complete novice with regards any Linux systems but I had an old Laptop [c2006] gathering dust which I decided to try and load Mint onto after picking up a magazine recently with a disk that had a Mint 19 installation on it. The HDD on the laptop had been previously wiped clean as it previously had Windows XP on it. The installation via the disk went fine and I have updated all the software via an ethernet cable, it's just there are no wi-fi networks shown at all on the network list. I have been into driver manager but nothing appears there at all. Any ideas where I go to try and get the wi-fi to work on this old laptop?

Acer 5103 WLmi
120GB HDD
4GB RAM

Thanks for any help.

User avatar
karlchen
Level 19
Level 19
Posts: 9196
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by karlchen » Thu Aug 16, 2018 6:31 pm

Hello, avi8tor.

Please, execute the terminal command

Code: Select all

inxi -Fxz
Mark the complete screen output and paste it in your next reply. This will give us a concise overview on your hardware, including the network interfaces, which Mint sees.

Regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Avi8tor
Level 1
Level 1
Posts: 3
Joined: Thu Aug 16, 2018 6:12 pm

Re: Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by Avi8tor » Fri Aug 17, 2018 6:27 am

Thanks for your reply Karl, as requested:

Code: Select all

System:    Host: user2018-Aspire-5100 Kernel: 4.15.0-32-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Acer product: Aspire 5100 v: V2.00 serial: N/A
           Mobo: Acer model: Navarro serial: N/A
           BIOS: Acer v: V2.00 date: 08/03/2006
CPU:       Dual core AMD Turion 64 X2 Mobile TL-52 (-MCP-) 
           arch: K8 rev.F+ cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 6383
           clock speeds: max: 1600 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV515/M52 [Mobility Radeon X1300]
           bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: ATI RV515
           version: 2.1 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB4x0 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.15.0-32-generic
Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 06:01.0
           IF: enp6s1 state: unknown speed: 100 Mbps duplex: full
           mac: <filter>
           Card-2: Broadcom Limited BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
           bus-ID: 06:02.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 120.0GB (12.9% used)
           ID-1: /dev/sda model: Hitachi_HTS54121 size: 120.0GB
Partition: ID-1: / size: 110G used: 15G (14%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 160 Uptime: 8 min Memory: 981.7/3944.4MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

User avatar
karlchen
Level 19
Level 19
Posts: 9196
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by karlchen » Fri Aug 17, 2018 10:03 am

Hello, Avi8tor.

Obviously, this section is what is of most interest at the moment:

Code: Select all

Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 06:01.0
           IF: enp6s1 state: unknown speed: 100 Mbps duplex: full
           mac: <filter>
           Card-2: Broadcom Limited BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
           bus-ID: 06:02.0
           IF: N/A state: N/A mac: N/A
So one more time it is a Broadcom Wireless Controller, for which the right driver does not get loaded automatically.

Does driver manager suggest a (proprietary Broadcom) driver software for it?
If so, you would download and install it while the wired connection is established.
Once the installation has been finished, you would reboot and disconnect the network cable so that the system has to try an use the wifi interface. This way it should become clear very quickly whether the newly installed driver works correctly or not.

--
P.S.:
Just found this thread, consisting of exactly 1 post, where LMSimon explains how he got his Broadcom Broadcom BCM4318 interface working on Mint 19: [Solved] Remove / Enable WiFi driver module every boot time
Hm, he should not have marked it as [solved], because it is clearly a workaround, not a solution, which he explains.
--
OK, guess I found a brief instruction by JeremyB, explaining how to make Broadcom BCM4318 work: RE: Mint 18.2 Wifi driver missing. OK. It is for Mint 18.2. Does not imply necessarily, the same steps will not work on Mint 19 though.

Regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Avi8tor
Level 1
Level 1
Posts: 3
Joined: Thu Aug 16, 2018 6:12 pm

Re: Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by Avi8tor » Fri Aug 17, 2018 1:24 pm

Thanks again for your help in looking into this Karl. Driver manager does not suggest anything to download. I followed the instructions about how to get the Broadcom BC4318 to work as per Jeremy B's post but I'm afraid it's still the same, in that only the wired connection is recognised.

Regards
Tony

User avatar
karlchen
Level 19
Level 19
Posts: 9196
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Linux Mint 19 install, Acer Aspire 5103 WLmi Wi-fi not working.

Post by karlchen » Sat Aug 18, 2018 5:05 am

Hello, Tony.

Does inxi still tell this about the wifi interface?

Code: Select all

           Card-2: Broadcom Limited BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
           bus-ID: 06:02.0
           IF: N/A state: N/A mac: N/A

You can inspect the network cards using the terminal command

Code: Select all

inxi -Nnz
This will only check the network interfaces and not go through all of the other hardware as well.

Regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Post Reply

Return to “Hardware Support”