Page 2 of 2

Re: HP Laptop with Advanced Micro Devices no audio

Posted: Sat Aug 25, 2018 8:50 pm
by MrEen
LOL!

Good luck! :)

Re: HP Laptop with Advanced Micro Devices no audio

Posted: Sat Aug 25, 2018 11:32 pm
by WesternSlope
YeHaaaaa... I'm back with sound. I guess the first install was bad. Thank you for all of your help. Love the TimeShift. Worked great. Had me back up and running in 10 minutes with all that I had. Needed to install Mint first, but no problem anymore. Use to be a bear.
Thanks again!

Re: HP Laptop with Advanced Micro Devices no audio

Posted: Sat Aug 25, 2018 11:35 pm
by MrEen
Way to go, WesternSlope!

Glad you're fixed. :D

Re: [SOLVED] HP Laptop with Advanced Micro Devices no audio

Posted: Sun Aug 26, 2018 12:49 am
by WesternSlope
I ran the line you gave me
xed admin:///etc/modprobe.d/alsa-base.conf
to see where the problem may have been. Can you see it?
Thanks

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Re: [SOLVED] HP Laptop with Advanced Micro Devices no audio

Posted: Sun Aug 26, 2018 12:54 am
by MrEen
No. There was probably nothing wrong with that file. It's just a place to add extra options to work around various issues.

More than likely the reinstallation of the kernel is what fixed you, I'm thinking.

Re: [SOLVED] HP Laptop with Advanced Micro Devices no audio

Posted: Sun Aug 26, 2018 1:03 am
by WesternSlope
You are the wiz here, so I'm not going to argue. Whatever fixed it fixed it.
Thank you, sir.

Re: [SOLVED] HP Laptop with Advanced Micro Devices no audio

Posted: Sun Aug 26, 2018 1:10 am
by MrEen
WesternSlope wrote:
Sun Aug 26, 2018 1:03 am
You are the wiz here, so I'm not going to argue. Whatever fixed it fixed it.
Thank you, sir.
You're very welcome. :)