Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
AaronCT
Level 1
Level 1
Posts: 4
Joined: Fri Sep 14, 2018 3:01 pm

Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by AaronCT » Fri Sep 14, 2018 3:32 pm

I understand there are a lot of these kinds of threads, but here's my issue:
I have a Lenovo ThinkPad T420 and the built-in microphone isn't detected at all. I know a lot of people say to start with pavucontrol, so I got it and I can't really figure it out. It has 3 audio inputs, one with what I assume is white nose and the other 2 listed as unplugged.

Here's what inxi -Fxz outputted:

Code: Select all

System:    Host: Unimportant Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: LENOVO product: 4180AP3 v: ThinkPad T420 serial: N/A
           Mobo: LENOVO model: 4180AP3 serial: N/A
           UEFI [Legacy]: LENOVO v: 83ET73WW (1.43 ) date: 11/30/2012
Battery    BAT0: charge: 43.2 Wh 99.4% condition: 43.5/93.2 Wh (47%)
           model: SANYO 45N1007 status: Charging
CPU:       Dual core Intel Core i5-2520M (-MT-MCP-) 
           arch: Sandy Bridge rev.7 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9966
           clock speeds: max: 2500 MHz 1: 951 MHz 2: 943 MHz 3: 943 MHz
           4: 838 MHz
Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.98hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
           version: 3.3 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 750.2GB (22.8% used)
           ID-1: /dev/sda model: Hitachi_HTS72757 size: 750.2GB
Partition: ID-1: / size: 183G used: 17G (10%) fs: ext4 dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 1970
Info:      Processes: 222 Uptime: 2 days Memory: 2307.2/3827.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Any help is appreciated.

User avatar
MrEen
Level 7
Level 7
Posts: 1962
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by MrEen » Fri Sep 14, 2018 4:01 pm

Hi AaronCT, and welcome to the forum.

What are the names of the inputs? Especially the one that does not say unplugged.

AaronCT
Level 1
Level 1
Posts: 4
Joined: Fri Sep 14, 2018 3:01 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by AaronCT » Fri Sep 14, 2018 7:01 pm

The inputs are as follows:
1: Internal microphone (unplugged)
2: Microphone (plugged in)
3: Dock Microphone (unplugged)

User avatar
MrEen
Level 7
Level 7
Posts: 1962
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by MrEen » Fri Sep 14, 2018 7:10 pm

As unintuitive as this may sound, have you tried setting it to Internal microphone (unplugged)?

That may very well work, but if it doesn't I have another option. Just let me know.

Also, if it doesn't work, in your next post please post the output of running these in the terminal: aplay -l and arecord -l

Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

AaronCT
Level 1
Level 1
Posts: 4
Joined: Fri Sep 14, 2018 3:01 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by AaronCT » Sat Sep 15, 2018 12:40 am

MrEen wrote:
Fri Sep 14, 2018 7:10 pm
As unintuitive as this may sound, have you tried setting it to Internal microphone (unplugged)?

That may very well work, but if it doesn't I have another option. Just let me know.

Also, if it doesn't work, in your next post please post the output of running these in the terminal: aplay -l and arecord -l

Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.
This did not work. I noticed that internal microphone unplugged does indeed get some input but it's very low/negligible.
aplay -l output:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20590 Analog [CX20590 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
arecord -l output:

Code: Select all

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20590 Analog [CX20590 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

wakafiu
Level 1
Level 1
Posts: 1
Joined: Sat Sep 15, 2018 4:14 am

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by wakafiu » Sat Sep 15, 2018 5:28 am

Awww !! I face it lot of times . So, unlucky i purchased this product ..in my empty spaces i always call to my friends .now i use messaging to connect with them.

Thanks

User avatar
MrEen
Level 7
Level 7
Posts: 1962
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by MrEen » Sat Sep 15, 2018 11:39 am

Before we go start changing pin configurations, try alsamixer (by typing that in the terminal) and make the window as wide as you can.

If the page that opens has CX20590 in the upper left, we're on the right page, otherwise press F6 to find it.

This is where it can get tricky. You may need to adjust a mic level here, or you may need to press F4 and adjust some levels on that page. I'm hoping one of the two pages will have a column with something like mic built-in whose levels you'll want to increase and if there's a boost column beside it, you might need to increase it as well.

To adjust the levels, you use left and right arrows to select the columns, up and down arrow to change levels, and m to toggle mute. A column is muted when you see MM underneath it.

I suggest going this route first as you said you had "some" input so this might be all you need. If it doesn't help, we'll start changing pins to try to fix it (via software) but it's not something I have experience with.

AaronCT
Level 1
Level 1
Posts: 4
Joined: Fri Sep 14, 2018 3:01 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by AaronCT » Sat Sep 15, 2018 5:25 pm

No success. Alternatively, I can just use a USB headset or something.

User avatar
MrEen
Level 7
Level 7
Posts: 1962
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 19 Cinnamon - Lenovo T420 built-in microphone not working

Post by MrEen » Sat Sep 15, 2018 5:41 pm

AaronCT wrote:
Sat Sep 15, 2018 5:25 pm
No success. Alternatively, I can just use a USB headset or something.
That might be easier, but if you want to continue trying to fix this, I'd suggest installing alsa-tools-gui then in the terminal run hdajackretask

When it opens, make sure the box in the upper left shows the CX20590 codec (click on it if necessary to change.) Then click on "Show unconnected pins" over on the right. Now it takes some experimentation. Under the Pin configuration box, you can try the override on the built-in mic, or go down to the first unconnected pin, click override and change to internal mic. Test the mic to see if it works, and when it works properly, click on Install boot override. That fix should be permanent.

You may have to play around with it more than that. Just remember to keep testing your mic between changes and don't click Install boot override until it works properly.

Good luck.

Post Reply

Return to “Hardware Support”