Cannot see any NVIDIA X Server settings inside

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 2:47 pm

I'm kinda new here (obviously). I have a laptop with nvidia mx150 and intel graphics. So when I open Nvidia x settings i see nothing except "application profiles" and "nvidia-settings configuration". I have installed 390.48 proprietary drivers. I know about Bumblebee and Prime but the laptop doesn't even see the graphics card when I checked trough terminal it shows only intel UHD 620. ( Had same problem on ubuntu 18.04)
Last edited by CrystalSun on Sat Sep 22, 2018 3:36 pm, edited 2 times in total.

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 3:26 pm

Please post the computers specs:

Code: Select all

lspci
inxi -Fxxz
ubuntu-drivers devices
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 3:32 pm

Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
03:00.0 Network controller: Intel Corporation Device 24fb (rev 10)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

System: Host: jeff Kernel: 4.15.0-34-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) dm: lightdm Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Acer product: Aspire E5-576G v: V1.29 serial: N/A
Mobo: KBL model: Ironman_SK v: V1.29 serial: N/A UEFI: Insyde v: V1.29 date: 07/21/2017
Battery BAT1: charge: 40.7 Wh 100.0% condition: 40.7/40.9 Wh (99%) volts: 16.7/14.6
model: LGC AS16A8K serial: <filter>status: Full
CPU: Quad core Intel Core i5-8250U (-MT-MCP-) arch: Kaby Lake rev.10 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14400
clock speeds: min/max: 400/3400 MHz 1: 1435 MHz 2: 1683 MHz 3: 1436 MHz 4: 1801 MHz 5: 1142 MHz
6: 1465 MHz 7: 1534 MHz 8: 1626 MHz
Graphics: Card-1: Intel UHD Graphics 620 bus-ID: 00:02.0 chip-ID: 8086:5917
Card-2: NVIDIA GP108M [GeForce MX150] bus-ID: 01:00.0 chip-ID: 10de:1d10
Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nouveau (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.05hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
version: 4.5 Mesa 18.0.5 (compat-v: 3.0) Direct Render: Yes
Audio: Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d71
Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network: Card-1: Intel Device 24fb driver: iwlwifi bus-ID: 03:00.0 chip-ID: 8086:24fb
IF: wlp3s0 state: down mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 04:00.1 chip-ID: 10ec:8168
IF: enp4s0f1 state: up speed: 10 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 1000.2GB (1.2% used)
ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB serial: <filter>
Partition: ID-1: / size: 916G used: 11G (2%) fs: ext4 dev: /dev/sda2
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 49.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 252 Uptime: 2:01 Memory: 1526.3/3820.8MB Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191 running in gnome-terminal-) inxi: 2.3.56



== /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001D10sv00001025sd0000121Abc03sc02i00
vendor : NVIDIA Corporation
model : GP108M [GeForce MX150]
driver : nvidia-driver-390 - distro non-free recommended
driver : xserver-xorg-video-nouveau - distro free builtin

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 3:42 pm

Did you disable Secure Boot in the bios settings ?
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 3:44 pm

No I didn't. Should I?

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 3:49 pm

CrystalSun wrote:
Sat Sep 22, 2018 3:44 pm
No I didn't. Should I?
The driver is compiled locally, it won't load with Secure Boot enabled because not signed by an authoritative key.
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 3:55 pm

It's enabled. When I try to go on it with arrow keys it skips the Secure boot enable/disable option. If I choose Legacy boot mode that option disappears completely. What should I do?

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 4:02 pm

I can't enter that line. Literally. It doesn't allow me to go on it. (while following the guide). I can't select anything below set HDD0 Password. It's all grey coloured.
Last edited by CrystalSun on Sat Sep 22, 2018 4:03 pm, edited 1 time in total.

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 4:02 pm

Check Acer support. Try to setup an admin password that may give you access to advanced options.
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 4:04 pm

By admin password you mean?

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 4:08 pm

Setting an admin/user password in the bios settings does not grant you access to advanced options settings ? Just guessing.

If Linux Mint is the only OS installed you may switch to Legacy boot and reinstall in that mode. Secure Boot is disabled in Legacy mode.
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 4:12 pm

setting up "Supervisor password" gave me access to the entrusting files settings. Did everything with the guide. What now?

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 4:15 pm

And still no access to SB option ? Changing that setting really depends on Acer uefi capabilities.
Image

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 4:16 pm

Disabled Safe boot, F10 and rebooted

CrystalSun
Level 1
Level 1
Posts: 9
Joined: Sat Sep 22, 2018 1:59 pm

Re: Cannot see any NVIDIA X Server settings inside

Post by CrystalSun » Sat Sep 22, 2018 4:18 pm

Now I can see all the settings I should in the nvidia x server settings. Holy s*it. Thank you so much.

Laurent85
Level 15
Level 15
Posts: 5747
Joined: Tue May 26, 2015 10:11 am

Re: Cannot see any NVIDIA X Server settings inside

Post by Laurent85 » Sat Sep 22, 2018 4:20 pm

Fine.
Image

Post Reply

Return to “Hardware Support”