Linux Mint 18 Cinnamon No Sound Problem Disappeared

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Mon Oct 01, 2018 12:03 pm

I think that snd_hda_intel loaded:

alex@Sartoris:~$ lsmod | grep snd
snd_hda_intel 40960 0
snd_hda_codec 131072 1 snd_hda_intel
snd_hda_core 81920 2 snd_hda_intel,snd_hda_codec
snd_hwdep 20480 1 snd_hda_codec
snd_pcm 98304 3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 32768 1 snd_seq_midi
snd_seq 65536 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 32768 2 snd_seq,snd_pcm
snd 81920 8 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_seq_device,snd_pcm
soundcore 16384 1 snd
alex@Sartoris:~$

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Mon Oct 01, 2018 3:13 pm

Well, it looks like everything is loaded that should be. Except for the module for your chip/codec!

This has worked for some people so we might as well try it. In the terminal type sudo touch /etc/modprobe.d/intel.conf followed by xed admin:////etc/modprobe.d/intel.conf and when the file opens add these two lines:

Code: Select all

options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1
Save the file then reboot and test your sound. Don't forget to see if aplay -l shows a card now.

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Mon Oct 01, 2018 6:54 pm

Here it is:

alex@Sartoris:~$ lsmod | grep snd
snd_hda_intel 40960 0
snd_hda_codec 131072 1 snd_hda_intel
snd_hda_core 81920 2 snd_hda_intel,snd_hda_codec
snd_hwdep 20480 1 snd_hda_codec
snd_pcm 98304 3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_seq_midi 16384 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 32768 1 snd_seq_midi
snd_seq 65536 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 16384 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 32768 2 snd_seq,snd_pcm
snd 81920 8 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_seq_device,snd_pcm
soundcore 16384 1 snd
alex@Sartoris:~$

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Mon Oct 01, 2018 6:59 pm

Oops. I got out of sequence.
The file Sartiris:/etc/modprobe.d/intel.conf exists but is empty! Shall I add the two lines to the empty file?

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Mon Oct 01, 2018 7:08 pm

I added the two lines to the empty file, rebooted and still no sound. Here is this:
alex@Sartoris:~$ aplay -l
aplay: device_list:270: no soundcards found...
alex@Sartoris:~$ cat /etc/modprobe.d/intel.conf
options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1
alex@Sartoris:~$ ls -l /etc/modprobe.d/intel.conf
-rw-r--r-- 1 root root 70 Oct 1 16:01 /etc/modprobe.d/intel.conf
alex@Sartoris:~$

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Mon Oct 01, 2018 7:12 pm

So it appears that didn't work. I thinks it's best to delete the file, /etc/modprobe.d/intel.conf to make sure it doesn't get in the way of other "fixes" then try doing this:
xed admin:///etc/modprobe.d/alsa-base.conf and scroll to the bottom of the file and add this line options snd-hda-intel model=auto.

Save and reboot and test.

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Mon Oct 01, 2018 7:43 pm

Sorry to say still no sound. I have the amended file here:

Code: Select all

alex@Sartoris:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto
alex@Sartoris:~$ 

options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto
alex@Sartoris:~$

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Mon Oct 01, 2018 8:29 pm

Well, I guess we're going to have to try the 4.18 kernel after all. Just to be sure, I'd like you to power down your machine for a minute then turn it back on. If still no sound, use Pjotr's guide here: https://sites.google.com/site/easylinux ... ted-kernel

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Tue Oct 02, 2018 1:49 pm

Update Manager lists a newer kernel. I will try that first:
kernel4.15.0.3-039.png
[attachment=0]

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Tue Oct 02, 2018 4:37 pm

Good idea.

Also, when done with kernel upgrade, let's check permissions just in case: find $HOME ! -user $USER

I doubt this one will help but let's also see the output of sudo fuser -v /dev/snd/*

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Thu Oct 04, 2018 6:48 pm

I have installed kernel 4.18.0-8, restarted my computer and still no sound. Here is:

alex@Sartoris:~$ sudo find $HOME ! -user $USER
[sudo] password for alex:
/home/alex/.dbus
/home/alex/.dbus/session-bus
/home/alex/.dbus/session-bus/ef635a010d284bc38d762d2b9f0e65ac-0
/home/alex/.cache/dconf
/home/alex/.cache/dconf/user
alex@Sartoris:~$ sudo fuser -v /dev/snd/*
alex@Sartoris:~$

Yes, no output with this command.

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Thu Oct 04, 2018 6:51 pm

Let's fix the permissions with sudo chown -R $USER:$USER /home/$USER

Then start pulseaudio with pulseaudio --start

Maybe this fixes you.

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Thu Oct 04, 2018 7:31 pm

I'm not sure if this worked. Still no sound.

alex@Sartoris:~$ sudo chown -R $USER:$USER /home/$USER
[sudo] password for alex:
alex@Sartoris:~$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {ef635a010d284bc38d762d2b9f0e65ac}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.
alex@Sartoris:~$

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Thu Oct 04, 2018 7:58 pm

I have installed Pavucontrol which represents itself as "the PulseAudio volume control. I still get:

alex@Sartoris:~$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {ef635a010d284bc38d762d2b9f0e65ac}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.
alex@Sartoris:~$

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Thu Oct 04, 2018 8:21 pm

Does aplay -l display a card now?

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Fri Oct 05, 2018 12:11 pm

No:
alex@Sartoris:~$ aplay -l
aplay: device_list:270: no soundcards found...
alex@Sartoris:~$

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Fri Oct 05, 2018 12:19 pm

Hi royston.

I am just about out of ideas. This might be my last suggestion:

Code: Select all

apt remove --purge alsa-base pulseaudio
apt install alsa-base pulseaudio
sudo alsa force-reload
Reboot after that. If still no sound, you're probably going to have to wait for Linux to catch up to your hardware. In the interim, you could use a USB sound thingy like this: https://www.amazon.com/Sabrent-External ... 49F313TS1V

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Fri Oct 05, 2018 6:18 pm

Thank you, MrEen for all your help. I suppose I will just have to wait till the software is written by some smart and generous individual.
Signing off for now,
Royston

royston
Level 1
Level 1
Posts: 31
Joined: Fri Sep 28, 2018 6:27 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by royston » Sun Oct 07, 2018 6:34 pm

I reinstalled Mint 18 Cinnamon, did a standard update, and my sound is back! I don't know why but I am pleased

User avatar
MrEen
Level 7
Level 7
Posts: 1734
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint 18 Cinnamon No Sound

Post by MrEen » Sun Oct 07, 2018 6:40 pm

I am very happy for you, royston!

It sucks that we can't figure out why it didn't work before.

I had Audacity crash on me this weekend and my soundcard disappeared following that, but a simple reboot fixed it.

Post Reply

Return to “Hardware Support”