ALC256 sound - Internal Microphone not working on Linux (Mint and Ubuntu)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

ALC256 sound - Internal Microphone not working on Linux (Mint and Ubuntu)

Post by esc11 » Fri Oct 12, 2018 5:51 am

Hi all, I bought an new laptop (Acer Swift 3) and decided to once again use Mint.
Problem is that my microphone is not working.
I have tried to unlock the mic in 'pulse'
I have also updated the kernel (tried 4 different versions)
And I tried upgrading from Linux Sylvia now to Tara.

I have also checked that " /usr/share/cinnamon/cinnamon-settings/modules/cs_sound.py" (self.inputSelector = self.buildDeviceSelect("input", self.inputDeviceList) ) is input and not output.

Is there anything else I can try? :? :?:
Last edited by esc11 on Mon Oct 15, 2018 11:21 am, edited 1 time in total.

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by sebastjava » Fri Oct 12, 2018 10:10 am

First, you could take a look and try to make changes in alsamixer in the terminal.
Attachments
Capture du 2018-10-12 10-06-10.png

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 12:39 pm

I have no option to edit my microphone.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 1:22 pm

screenshot_3.png
My old Acer recognizes the internal microphone.
screenshot.png
My new Acer does not seem to recognise the microphone. Hence 'Analog Input'

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 2:23 pm

Hi esc11, and welcome to the forum.

I assume listening to sound works. Let's see the output of arecord -l to see if that gives us a clue as to what's wrong.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 3:15 pm

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC256 Alt Analog [ALC256 Alt Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

Thanks MrEen

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 3:40 pm

The arecord output looks normal.

My suggestion would be to install and run PulseAudio Volume Control (pavucontrol.)

On the Configuration tab select Analog Stereo Output + Analog Mono Input (or something similar such as Analog Stereo Duplex.)

Then check the Input Devices tab to make sure the internal mic shows up and isn't muted. Once you try to record something with the mic, you should also see it on the Recording tab.

Good luck.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 3:50 pm

Sadly I have already tried this. I have been through most of the forums concerning a mic not working.

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 3:53 pm

The mic doesn't show on the Input Devices tab?

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 5:03 pm

It shows up but there is still no sound. Can't record, use skype etc. Just silence...

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 5:05 pm

Works perfectly on windows and I have not seen anyone else with my version pc that has complained about it so.
So I really don't know because I have tried two versions of Linux mint and different kernels.

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 5:31 pm

Okay. That really sounds like it's muted. Open alsamixer again. You may need to press F6 to select the appropriate sound device. You said earlier your mic doesn't show up, so keep hitting the right arrow key to see if it's hidden off the right end of the window.

You can also press F4 and make sure Capture isn't muted.

See if that helps.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 5:42 pm

No I still don't have a microphone setting and capture says
"This sound device does not have any capture controls."

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 5:44 pm

If you press F6, are there other choices?

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 5:45 pm

Only default and the sound card (so essentially the same).

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 5:50 pm

Give this a try. apt install alsa-tools-gui and once it's installed hdajackretask

I'm guessing you will not have to select the device in the box in the upper left, but wherever it shows the internal mic, click on Override then test the mic. If that works, click on Install boot override.

I don't have experience using that app, so if it doesn't work you might try searching for how others got things working with it.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 5:56 pm

The microphone doesn't exist, only the speaker and headphone jack.

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 5:59 pm

WOW. What does dmesg | grep snd return?

User avatar
MrEen
Level 7
Level 7
Posts: 1692
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 6:04 pm

I have to head out for a bit. Check your BIOS as well to make sure the sound input isn't disabled or something.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 6:16 pm

dmesg | grep snd
[ 15.307397] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 15.480609] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 15.480611] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 15.480613] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 15.480615] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 15.480615] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10346.202429] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10346.230167] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10346.230176] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10346.230182] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10346.230186] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10346.230189] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10346.230195] snd_hda_codec_realtek hdaudioC0D0: Mic=0x12
[10544.837607] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10544.869505] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10544.869508] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10544.869510] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10544.869512] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10544.869513] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10544.869515] snd_hda_codec_realtek hdaudioC0D0: Mic=0x13
[10680.283683] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10680.322399] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10680.322402] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10680.322404] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10680.322405] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10680.322407] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10729.264225] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10729.284044] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10729.284046] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10729.284048] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10729.284049] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10729.284051] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10729.284052] snd_hda_codec_realtek hdaudioC0D0: Mic=0x13
[10849.050366] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10849.079435] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10849.079437] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10849.079439] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10849.079440] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10849.079441] snd_hda_codec_realtek hdaudioC0D0: inputs:
[10849.079443] snd_hda_codec_realtek hdaudioC0D0: Mic=0x18
[10910.029207] snd_hda_codec_realtek hdaudioC0D0: hda-codec: reconfiguring
[10910.048582] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC256: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[10910.048584] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[10910.048586] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[10910.048587] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[10910.048588] snd_hda_codec_realtek hdaudioC0D0: inputs:

Post Reply

Return to “Hardware Support”