ALC256 sound - Internal Microphone not working on Linux (Mint and Ubuntu)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sun Oct 14, 2018 2:04 pm

MrEen wrote:
Sun Oct 14, 2018 11:48 am
One other thing worth trying is instead of model=laptop-dmic, see if model=laptop-amic in the alsa-base.conf file helps.

Or model=inv-dmic is another possibility. This one actually sounds promising, although it's probably because I don't understand what it means.
Changing to amic, there is movement for inputs in the sound preferences however the movement is not consistent with an sounds.
The other one doesn't work at all.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sun Oct 14, 2018 2:05 pm

So I found a somewhat official fix but I don't know how to implement it.
Could someone please explain to me how to implement this...

https://www.systutorials.com/linux-kern ... linux-4-1/

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by sebastjava » Sun Oct 14, 2018 2:59 pm

esc11 wrote:
Sun Oct 14, 2018 2:04 pm
Changing to amic, there is movement for inputs in the sound preferences however the movement is not consistent with an sounds.
...
While waiting for an answer on your promising official solution, you could try this: open alsamixer, press F4 key, turn Mic Boost to zero, then check sound preferences again. "Movement is not consistent with any sounds." Still? Try adjusting input level.

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by sebastjava » Sun Oct 14, 2018 8:30 pm

I really insist you give a try to my instructions in my preceding post. Please. It takes just a few seconds.

First, make sure you are still using that line:
options snd-hda-intel model=laptop-amic

Next, check your "Sound Preferences". Do you still get "movement for inputs in the sound preferences however the movement is not consistent with any sounds" !?? I hope so.

Now, open alsamixer again. Press F4. Do you see any Mic Boost level? Is it turned on? Set it to zero. Go back to your Sound Preferences. How does it looks now on the input tab? Try some mic input software like Cheese.

I have some hopes here. Not much but it is worth the test. Let me explain. On my little notebook, there is a Mic Boost control. The default value was 100 before i permanently changed it to zero. When Mic Boost is at 100, the input level is so over amplified it is just 100% white noise and at maximum volume and the bar graph is not moving at all. At intermediate values it is still mainly white noise and the bar graph moves a bit, randomly. But when the Mic Boost is set to zero, well... the microphone works perfectly!
Attachments
Capture du 2018-10-14 20-02-07.png

User avatar
MrEen
Level 7
Level 7
Posts: 1735
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sun Oct 14, 2018 9:15 pm

esc11 wrote:
Sun Oct 14, 2018 2:05 pm
So I found a somewhat official fix but I don't know how to implement it.
Could someone please explain to me how to implement this...

https://www.systutorials.com/linux-kern ... linux-4-1/
That is a patch to the kernel that as far as I can tell, has probably already been implemented. I could be wrong.

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Misleading title - Internal Microphone not working

Post by sebastjava » Mon Oct 15, 2018 10:48 am

Your title is misleading, in my opinion. It is not a LM Cinnamon 19 problem. It is a Ubuntu problem. You could try installing Ubuntu, Lubuntu, Xubuntu, LM Xfce or Mate, you would still be stuck with this problem.

A good title would be: " Acer Swift 3 - Internal Microphone not working " Because it is a hardware-specific issue.

First, try changing the Mic Boost setting, as i said before.

Then i would suggest you try every possible alsa-base.conf option for your chip/codec: ALC256 Analog. Analog? That is what i found on your Fri Oct 12, 2018 3:15 pm post.

The keywords for your Google searches are:
Ubuntu - Acer Swift 3 - Acer Swift SF314-54 - Alsa - alsa-base.conf - ALC256 - Microphone - Input - hdajackretask

Those keywords resume what i feel about this problem. It is listed by order of importance. This "ALC256" is pretty significant, in my opinion.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Mon Oct 15, 2018 11:17 am

sebastjava wrote:
Sun Oct 14, 2018 8:30 pm
I really insist you give a try to my instructions in my preceding post. Please. It takes just a few seconds.

First, make sure you are still using that line:
options snd-hda-intel model=laptop-amic

Next, check your "Sound Preferences". Do you still get "movement for inputs in the sound preferences however the movement is not consistent with any sounds" !?? I hope so.

Now, open alsamixer again. Press F4. Do you see any Mic Boost level? Is it turned on? Set it to zero. Go back to your Sound Preferences. How does it looks now on the input tab? Try some mic input software like Cheese.

I have some hopes here. Not much but it is worth the test. Let me explain. On my little notebook, there is a Mic Boost control. The default value was 100 before i permanently changed it to zero. When Mic Boost is at 100, the input level is so over amplified it is just 100% white noise and at maximum volume and the bar graph is not moving at all. At intermediate values it is still mainly white noise and the bar graph moves a bit, randomly. But when the Mic Boost is set to zero, well... the microphone works perfectly!
Sorry had some other problems.
I don't have that option in alsamixer there is only such an option with dmic

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Misleading title - Internal Microphone not working

Post by esc11 » Mon Oct 15, 2018 11:29 am

sebastjava wrote:
Mon Oct 15, 2018 10:48 am
Your title is misleading, in my opinion. It is not a LM Cinnamon 19 problem. It is a Ubuntu problem. You could try installing Ubuntu, Lubuntu, Xubuntu, LM Xfce or Mate, you would still be stuck with this problem.

A good title would be: " Acer Swift 3 - Internal Microphone not working " Because it is a hardware-specific issue.

First, try changing the Mic Boost setting, as i said before.

Then i would suggest you try every possible alsa-base.conf option for your chip/codec: ALC256 Analog. Analog? That is what i found on your Fri Oct 12, 2018 3:15 pm post.

The keywords for your Google searches are:
Ubuntu - Acer Swift 3 - Acer Swift SF314-54 - Alsa - alsa-base.conf - ALC256 - Microphone - Input - hdajackretask

Those keywords resume what i feel about this problem. It is listed by order of importance. This "ALC256" is pretty significant, in my opinion.
The problem is with the ALC256 sound card (which has been in circulation for, what I can gather, 1 and a half year. Since on all Linux distros people with so far 3 different brands (Acer, Asus and Panasoncic) have had the problem.
All slightly different some getting a fix others (like myself) getting nowhere. Some having both a microphone and speaker problem, others only headphones etc.
So I have sort of given up until either Kernel or whoever fixes the bug in the driver code.
Also everyone has noted that this problem does not occur on Windows.

Post Reply

Return to “Hardware Support”