CPU Scalling slowing down during gaming

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 5
Joined: Sun Oct 14, 2018 6:43 pm

CPU Scalling slowing down during gaming

Post by David556 » Sun Oct 14, 2018 7:21 pm

Hello everyone.

I'm new here so I am not sure my post will be complete. But I will try to make it as complete as I can, following the headlines given.

Let me explain the problem: This weekend I have been feeling like gaming, particular Day of Defeat Source. So I start my computer with Linux Mint 19 Tara MATE, open Steam and run the Game. It works fine for a few minutes, after which it starts lagging like hell, becoming unplayable. This came as a big surprise: in Windows, the game works just fine, and went to confirm it, sucessfully: it still works fine on the computer i'm using, but with windows in dual booth.

I researched on the Internet a bit and came to the conclusion that this was because of CPU Throttling ( which later I confirmed, with the command watch grep \"cpu MHz\" /proc/cpuinfo). The recommendations I found were to change my CPU Power Settings ( I believe that that's how they're called?) from powersave to performance, which I did. This only helped a little bit: the game works fine for more that what it used to, but it still lags after a few minutes, but this time still being playable, and coming back to normal some seconds seconds later.
Running watch grep \"cpu MHz\" /proc/cpuinfo and sensors at the same time as the game shows a very interesting fact. In performance mode, the CPU runs at 2195 MHz in both cores most of the time, except that it reduces drastically to less than 800MHz at some points during the gameplay, going to full speed again after. I have come to find out that this happens because my computer reaches 80ºC ( which sensors says it's "high" and does it, I believe, to cool down, which actually happens, with temperatures dropping to around 76ºC. This is what makes the game go slower for a few seconds.

Now, let me tell you what happens in Windows. I monitored the computer performance at the same time the game was running. The CPU temperatures are around 84-85ºC ( which sensors says it's the critical temperature) and the CPU never runs at full frequency, but rather at around 1600~1800 MHz

I would be actually ok with this if it wasn't for the fact that Windows runs the game fine and that this game has been optimized for Linux.

I have tried to searched for a solution that doesn't allow the CPU to go as low as that and let it be okay with going over 80ºC. The latter actually helps it but just a little and it was with a Script.

Any of you guys know a solution? Or has had similar problems?

Here's the inxi -Fxz

Code: Select all

System:    Host: david-K54C Kernel: 4.15.0-36-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: K54C v: 1.0 serial: N/A
           Mobo: ASUSTeK model: K54C v: 1.0 serial: N/A
           BIOS: American Megatrends v: K54C.207 date: 04/18/2012
CPU:       Dual core Intel Pentium B960 (-MCP-) 
           arch: Sandy Bridge rev.7 cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3) bmips: 8780
           clock speeds: max: 2200 MHz 1: 1507 MHz 2: 1466 MHz
Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x1024@75.02hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
           version: 3.3 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Ralink RT5390 Wireless 802.11n 1T/1R PCIe
           driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: port: a000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 324.1GB (12.2% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD0 size: 320.1GB
           ID-2: USB /dev/sdb model: UDisk size: 4.0GB
Partition: ID-1: / size: 101G used: 37G (39%) fs: ext4 dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3000
Info:      Processes: 185 Uptime: 1:41 Memory: 2218.4/3846.9MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
TL;DR: When I game, games slow down for a few seconds to keep the temperature in check. Changing CPU powerstate doesn't fix it and I don't have that problem when on Windows. Is there anything I can do to fix it?

Level 1
Level 1
Posts: 5
Joined: Sun Oct 14, 2018 6:43 pm

Re: CPU Scalling slowing down during gaming

Post by David556 » Wed Oct 17, 2018 11:09 am

Thank you everyone who watched and tried to figure out an answer. I Found the problem. Thermald was Throttling my CPU to those very low values, making gaming hard as a consequence. For this, I uninstalled it. I am not having any overheating issues whatsoever. I Believe my computer comes with it's own cooling settings.

Post Reply

Return to “Hardware Support”