JBL Bluetooth headset keeps crashing bluetooth drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
DyingDutchman
Level 1
Level 1
Posts: 1
Joined: Mon Oct 15, 2018 5:06 am

JBL Bluetooth headset keeps crashing bluetooth drivers

Post by DyingDutchman » Mon Oct 15, 2018 5:23 am

I got a problem where my JBL bluetooth headset keeps crashing my bluetooth drivers after working fine for a couple of minutes (the interval is completely random. Some days it works fine).

I am running the latest version of Linux Mint 64 bit on a Asus K56CB-XX396H laptop (upgraded with a SAMSUNG SSD).

I have already changed the bluetooth discover command to be executed after my system has booted, instead of during boot, but that changes nothing. I removed the normal mint bluetooth manager in favor of Blueman, which worked better, but did not solve the issue.

After the crash occours, blueman (or other bluetooth managers) seem to flip out and become unresponsive. When i kill the bluetooth process, blueman errors into a "Connection Failed: blueman.bluez.errors.DBusFailedError: Software caused connection abort" error. afterwards the entire applet becomes unresponsive, and i can no longer find my bluetooth device in my list of active devices (which i think is logical)

Then i restart bluetooth with:

Code: Select all

sudo service bluetooth restart
I get no error and my device does show up, but blueman is still unresponsive. So i try to kill and restart blueman, but that does not change it's behaviour.

Restarting my pc fixes the issue, before it starts coming back again after a few minutes most of the time. Most answers i found while searching ask to do the same stuff i described above, but it clearly does not seem to work.

Do i have some sort of compatibillity issue with the bluetooth drivers? If yes, i do not mind running a command every once in a while to fix it, but i just can't find the command to make it work again.

Code: Select all

rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Code: Select all

lspci -knn | grep Net -A2; lsusb
libkmod: ERROR ../libkmod/libkmod-config.c:635 kmod_config_parse: /etc/modprobe.d/disable-btcoex.conf line 1: ignoring bad line starting with '<<<'
03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
	Subsystem: AzureWave AR9485 Wireless Network Adapter [1a3b:2c97]
	Kernel driver in use: ath9k
	Kernel modules: ath9k
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 13d3:5165 IMC Networks 
Bus 001 Device 003: ID 13d3:3362 IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046d:c068 Logitech, Inc. G500 Laser Mouse
Bus 003 Device 002: ID 045e:00dd Microsoft Corp. Comfort Curve Keyboard 2000 V1.0
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

pacmd list-sinks
1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE 
	priority: 9959
	volume: front-left: 0 /   0% / -inf dB,   front-right: 0 /   0% / -inf dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: yes
	current latency: 0,00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 1
	configured latency: 0,00 ms; range is 0,50 .. 371,52 ms
	card: 0 <alsa_card.pci-0000_00_1b.0>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC270 Analog"
		alsa.id = "ALC270 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf7a18000 irq 32"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1e20"
		device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Realtek ALC270"
		alsa.components = "HDA:10ec0270,10431587,00100100 HDA:80862806,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>

Code: Select all

bluetoothctl
[NEW] Controller 6C:71:D9:72:AB:FE user-K56CB [default]
[NEW] Device 78:44:05:A9:C0:A5 JBL T450BT

Code: Select all

sudo apt-get install pulseaudio-module-bluetooth
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pulseaudio-module-bluetooth is already the newest version (1:8.0-0ubuntu3.10).
0 upgraded, 0 newly installed, 0 to remove and 497 not upgraded.

pactl load-module module-bluetooth-discover
Failure: Module initialization failed
EDIT:

I finally found a script that does manage to reset my bluetooth by undbinding the usb controller on which the bluetooth module is updated, and then rebinding it.

Code: Select all

echo -n "1-1.1:1.0" | sudo tee /sys/bus/usb/drivers/btusb/unbind
echo -n "1-1.1:1.0" | sudo tee /sys/bus/usb/drivers/btusb/bind
It still does not fix my bluetooth from crashing though, so advice is still appreciated.

EDIT 2:

Never mind. It fixed it once. The second time it happened blueman no longer shows up in the tray and i am unable to connect any bluetooth device until i restart.

MigueLEsPaul
Level 1
Level 1
Posts: 1
Joined: Mon Oct 15, 2018 9:10 am

Re: JBL Bluetooth headset keeps crashing bluetooth drivers

Post by MigueLEsPaul » Mon Oct 15, 2018 9:30 am

Hello ! I have similar issue with my MOW! headset.I am using Linux Mint 19 Tara on an HP notebook. I thought it was an issue of this specific device until I tested with a different headset and speakers. I also installed blueman with no different results. It start working fine and then it cracks randomly, or, if it works, the sound comes out rippled and with delays and pitch variations.
This is what comes out of ```dmesg|grep -i blue``` on my machine :

```
[ 2.882445] usb 1-1.6: Product: Bluetooth Radio
[ 20.315642] Bluetooth: Core ver 2.22
[ 20.315662] Bluetooth: HCI device and connection manager initialized
[ 20.315667] Bluetooth: HCI socket layer initialized
[ 20.315670] Bluetooth: L2CAP socket layer initialized
[ 20.315677] Bluetooth: SCO socket layer initialized
[ 20.325347] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[ 20.325349] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[ 20.382697] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[ 20.382700] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[ 20.447348] Bluetooth: hci0: rom_version status=0 version=1
[ 20.447356] Bluetooth: hci0: cfg_sz 0, total size 22496
[ 35.726580] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 35.726582] Bluetooth: BNEP filters: protocol multicast
[ 35.726585] Bluetooth: BNEP socket layer initialized
[ 47.257284] Bluetooth: RFCOMM TTY layer initialized
[ 47.257290] Bluetooth: RFCOMM socket layer initialized
[ 47.257296] Bluetooth: RFCOMM ver 1.11
```

it says it cannot load the driver configuration from the default. I don't really know what this means, if it is trying with a default set of drivers that does not suit my specific hardware or something. I wish I have a solution for you and not a slightly different issue... Hope some folks with more insight knowledge could respond to our questions.

Post Reply

Return to “Hardware Support”