[SOLVED] No Sound on Notebook

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

[SOLVED] No Sound on Notebook

Post by dzhDante » Tue Oct 16, 2018 7:33 am

Hi guys! Sorry if I opened this topic on the wrong section. I´m pretty new here. :) I recently bought a new laptop and I installed mint 19 on it. It is a i7-8750H, 32 Gb of RAM, and has a GPU Nvidia GTX 1070 (8 Gb). Since a installed mint 19, there is no sound on the laptop and I don´t know anymore what to do. I read a lot of stuff on internet about modules and all but nothing I tried solved my issue. Can you guys help me plz?
Last edited by dzhDante on Fri Nov 30, 2018 4:30 pm, edited 1 time in total.

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Oct 16, 2018 7:19 pm

Hi dzhDante.

Open a terminal and paste the following into it to see if any errors are reported:

Code: Select all

aplay /usr/share/sounds/alsa/Front_Center.wav
Also in the terminal, paste back the results of inxi -Fxz and aplay -l

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Wed Oct 17, 2018 9:48 am

Ok!

Command:
aplay /usr/share/sounds/alsa/Front_Center.wav
NOTE: When I execute the aplay command, there is no sound on the laptop.
Result

Code: Select all

Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono


Comand:
inxi -Fxz

Result:

Code: Select all

System:    Host: pedro-g1570 Kernel: 4.15.0-36-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Notebook product: G1570 serial: N/A
           Mobo: Notebook model: P95xER serial: N/A
           UEFI: American Megatrends v: 7.006 date: 05/18/2018
Battery    BAT0: charge: 46.7 Wh 82.5% condition: 56.6/53.2 Wh (106%)
           model: Notebook BAT status: Discharging
CPU:       6 core Intel Core i7-8750H (-MT-MCP-) 
           arch: Skylake rev.10 cache: 9216 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26496
           clock speeds: max: 4100 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz 5: 800 MHz 6: 800 MHz 7: 800 MHz 8: 800 MHz 9: 800 MHz
           10: 800 MHz 11: 800 MHz 12: 799 MHz
Graphics:  Card-1: Intel Device 3e9b bus-ID: 00:02.0
           Card-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@120.00hz
           OpenGL: renderer: GeForce GTX 1070 with Max-Q Design/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card Intel Device a348 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Intel Device a370 driver: iwlwifi bus-ID: 00:14.3
           IF: wlo1 state: up speed: N/A duplex: N/A mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 980.2GB (9.0% used)
           ID-1: /dev/sda model: WDC_WDS500G2B0B size: 500.1GB
           ID-2: /dev/sdb model: SanDisk_SDSSDA48 size: 480.1GB
Partition: ID-1: / size: 439G used: 82G (20%) fs: ext4 dev: /dev/sdb2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.0C mobo: N/A gpu: 0.0:46C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 304 Uptime: 1 min Memory: 1105.1/32021.4MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56  
Command:
aplay -l

Result:

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1220 Analog [ALC1220 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1220 Digital [ALC1220 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Wed Oct 17, 2018 6:25 pm

So far so good. I am hoping it is just a simple config issue.

Start a song or video and while it is playing run pacmd list-sinks in the terminal. Paste back the results and we can hopefully tell you what to change so you can hear it.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Fri Oct 19, 2018 4:58 pm

Ok!

Results:

Code: Select all

1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: 
	priority: 9039
	volume: front-left: 37097 /  57% / -14,83 dB,   front-right: 37097 /  57% / -14,83 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 78,32 ms
	max request: 15 KiB
	max rewind: 64 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Estéreo
	used by: 1
	linked by: 1
	configured latency: 90,00 ms; range is 0,50 .. 371,52 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC1220 Analog"
		alsa.id = "ALC1220 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa5410000 irq 145"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Estéreo analógico"
		device.description = "Áudio interno Estéreo analógico"
		alsa.mixer_name = "Realtek ALC1220"
		alsa.components = "HDA:10ec1220,155895e1,00100003"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Alto-falantes (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Fones de ouvidos (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>


User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Fri Oct 19, 2018 7:03 pm

This is the part causing the problem:

Code: Select all

analog-output-speaker: Alto-falantes (priority 10000, latency offset 0 usec, available: unknown)
From the looks of your inxi report, I am guessing you are dual booting with Windows. If this is the case, please boot back into Windows then do a complete shutdown. Wait 10 seconds then power up and boot into Mint and test your sound. It is possible that Windows left something in an unclean state and this should take of that. If this doesn't help, we have other things we can try.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Tue Oct 23, 2018 9:49 am

It didn't work. :( I did everything, unchecked the "shutdown optimization" on windows, completely turned off my notebook, started it again after 10 seconds and boot Mint. And yet no sound. I'm sorry for all the trouble, man...

PS: Yes, I do have dual boot on my laptop. Every SO has its own disk (I have two disks - HD - on my laptop).

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Oct 23, 2018 3:43 pm

Okay. I think you're going to have to install alsa-tools-gui then run hdajackretask in the terminal. When it opens, make sure the ALC1220 is in the box in the upper left corner. After that, I'm not much help, but here are a couple of threads where it was used successfully:

viewtopic.php?f=48&t=279947&p=1542019&h ... k#p1542019

viewtopic.php?f=48&t=276433&p=1519491&h ... k#p1519491

Good luck, and don't be afraid to ask for more help if you need it.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Tue Nov 06, 2018 6:37 am

So, I've been away for some time (sorry for the delay on the answer), but I tried everything that posted here, and nothing yet. No sound. xD
I tried every setup on the hdajackretask, but nothing worked. I passed my hole weekend trying to make it work, but I didn't make it. :(

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Nov 06, 2018 8:21 am

I had written the part below before I found a possible workaround for your ALC1220 codec which we'll try first.

In the terminal type xed admin:///etc/modprobe.d/alsa-base.conf then scroll to the bottom of the file and add this line:

Code: Select all

options snd-hda-intel model=dual-codecs
Save the file, reboot and test sound. If that didn't help, undo the change then follow the next part.



Maybe you need to follow the steps here: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

When it instructs to download a deb file, get the one from the Bionic section.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Tue Nov 13, 2018 7:16 am

Nice! Things got a little better now!
I added this line

Code: Select all

options snd-hda-intel model=dual-codecs

on the alsa-base.conf and guess what: There is no sound on the speakers, BUT, now my headphones work! I can listen to anything on my notebook!
I belive we are close to solve the problem!
I didn´t make the last part (this steps: ttps://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS). If You want me to do it, just say it and I will!

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Nov 13, 2018 8:35 am

Hey, we're getting somewhere!

Before trying the ALSA upgrade, I'd suggest trying this:

Run alsamixer in the terminal. If you don't see ALC1220 for Chip in the upper left corner press F6 to change the card. Make sure nothing is muted which would have MM at the bottom of the column. Use left and right arrows to select columns, use the m key to toggle mute/unmute, and use the up and down arrows to raise and lower levels. Be aware that there might be more columns than you can see. Keep using the right arrow until it won't go any farther.

Also, if you don't already have it, install and run PulseAudio Volume Control (pavucontrol.) Go to the Output Devices tab while listening to something on the headphones, then unplug the headphones. Did the Port switch and if so, to what? Can you change it to Speakers or Line Out yourself even if it says (unplugged) and does it make any difference.

Good luck.

simpsontruckdriver
Level 1
Level 1
Posts: 6
Joined: Tue Nov 13, 2018 5:39 pm

Re: No Sound on Notebook

Post by simpsontruckdriver » Tue Nov 13, 2018 6:33 pm

My sound just died, and none of the steps worked, except one: shutting down for a minute. I also dual boot between Linux Mint 19 Cinnamon and Windows 10 (*ugh*). I think that should be #1 diagnostics for sound that does not work: do not reboot, turn the computer off for 60 seconds! Also, I tried to do some diagnostics on "ItsFoss", it wound up messing up Cinnamon. So, NO ONE should use external non-LinuxMint sites to diagnose, since it may wind up messing up your system. Just glad I came here and got it fixed!

TS

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Nov 13, 2018 7:38 pm

Hi simpsontruckdriver, and welcome to the forum.

Overall, nice post. When working sound suddenly dies, removing the files in ~/.config/pulse and running pulseaudio -k in the terminal will often fix it. Your shutdown fix is something I often forget to recommend to dual booters, but it is a good step to take.

In the OP's case, they didn't have sound upon installation of the OS. This is what I've noticed most often on this forum regarding sound issues, and while a full shutdown is still a good idea, it's usually some other issue in these cases.

Thanks for the post.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Mon Nov 26, 2018 10:13 am

sorry the delay again. This end of the yaer has been painfully dificult, lol. Promisse I´ll try to answer faster next time.

I did what you asked. started alsamixer and my chip is correct (ALC1220). I unmuted (reactivated) all outputs that were muted. Then I installed the pavucontrol package and started it. The principle works just fine, when I´m listening (or not listening) to anything on my speakers and plug my headphones, the audio output automactilly change to the headphone output, and when I remove the headphone, the audio output automactly change to my speakers, but no sound goes out. But still there is no sound on them (speakers).

The funny part is, when the speakers are active, the sound bar moves like if the speakers were realy making any sound.

Got any ideas?

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Mon Nov 26, 2018 5:56 pm

No worries about the delay, dzhDante.

I have learned more about the use of hdajackretask since I first suggested using it. To be able to help you use it, I need to see the output of dmesg | grep snd please.

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Tue Nov 27, 2018 8:41 am

HI MrEen! Thanks for your efforts! Realy, thank you a lot!
Here we go!

Code: Select all

[    6.315448] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    6.315614] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    6.347845] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=1 (0x1b/0x0/0x0/0x0/0x0) type:speaker
[    6.347846] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.347847] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
[    6.347848] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    6.347849] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
[    6.347849] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    6.347850] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[    6.347851] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Tue Nov 27, 2018 6:01 pm

First off, I've never seen something like this from your paste:

Code: Select all

[    6.315448] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    6.315614] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
No idea whatsoever if this is good, bad or indifferent. The way I read that, you audio bus-id (0000:00:1f.3) is "bound" to your Intel video bus-id (0000:00:02.0), whatever that means. Usually, you'd have an HDMI option that would've been bus-id 0000:00:02.1 (or .1 on the end of the nvidia card's bus-id.)

Anyway, we'll not worry about that for now.

Run hdajackretask by typing hdajackretask & in the terminal (or from your Menu.) The reason for the ampersand is so you can use the terminal to test your sound in a later step while hdajackretask is still running. Make sure ALC1220 is showing in the upper left corner where it says Select a codec:. Now click on Show unconnected pins up high on the right. On the left, select one of the unconnected pins by clicking on its Override checkbox, then click on the box to see what options are available. As your dmesg output did not list internal speakers, I'd suggest finding an unconnected pin that gives you that choice (Internal Speaker) and once it is selected, click on Apply near the lower right. Test your sound in the terminal with speaker-test -t wav -c 6 and use Ctrl-c to stop it. If no sound, undo that change and try another unconnected pin. Some pins won't have the option to change them to Internal speaker. I'm hoping you can find a pin that makes the speakers work. If you do, then click on Install boot override near the lower left and you should be all set.

If at any time you feel like you may have messed anything up (like changing an existing in use pin) you can simply close hdajackretask and start over. Nothing will be saved until you click on Install boot override. Even after doing that, Remove boot override is available to undo any changes any time down the road.

The weird thing is I was expecting to see a pin for the speakers in your dmesg output that I was going to have you set to unconnected then try a different pin, but that wasn't even necessary.

Anyway, hopefully that all makes sense and is actually productive this time.

The important things to remember are to click on Apply before every sound test and only click on Install boot override when sound is working.

Good luck! :)

dzhDante
Level 1
Level 1
Posts: 13
Joined: Tue Oct 16, 2018 7:22 am

Re: No Sound on Notebook

Post by dzhDante » Wed Nov 28, 2018 9:56 am

I´ve tried what you ask.
I Did one unconnected pin after another, always selecting Internal Speakers¨, applying, testing the sound with the speaker-test -t wav -c 6 command, then unchecking the override option, applying again, selecting the next unconnected pin, and so on...and yet no sound, with any option chosen.

Any ideas? lol

User avatar
MrEen
Level 9
Level 9
Posts: 2899
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound on Notebook

Post by MrEen » Wed Nov 28, 2018 3:30 pm

Damn! I was really hoping that would work.

I think the best step at this point would be to go back to this post and try changing dual-codecs to auto. You may lose the headphones after rebooting, but then again, you may gain the speakers. Using auto has helped some people where it wasn't listed as an option for their codec, so we can hope it'll fix things for you.

If it doesn't fix everything, do another pacmd list-sinks with sound playing so I can see any changes in the config as well as dmesg | grep snd again.

It's possible there'll be some changes but still not working, so it'll be back to hdajackretask with the auto setting.

Good luck.

Post Reply

Return to “Hardware Support”