Mint 19: Nemo thinks my hard drives are removable

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
foberle
Level 1
Level 1
Posts: 35
Joined: Fri Oct 13, 2017 4:52 pm

Mint 19: Nemo thinks my hard drives are removable

Post by foberle » Tue Oct 16, 2018 12:56 pm

I just did a new installation of Mint 19/Cinnamon and am running into something I've not encountered before.

Since the days of Windows 95, I've had multiple partitions on multiple hard drives in order to facilitate OS upgrades, backups, seccurity, etc. etc. and have never had an issue doing that.

On my current machine I have an SSD and two hard drives. The SSD has three partitions, one with the new Mint 19, and the other two with Mint 18.3 and Ubuntu 16.04; all of these share access to all the partitions on the hard drives.

The issue I'm having with Mint 19 is that Nemo shows all of the "replacements" for standard folders as removable drives. For instance, I have a partition on a fixed hard drive which contains all of my music files. In Mint 18.2 and 18.3, as well as previous versions of Ubuntu going back to 11.04, the entry in my /etc/fstab file was:

Code: Select all

## /dev/sdb9: LABEL="Music"
UUID=17aded39-beee-4e51-86ed-b4d657dfb395 /mnt/Music        ext4 nodev,nosuid,commit=10         0 2
Towards the end of fstab, the following line "connected" that partition to the standard Music directory:

Code: Select all

/mnt/Music       /home/frank/Music       auto bind 0 0
Adding Bookmarks in Nemo (or Nautilus before that) for everything made for a nicely ordered sidebar, and permitted the addition of more descriptive comments (e.g. to show the difference between "Music" and "Scores" partitions).

All this still "works" in that I can access the files from any of the currently installed OSs, as well as two Virtual Machines I have installed using VirtualBox. But having the panel icon ALWAYS DISPLAYED is rather annoying and, I suspect, will be the "Applet that cried Wolf" if I become so used to it that I shut down without disconnecting an actual removable drive (such as my backup drives, camera, tablet, or whatever).

I tried commenting out the bind line, and changing the mount line to the following:

Code: Select all

## /dev/sdb9: LABEL="Music"
UUID=17aded39-beee-4e51-86ed-b4d657dfb395 /home/frank/Music ext4 nodev,nosuid,commit=10         0 2
... but that didn't change anything.

I then attempted to see if there were possibly some naming conflicts that the new version of nemo doesn't care for; as it turns out, though, the partition I have attached to the standard Pictures directory is not labeled "Pictures" but "Imaging" so that doesn't seem to be the case.

I've trolled through /dev and /sys/devices but, having never encountered this situation before, don't know what I'm looking for. I found one seemingly detailed discussion that mentioned a "removable" subdirectory under /sys/devices but I don't have any such directory on any of the three installed OSs.

Does anyone know what's different about the distinction between fixed and removable drives in Mint 19 (or perhaps even in Ubuntu 18.04, on which it's based? Thanks.

altair4
Level 19
Level 19
Posts: 9278
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint 19: Nemo thinks my hard drives are removable

Post by altair4 » Tue Oct 16, 2018 1:55 pm

Took me a bit to follow your description but the answer is: It's a bug. Not in Mint but in Gnome.

What you would like to do is this:
/mnt/Music /home/frank/Music auto bind,x-gvfs-hide 0 0
x-gvfs-hide disables any mount from displaying on the desktop or side panel of the file manager but it doesn't work for a bind mount: fstab binds appear as mounts (x-gvfs-hide is being ignored)

It should work with this though:
UUID=17aded39-beee-4e51-86ed-b4d657dfb395 /home/frank/Music ext4 nodev,nosuid,commit=10,x-gvfs-hide 0 2
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

foberle
Level 1
Level 1
Posts: 35
Joined: Fri Oct 13, 2017 4:52 pm

SOLVED: Mint 19: Nemo thinks my hard drives are removable

Post by foberle » Tue Oct 16, 2018 3:23 pm

Wow!! Sanity restored...

I doubt if I would ever have found that. I began using the bind lines somewhere in the dim dark past because I couldn't use the existing "standard" directories as mount points due to some bug; since I was already doing binds for other partitions, it actually made the fstab look more consistent, and I just continued doing that until now.

This is also the first time I've seen the x-gvfs-hide option; I just went back through all the stuff I downloaded while trying to figure out what's going on, and I can't find it mentioned anywhere.

So, thanks very much for a fast and useful response ...

Post Reply

Return to “Hardware Support”