Nvidia G-sync with multi-monitor setup

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
PatrikOnLinux
Level 1
Level 1
Posts: 3
Joined: Wed Sep 19, 2018 1:31 pm

Nvidia G-sync with multi-monitor setup

Post by PatrikOnLinux » Wed Oct 17, 2018 5:51 am

Hi,
I'm running a 1080 TI with a G-sync monitoring and Linux Mint 19 (64-bit) Cinnamon.
I recently installed the latest Nvidia drivers 410.66 that was released a couple of days ago.

On google I see some old (2017 and back) forum post saying that G-sync does not work with multi-monitor setup were not all is G-sync monitors.
Is this still true? Have anybody got this to work?
Some forum post says that Cinnamon is not compatible with G-sync due to Compositior in Cinnamon.
But i haven't found a way to try to disable the Compositior in Cinnomon to test this.

In Nvidia X-server i've enabled "Sync to VBlank", "Allow flipping", "allow G-sync", "Enable G-sync Visual Indicator".
But in-game i dont even get the visual indicator in the top right corner. It doen't even shows as "off".

I tried it in a native game Rise of the tomb raider.
I've ran in to a stop on this and don't know what to do next.
I'm quite new to Linux and hope you guys can help me :)

EDIT:
Forgot something.

Code: Select all

inxi -Fxz
System:    Host: patrik-desktop-gaming Kernel: 4.18.12-041812-generic x86_64 bits: 64 gcc: 8.2.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: MSI model: Z97 GAMING 3 (MS-7918) v: 1.0 serial: N/A
           UEFI: American Megatrends v: V2.10 date: 02/16/2016
CPU:       Quad core Intel Core i7-4790K (-MT-MCP-) arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 32003
           clock speeds: max: 4700 MHz 1: 1191 MHz 2: 1449 MHz 3: 1668 MHz 4: 1524 MHz 5: 1403 MHz 6: 1552 MHz
           7: 1212 MHz 8: 1479 MHz
Graphics:  Card: NVIDIA GP102 [GeForce GTX 1080 Ti] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) driver: nvidia
           Resolution: 1920x1080@144.00hz, 1920x1200@59.95hz, 2560x1440@144.00hz
           OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 version: 4.6.0 NVIDIA 410.66 Direct Render: Yes
Audio:     Card-1 Intel 9 Series Family HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GP102 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 Kingston driver: USB Audio usb-ID: 003-002
           Sound: Advanced Linux Sound Architecture v: k4.18.12-041812-generic
Network:   Card: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller driver: alx port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 3002.6GB (18.0% used)
           ID-1: /dev/nvme0n1 model: Samsung_SSD_960_PRO_512GB size: 512.1GB
           ID-2: /dev/sda model: SAMSUNG_HD103SJ size: 1000.2GB
           ID-3: /dev/sdb model: Samsung_SSD_840 size: 250.1GB
           ID-4: /dev/sdc model: SAMSUNG_HD103SJ size: 1000.2GB
           ID-5: /dev/sdd model: WDC_WDS240G2G0A size: 240.1GB
Partition: ID-1: / size: 219G used: 65G (32%) fs: ext4 dev: /dev/sdd2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:55C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 241 Uptime: 1 min Memory: 1514.8/15983.8MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

Post Reply

Return to “Hardware Support”