LM 18.3 MAcbookpro5.5

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
dave8671
Level 3
Level 3
Posts: 140
Joined: Sat Jul 23, 2016 7:04 pm

LM 18.3 MAcbookpro5.5

Post by dave8671 » Thu Oct 25, 2018 2:41 pm

well I was wiping the macs HDD for recycle and through lets try Linux before I recycle. Not to say that I still will not recycle it.

I tried elementary loki first you know mac like all was well till eOS had a kernel update and broken the wifi. I like Eos for other PCs and not macs lets say that. eOS does not seem to have a option to update or not update the kernel. Yesterday I installed LM 18.3 and I am writing this on this mac.

Process of install

I found a article (I will add said article once I find it again) that said format the HDD on a mac ms dos so I did fat32 and this forced it to legacy mode.
When I inserted the LM disc it though it was windows.

The installer did its thing and I was greeted with a live session. I clicked install after I looked at what the system found I use
lspci -v

All hardware was detected
-Airport Wi-Fi has to be manually installed
-Open source driver the Nvidia card is used.


Installed OS and update it and than updated the kernel
kernel 4.15.0-38-generic
Macfanctld
TLP 1.1 from website

Does get warm but it got warm from OSX as well and in the same spot left side and below the display I do h ear the fan off and on etc. Does not shut down or freeze up not yet. I suspect that if I update to another kernel it would brake the Wi-FI and Nvidia drivers on the system. I am not going to since it happened on eOS.

What works
  • Music CD play with Rhythmbox
  • DVD playing (note on if one installs the libdvd.pkg dvds do not play as well this was true with Eos. Mint however
    does not install the libdvd-pkg. just libdvdcss2, libdvdread4, libdvdnav and no issues.)
  • Function keys work out of the box that one would need. Except for F3 and F4 since those were application keys including the ejection button.
  • SD card works

Questions


The GPU is a 9400m and I read a post where I do not remember that said that the driver
Nvidia 340 do not build on newer kernels is this true?

If I try the 340 driver how do I go back to the open source driver if necessary?

The Intel microcode: good to install on a mac?

End questions


Here is the results of inxi -Fxz

Code: Select all

System:    Host: mac-MacBookPro Kernel: 4.15.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia

Machine:   System: Apple (portable) product: MacBookPro5 5 v: 1.0
           Mobo: Apple model: Mac-F2268AC8
           Bios: Apple v: MBP55.88Z.00AC.B03.0906151708 date: 06/15/09

CPU:       Dual core Intel Core2 Duo P7550 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9021
           clock speeds: max: 2261 MHz 1: 1113 MHz 2: 1153 MHz

Graphics:  Card: NVIDIA C79 [GeForce 9400M] bus-ID: 02:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.22hz
           GLX Renderer: NVAC
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes

Audio:     Card NVIDIA MCP79 High Definition Audio
           driver: snd_hda_intel bus-ID: 00:08.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic

Network:   Card-1: NVIDIA MCP79 Ethernet
           driver: forcedeth port: 21e0 bus-ID: 00:0a.0
           IF: enp0s10 state: down mac: <filter>
           Card-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN Controller
           driver: wl bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>

Drives:    HDD Total Size: 161.1GB (6.6% used)

           ID-1: /dev/sda model: TOSHIBA_MK1655GS size: 160.0GB
           ID-2: USB /dev/sdb model: SD_Card_Reader size: 1.0GB

Partition: ID-1: / size: 143G used: 6.4G (5%) fs: ext4 dev: /dev/sda2

           ID-2: swap-1 size: 4.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3

RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors:   System Temperatures: cpu: 65.0C mobo: N/A gpu: 61.0
           Fan Speeds (in rpm): cpu: N/A

Info:      Processes: 194 Uptime: 17 min Memory: 1453.2/3668.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
So far the system is running smooth. I will update this once I try the 340 driver. I do not except it to work but we will see.
Last edited by Moem on Thu Oct 25, 2018 3:29 pm, edited 1 time in total.
Reason: added some formatting

User avatar
dave8671
Level 3
Level 3
Posts: 140
Joined: Sat Jul 23, 2016 7:04 pm

Re: LM 18.3 MAcbookpro5.5

Post by dave8671 » Fri Oct 26, 2018 5:13 pm

Well Tried the nvidia driver 340-104 cinnamon crash after the GUI loaded than it said in Fail back mode. I see Nvidia configuration on the menu. Attached is the log file. Not sure what do I learning about these drivers on Linux.
Attachments
Xorg log .odt
I would like advice on why cinnamon crashed. Function keys do not work in guess in recover mode.
(29.8 KiB) Downloaded 4 times

User avatar
dave8671
Level 3
Level 3
Posts: 140
Joined: Sat Jul 23, 2016 7:04 pm

closed: LM 18.3 MAcbookpro5.5

Post by dave8671 » Sat Oct 27, 2018 5:00 pm

When back to open source driver all is good. system will not hibernate or suspend as normal but its to to being a close hardware and a mac. I am going to test Ubuntu 18.04. Thanks for the replies.

Post Reply

Return to “Hardware Support”