Wifi 5GHz on linux mint 19

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
overkill22
Level 4
Level 4
Posts: 393
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Wifi 5GHz on linux mint 19

Post by overkill22 » Mon Nov 12, 2018 4:40 am

I have a laptop that should be compatible with the 5Ghz wifi (802.11ac if not mistaken), however I can't see any 5Ghz network in my network manager.
I always overlooked at this but now I'd like to give a try and see if there's any difference.

Is there anything I have to do to enable the 5Ghz?

Code: Select all

Network:   Card: Intel Wireless 7265 driver: iwlwifi
System:    Host: UX305FA Kernel: 4.15.0-38-generic x86_64 bits: 64 Desktop: Cinnamon 3.8.9 Distro: Linux Mint 19 Tar

DAMIEN1307
Level 6
Level 6
Posts: 1249
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Wifi 5GHz on linux mint 19

Post by DAMIEN1307 » Tue Nov 13, 2018 11:43 am

are you using a router that is dual band (both 2.4 and 5ghz compatiable?)...if so, have you accessed the router to see what is connecting with each device either 2.4 or 5?
ORDO AB CHAO

User avatar
overkill22
Level 4
Level 4
Posts: 393
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Wifi 5GHz on linux mint 19

Post by overkill22 » Wed Nov 14, 2018 10:52 pm

DAMIEN1307 wrote:
Tue Nov 13, 2018 11:43 am
are you using a router that is dual band (both 2.4 and 5ghz compatiable?)...if so, have you accessed the router to see what is connecting with each device either 2.4 or 5?
yes, the router is dual band and everything is set up correctly from that end. In fact I'm connected to the 5GHz with my phone.
On the other end, the laptop doesn't even see the 5GHz network.

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi 5GHz on linux mint 19

Post by JeremyB » Thu Nov 15, 2018 6:26 am

See https://ubuntuforums.org/showthread.php ... st13614520
Especially
Then set your regulatory domain explicitly. Check yours:

Code: Select all

sudo iw reg get
If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

Code: Select all

sudo iw reg set IS
Of course, substitute your country code if not Iceland. Set it permanently:

Code: Select all

gksudo gedit /etc/default/crda
Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

Code: Select all

REGDOMAIN=IS
Proofread carefully, save and close the text editor.
You will likely need to use xed admin:///etc/default/crda rather than gksudo gedit /etc/default/crda

User avatar
overkill22
Level 4
Level 4
Posts: 393
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Wifi 5GHz on linux mint 19

Post by overkill22 » Thu Nov 15, 2018 7:01 am

JeremyB wrote:
Thu Nov 15, 2018 6:26 am
See https://ubuntuforums.org/showthread.php ... st13614520
Especially
Then set your regulatory domain explicitly. Check yours:

Code: Select all

sudo iw reg get
If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

Code: Select all

sudo iw reg set IS
Of course, substitute your country code if not Iceland. Set it permanently:

Code: Select all

gksudo gedit /etc/default/crda
Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

Code: Select all

REGDOMAIN=IS
Proofread carefully, save and close the text editor.
You will likely need to use xed admin:///etc/default/crda rather than gksudo gedit /etc/default/crda
I don't understand what this is supposed to do

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi 5GHz on linux mint 19

Post by JeremyB » Thu Nov 15, 2018 7:10 am

Normally the iw reg get will show 00 for a code which is generic and may limit what 5GHz channels are used, do iwlist chan to see what channels you can use, you may find the channel used by your router is not in the list and setting your country code might fix it

User avatar
overkill22
Level 4
Level 4
Posts: 393
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Wifi 5GHz on linux mint 19

Post by overkill22 » Thu Nov 15, 2018 7:14 am

JeremyB wrote:
Thu Nov 15, 2018 7:10 am
Normally the iw reg get will show 00 for a code which is generic and may limit what 5GHz channels are used, do iwlist chan to see what channels you can use, you may find the channel used by your router is not in the list and setting your country code might fix it
I can't understand the results I'm getting:

Code: Select all

sudo iw reg get
global
country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
	(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

phy#0 (self-managed)
country 00: DFS-UNSET
	(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
	(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
	(2447 - 2472 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
	(2457 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN
	(5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5250 - 5270 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5270 - 5290 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5290 - 5310 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5310 - 5330 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5490 - 5510 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5510 - 5530 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5530 - 5550 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5550 - 5570 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5570 - 5590 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5590 - 5610 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5610 - 5630 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5630 - 5650 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5650 - 5670 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5670 - 5690 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5690 - 5710 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5710 - 5730 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN

Code: Select all

iwlist chan
tun0      no frequency information.

wlp2s0    32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.462 GHz (Channel 11)

lo        no frequency information.

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi 5GHz on linux mint 19

Post by JeremyB » Thu Nov 15, 2018 7:16 am

What country are you in?

User avatar
overkill22
Level 4
Level 4
Posts: 393
Joined: Fri Jan 16, 2015 6:09 am
Contact:

Re: Wifi 5GHz on linux mint 19

Post by overkill22 » Thu Nov 15, 2018 7:17 am

JeremyB wrote:
Thu Nov 15, 2018 7:16 am
What country are you in?
Traveling, Malaysia at the moment

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi 5GHz on linux mint 19

Post by JeremyB » Thu Nov 15, 2018 7:24 am

Try sudo iw reg set MY, you may have to reboot. See if the iwlist chan changed any

Post Reply

Return to “Hardware Support”