[SOLVED] Disabling Touchscreen but keep Trackpad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
thebrookster
Level 1
Level 1
Posts: 5
Joined: Mon Nov 12, 2018 8:27 am

[SOLVED] Disabling Touchscreen but keep Trackpad

Post by thebrookster » Mon Nov 12, 2018 8:44 am

Hi guys,

Some assistance would be appreciated!

I am running Mint 19 on an Acer Nitro 5 Spin, the touchscreen model.

Problem is, I cracked the screen the other day. So until I get the new screen fitted, I tried to disable the touchscreen with the following:

Code: Select all

# Cracked Screen disabling the kernel module
blacklist hid_multitouch 
This is saved as follows: /etc/modprobe.d/blacklist-hid-multitouch.conf

This works a treat, touchscreen disabled and pointer no longer jumping around. Except, pointer no longer moves at all!! It turns out that this mod not only disables the touchscreen, but the trackpad as well.

Which is not so useful, oddly enough.

Has anyone got a better solution to help tide me through until I replace the screen? Or do I just suck it up and buy a mouse?

Cheers,

Phil
Last edited by thebrookster on Mon Nov 12, 2018 11:33 am, edited 1 time in total.

HaveaMint
Level 4
Level 4
Posts: 484
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: Disabling Touchscreen but keep Trackpad

Post by HaveaMint » Mon Nov 12, 2018 9:23 am

I would disable it with menu/settings/mouse&touchpad settings.
"Tune for maximum Smoke and then read the Instructions".

Esme93
Level 1
Level 1
Posts: 4
Joined: Sun Nov 11, 2018 4:44 pm

Re: Disabling Touchscreen but keep Trackpad

Post by Esme93 » Mon Nov 12, 2018 9:37 am

I have the same problem with my ASUS Vivobook Max, except it has a touchpad called "FTE1200:00 0B05:0201". It'll freeze, but the commands "sudo modprobe -r hid-multitouch && sudo modprobe hid-multitouch" are the only way to turn my trackpad/touchpad back on. Sometimes the keyboard shortcut to toggle my touchpad doesn't work.

thebrookster
Level 1
Level 1
Posts: 5
Joined: Mon Nov 12, 2018 8:27 am

Re: Disabling Touchscreen but keep Trackpad

Post by thebrookster » Mon Nov 12, 2018 9:38 am

HaveaMint wrote:
Mon Nov 12, 2018 9:23 am
I would disable it with menu/settings/mouse&touchpad settings.
I only have the option to disable the trackpad here, not the touchscreen?

I only want to disable the touchscreen, and keep the trackpad in use ideally!

Phil

HaveaMint
Level 4
Level 4
Posts: 484
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: Disabling Touchscreen but keep Trackpad

Post by HaveaMint » Mon Nov 12, 2018 10:56 am

thebrookster wrote:
Mon Nov 12, 2018 9:38 am

I only have the option to disable the trackpad here, not the touchscreen?

I only want to disable the touchscreen, and keep the trackpad in use ideally!

Phil
On my laptop running XFCE DE there is a drop menu to select from my trackpad , touchscreen and external mouse. I am not sure what DE you are running.
"Tune for maximum Smoke and then read the Instructions".

User avatar
thx-1138
Level 6
Level 6
Posts: 1290
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Disabling Touchscreen but keep Trackpad

Post by thx-1138 » Mon Nov 12, 2018 11:00 am

thebrookster wrote:
Mon Nov 12, 2018 9:38 am
............................................
I only want to disable the touchscreen, and keep the trackpad in use ideally!
Option "Ignore" "on"

thebrookster
Level 1
Level 1
Posts: 5
Joined: Mon Nov 12, 2018 8:27 am

Re: Disabling Touchscreen but keep Trackpad

Post by thebrookster » Mon Nov 12, 2018 11:21 am

HaveaMint wrote:
Mon Nov 12, 2018 10:56 am

On my laptop running XFCE DE there is a drop menu to select from my trackpad , touchscreen and external mouse. I am not sure what DE you are running.
Ahh, sorry!

Running Cinnamon as DE.

Phil

HaveaMint
Level 4
Level 4
Posts: 484
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: Disabling Touchscreen but keep Trackpad

Post by HaveaMint » Mon Nov 12, 2018 11:26 am

thebrookster wrote:
Mon Nov 12, 2018 11:21 am
HaveaMint wrote:
Mon Nov 12, 2018 10:56 am

On my laptop running XFCE DE there is a drop menu to select from my trackpad , touchscreen and external mouse. I am not sure what DE you are running.
Ahh, sorry!

Running Cinnamon as DE.

Phil
Do you not get the drop menu as I stated?
"Tune for maximum Smoke and then read the Instructions".

thebrookster
Level 1
Level 1
Posts: 5
Joined: Mon Nov 12, 2018 8:27 am

Re: Disabling Touchscreen but keep Trackpad

Post by thebrookster » Mon Nov 12, 2018 11:31 am

thx-1138 wrote:
Mon Nov 12, 2018 11:00 am
thebrookster wrote:
Mon Nov 12, 2018 9:38 am
............................................
I only want to disable the touchscreen, and keep the trackpad in use ideally!
Option "Ignore" "on"
Perfect!!

This seems to be working, many thanks. I knew that there had to be a solution that was simple.

Many thanks,

Phil

thebrookster
Level 1
Level 1
Posts: 5
Joined: Mon Nov 12, 2018 8:27 am

Re: Disabling Touchscreen but keep Trackpad

Post by thebrookster » Mon Nov 12, 2018 11:36 am

HaveaMint wrote:
Mon Nov 12, 2018 11:26 am
thebrookster wrote:
Mon Nov 12, 2018 11:21 am
HaveaMint wrote:
Mon Nov 12, 2018 10:56 am

On my laptop running XFCE DE there is a drop menu to select from my trackpad , touchscreen and external mouse. I am not sure what DE you are running.
Ahh, sorry!

Running Cinnamon as DE.

Phil
Do you not get the drop menu as I stated?
Nope.
IMG_20181112_153444-1152x544.jpg
IMG_20181112_153436-1152x544.jpg
Phil

HaveaMint
Level 4
Level 4
Posts: 484
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: [SOLVED] Disabling Touchscreen but keep Trackpad

Post by HaveaMint » Mon Nov 12, 2018 12:38 pm

Someone familiar with 19 Cinnamon will have to help you out.
"Tune for maximum Smoke and then read the Instructions".

Post Reply

Return to “Hardware Support”