No Wifi available [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
abdemirza
Level 1
Level 1
Posts: 23
Joined: Sun Nov 18, 2018 7:07 am

No Wifi available [SOLVED]

Post by abdemirza » Sun Nov 18, 2018 7:51 am

Hello,
I have just moved to Linux Mint from Windows 10 and the Wifi was working perfectly on that but on linux mint it is not showing wifi options , Here is the information about my system

Code: Select all

System:    Host: Linux Kernel: 4.19.2-041902-generic x86_64
           bits: 64 gcc: 8.2.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: LENOVO product: 81D2 v: Lenovo ideapad 330-15ARR serial: N/A
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: N/A
           UEFI: LENOVO v: 7VCN22WW date: 05/30/2018
Battery    BAT0: charge: 12.7 Wh 36.7% condition: 34.6/35.0 Wh (99%)
           model: SMP L17M2PF0 status: Discharging
CPU:       Quad core AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (-MT-MCP-) 
           arch: Zen rev.0 cache: 2048 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15970
           clock speeds: max: 2000 MHz 1: 1542 MHz 2: 1401 MHz 3: 1347 MHz
           4: 1362 MHz 5: 1324 MHz 6: 1355 MHz 7: 1338 MHz 8: 1280 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Vega [Radeon Vega 8 Mobile]
           bus-ID: 03:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa,radeon)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: AMD RAVEN (DRM 3.27.0 / 4.19.2-041902-generic, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 15e3
           driver: snd_hda_intel bus-ID: 03:00.6
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15de
           driver: snd_hda_intel bus-ID: 03:00.1
           Sound: Advanced Linux Sound Architecture v: k4.19.2-041902-generic
Network:   Card-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
           port: 3000 bus-ID: 01:00.0
           IF: N/A state: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 port: 2000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (1.8% used)
           ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 916G used: 17G (2%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A gpu: 38.0
Info:      Processes: 257 Uptime: 4 min Memory: 1152.0/7582.0MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Last edited by abdemirza on Tue Nov 20, 2018 7:15 am, edited 1 time in total.

JeremyB
Level 19
Level 19
Posts: 9445
Joined: Fri Feb 21, 2014 8:17 am

Re: No Wifi available

Post by JeremyB » Sun Nov 18, 2018 8:04 am

Try

Code: Select all

sudo apt install git build-essential dkms
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh
Reboot, disable Secure Boot in BIOS

abdemirza
Level 1
Level 1
Posts: 23
Joined: Sun Nov 18, 2018 7:07 am

Re: No Wifi available

Post by abdemirza » Sun Nov 18, 2018 12:20 pm

Thank you so Much :D , now its working fine..

Post Reply

Return to “Hardware Support”