Wireless dissapears?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 2
Level 2
Posts: 78
Joined: Tue Jun 09, 2009 8:13 pm

Wireless dissapears?

Postby Chasester » Sun Jun 28, 2009 7:28 pm

Hey folks.

Compaq C751NR
01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

When I first installed Linux Mint about a month and half ago it found the wireless right off the bat, then every time I would get any updates I would reboot and wireless would not be an available option. Reboot several times and It would find it again. I got fed up with it one night and reinstalled Mint - did this a few times where the first couple attempts did not show wireless either.

This last time I had it working very sweet, went to put the laptop into suspended mode last night - came back this morning unlocked and wireless is not an option again.

In all of the above attempts, I"ve tried using the Atheros driver, and tried the ndiswrapper one as well. All attempts give the same result - wireless not an option. If I run iwconfig I receive this.

Code: Select all

lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions

If I left click on the Network Manager it used to show the option to connect to a hidden wireless network (for some reason does not now). If I put in the same ssid as my wireless point it will not give me the connecting icon at all.

Would anybody have any suggestions on what to try?

Thank you
youth is certainly wasted on the young.

Level 7
Level 7
Posts: 1865
Joined: Mon May 11, 2009 1:21 am

Re: Wireless dissapears?

Postby pdc_2 » Mon Jun 29, 2009 3:37 am

we used this guide

http://www.ubuntugeek.com/how-to-get-at ... -ibex.html

to install the requisite drivers to a MoonOS on an ASUS: reason is the MoonOS is a light LXDE distro; but it did not have the atheros drivers; the install worked very well; (and we used it to install on to a couple of SD cards as well!)

I wonder if you check the blacklisting that needs to be done: ie check that those drivers that need to be blacklisted are still so;

(and I worry that ndiswrapper is lurking in the background too, but I am no wireless expert)

Level 2
Level 2
Posts: 78
Joined: Tue Jun 09, 2009 8:13 pm

Re: Wireless dissapears?

Postby Chasester » Mon Jun 29, 2009 10:44 pm

Thanks pdc_2,

The solution was probably quite spot on. Although it didn't quite work. So to remove whatever i may have done was I did a full install (again). Wireless still did not work. So poking around more I found that that typing in a Terminal

Code: Select all

lshw -C Network

showed the wireless as "Unclaimed" Go figure that one. so I said the hell with it, Little more browsing around and found this over at Ubuntu - same basic resolution as you indicated.

Go to http://linuxwireless.org/download/compat-wireless-2.6/ and download the tar


Code: Select all

cd ~/Desktop
sudo apt-get install build-essential
tar -xjvf compat-wireless*
cd compat-wireless*
sudo make unload
sudo make load
sudo make install
echo ath9k | sudo tee -a /etc/modules
echo ath5k | sudo tee -a /etc/modules
echo ath_pci | sudo tee -a /etc/modules

And it worked.

Many thanks for the point.
youth is certainly wasted on the young.

Return to “Hardware Support”

Who is online

Users browsing this forum: Volunteer4F and 8 guests