SD card doesn't mount on one computer anymore

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Ctulhu
Level 2
Level 2
Posts: 79
Joined: Mon May 02, 2011 5:45 pm

SD card doesn't mount on one computer anymore

Post by Ctulhu »

Hi all

I have two laptops with Mint 19.1 Cinnamon. I use a 128GB SD card for backups. Last time I shut down laptop1 that had the card in it, it turned off before a a disk process apparently involving the card was completed and now laptop1 on which that happened doesn't mount that SD card anymore. The other laptop, laptop2, which is configured the same way, does mount it without problems. I tried reformatting it and creating a new ext4 partition, but while this process concludes successfully and while laptop2 again mounts it alright, laptop1 just does not do anything when the card is inserted (and nothing shows up in Disks or GParted) so I am guessing there's something left in laptop1's file system that causes that problem - any ideas what I might do?

Thanks for any input you might have!
Ctulhu
Level 2
Level 2
Posts: 79
Joined: Mon May 02, 2011 5:45 pm

Re: SD card doesn't mount on one computer anymore

Post by Ctulhu »

And I forgot to mention, the laptop1 also doesn't recognize other SD cards anymore so it COULD be a hardware problem, but since this all only started after the disk process wasn't concluded, I doubt that and bet it's a software thing.
Post Reply

Return to “Hardware Support”