Page 1 of 1

[SOLVED]g15daemon doesn't start at boot

Posted: Tue Jan 29, 2019 2:13 pm
by dancer_69
As the title says.
I can start g15daemon.service via systemctl and then it works fine until reboot:

Code: Select all

systemctl status g15daemon.service
● g15daemon.service - LSB: load deamon for Logitech G15 keyboard lcd display
   Loaded: loaded (/etc/init.d/g15daemon; generated)
   Active: active (running) since Tue 2019-01-29 19:50:48 EET; 6min ago
     Docs: man:systemd-sysv-generator(8)
    Tasks: 6 (limit: 4915)
   CGroup: /system.slice/g15daemon.service
           └─1029 /usr/sbin/g15daemon
I tried to enable it:

Code: Select all

systemctl enable g15daemon.service
I get this output:

Code: Select all

g15daemon.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable g15daemon
but again it doesn't autostart on reboot.
How can I make it start at boot?

Re: g15daemon doesn't start at boot

Posted: Wed Jan 30, 2019 3:36 am
by dancer_69
Since there' s no answer yet and I found a solution I answer myself.
I found some info here about this bug: ... ug/1441365

So, based on above, I removed the g15daemon file from /etc/init.d and I created a g15daemon.service file in /lib/systemd/system
with these contents:

Code: Select all

Description=A daemon that makes it possible to use the G-Buttons and draw on the G15 LCD


Then I enabled it by:

Code: Select all

sudo systemctl enable g15daemon.service
and now it starts at boot as expected.