[solved] Touchpad Worked in 6, Not in 7

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 5
Joined: Mon Jul 13, 2009 12:36 pm

[solved] Touchpad Worked in 6, Not in 7

Postby Axman » Mon Jul 13, 2009 12:38 pm

So I installed Linux Mint 7 and my mouse doesn't work. I look at /proc/bus/input/devices and it says I have a gsynaptics-elantech mouse, which I know isn't right. Seeing how it worked fine with Mint 6, I installed that real quick, which, sure enough, says that it's a PS/2 Logitech Wheel Mouse. That lasts for a while, but then I get tired of 6.

I decided to reinstall Mint 7, but now the device file seems to be corrupt, it says that I don't have permission to do anything with the file; delete it, chmod it, nothing works, even as root. When I open it to read the thing, it's blank, and then it quickly says that the file's changed, time to reload it; it's always blank. I've reinstalled several times, even going so far as to delete all the partitions before doing an install just to make sure it's not reusing anything from the borked install, but it's always the same.

Edit: so now I know a little more about the /proc directory and how it works; I know that's not where you make the changes. I'm still stumped, though. And I can't read devices to see what, if anything's going on.

I can click the mouse buttons, they work fine. I just can't move the cursor. Again, it all works normally with Mint 6.

I just ran # cat /dev/input/mouse0 and it doesn't detect a damn thing. How do I go about making sure that the right modules are loaded?

Fixed it:

Code: Select all

modprobe -r psmouse
modprobe psmouse proto=imps

Now, can someone tell me why this fixed it?

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: [solved] Touchpad Worked in 6, Not in 7

Postby Husse » Tue Jul 14, 2009 5:49 am

modprobe -r somemodule followed by modprobe of the same module seems to fix a lot of problems
proto=imps changes some setting in the kernel - have not had the time to check exactly what
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Hardware Support”