Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
cooch17
Level 1
Level 1
Posts: 9
Joined: Sat Jul 23, 2016 8:28 pm

Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by cooch17 »

So, have a very basic Dell machine, which has a GT 710 nVidia graphics card in it. Was running Mint 18.3, with the nVidia drivers, without a hitch. Decided to try an 'update' to 19.1, so blew away 18.3, and did a brand spanking new install of 19.1. No muss, no fuss. Ran through some reboot cycles, and all seemed fine.

Then, I (foolishly) tried to install the 390 device driver, replacing the Nouveau default, and...problems. I suppose my first clue was that it took almost 5 minutes to apply the proprietary nVidia driver. Did a reboot and...the dreaded warning that 'Cinnamon is running in software rendering mode...blah, blah blah'.

So, reverted to Noveau, rebooted, and...still getting the same 'software rendering mode' message. And, when I looked at the 'driver update' app, both 'nVidia' and 'Noveau' were greyed out.

So, before I revert all the way back to 18.3, and perhaps an older driver, any suggestions?
Last edited by cooch17 on Wed Jul 24, 2019 7:57 pm, edited 1 time in total.
cooch17
Level 1
Level 1
Posts: 9
Joined: Sat Jul 23, 2016 8:28 pm

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by cooch17 »

Went ahead and blew away 19.1, and reverted to 18.3 (takes all of 10 minutes to go back and forth). Interestingly, for 18.3, the driver update offered 384 nVidia (not 390), and also a microcode update, which 19.1 didn't offer. So, applied both, and so far (6 reboot cycles later), no muss, no fuss.

So, casual conclusion is that there is something about either (i) nVidia 390 driver, (ii) Cinnamon coming with 19.1, (iii) the 19.1 drive update tool (which isn't offering a microcode update, but 18.3 is?), or some combination of (i) -> (iii), that doesn't play nice with this system (the GT 710 card is about as generic as you can get).
ajgringo619
Level 8
Level 8
Posts: 2100
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California, USA

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by ajgringo619 »

Is the 390 driver the recommended version? I guess you could try adding the Nvidia PPA and try the latest-and-greatest (v430.26 right now); maybe that would fix your 19.1 problems.
Mint 20 XFCE [kernel 5.4.0-52-generic]
Ryzen 7 2700X Eight-Core w/16 GB RAM
AMD Radeon R9 290 w/4GB RAM
Image
cooch17
Level 1
Level 1
Posts: 9
Joined: Sat Jul 23, 2016 8:28 pm

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by cooch17 »

ajgringo619 wrote:
Wed Jul 24, 2019 8:16 pm
Is the 390 driver the recommended version?
Yes -- I didn't download anything separate from what Mint's 'driver' utility presented.
I guess you could try adding the Nvidia PPA and try the latest-and-greatest (v430.26 right now); maybe that would fix your 19.1 problems.
Maybe a good experiment for another time. 18.3 is running fine, with the 384 driver, which is enough for my generic purposes. I guess I'm surprised that things borked on a generic GT 710. If 19.1 choked on that out the box, then...
Last edited by cooch17 on Sun Aug 04, 2019 12:53 pm, edited 2 times in total.
ajgringo619
Level 8
Level 8
Posts: 2100
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California, USA

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by ajgringo619 »

cooch17 wrote:
Wed Jul 24, 2019 9:00 pm
ajgringo619 wrote:
Wed Jul 24, 2019 8:16 pm
Is the 390 driver the recommended version?
Yers -- I didn't download anything separate from what Mint's 'driver' utility presented.
I guess you could try adding the Nvidia PPA and try the latest-and-greatest (v430.26 right now); maybe that would fix your 19.1 problems.
Maybe a good experiment for another time. 18.3 is running fine, with the 384 driver, which is enough for my generic purposes. I guiess I'm surprised that things borked on a generic GT 710. If 19.1 choked on that out the box, then...
According to the Nvidia site, your card is supported by the 430 series drivers (same one I'm using with my GeForce 960, which has never failed me from 18.1 to 19.1). As long as you have Timeshift, this would be a quick test.
Mint 20 XFCE [kernel 5.4.0-52-generic]
Ryzen 7 2700X Eight-Core w/16 GB RAM
AMD Radeon R9 290 w/4GB RAM
Image
User avatar
jimthedj65
Level 1
Level 1
Posts: 15
Joined: Wed Feb 03, 2016 8:18 am

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by jimthedj65 »

I upgraded to the Nvidia Module 430.40 today running Cinnamon 19.1 and can report it is much more stable than the 390.116 bundled drivers. I'm running an MSI GT710 as an interface to my
product: AMD FX(tm)-6300 Six-Core Processor powered TV system. The bundled 390.116 driver was causing out of focus issues and the new 430.40 drivers are very stable and look much sharper on my Sony lcd tv than the nouveau 1:1.0.15-2 open source drivers.

Path for nvidia drivers used is http://us.download.nvidia.com/XFree86/L ... 430.40.run

Thanks to all for the help in this forum.
cooch17
Level 1
Level 1
Posts: 9
Joined: Sat Jul 23, 2016 8:28 pm

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by cooch17 »

Thanks -- when I'm feeling brave, I might try 19.1 again, with the 'newer, better' nVidia drivers. There is something comforting about 18.3 working flawlessly (as the saying goes, if it ain't broke, don't fix it...).
User avatar
jimthedj65
Level 1
Level 1
Posts: 15
Joined: Wed Feb 03, 2016 8:18 am

Re: Mint 19.1 Cinnamon | problem with nVidia 390 | rendering?

Post by jimthedj65 »

Couldn't agree more
Post Reply

Return to “Hardware Support”