Page 1 of 1

[SOLVED]Help with WIFI, got to modprobe every power on, Lenovo, Mint 19.2

Posted: Sun Aug 04, 2019 8:52 pm
by amrivas
Hello,

I am trying Mint 19.2; I have a lenovo 2-1 Flex 6-14ARR ryzen 3 2200U. So far I got the video amdgpu pro installed, backlight issue with it, but its a matter of research or test.

My main issue its the WIFI, I got it installed, it works and even the bluetooth works, but every time I turn on the laptop its disabled and I have to do a

Code: Select all

sudo modprobe -r ideapad_laptop
to enable it

Its there a way to make it permanent? I even did the solution tomas pinho put in his github driver about the pcie

WIFI Realtek rtl8821ce
PCIe Activate State Power Management

Your distribution may come with PCIe Active State Power Management enabled by default. That may conflict with this driver. To disable:

sudo $EDITOR /etc/default/grub

Add pci=noaer at the end of GRUB_CMDLINE_LINUX_DEFAULT. Line should look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=noaer"

Then update your GRUB configuration:

sudo update-grub

Reboot.

Re: Help with WIFI, got to modprobe every power on, Lenovo, Mint 19.2

Posted: Sun Aug 04, 2019 8:57 pm
by thx-1138
echo 'blacklist ideapad_laptop' | sudo tee /etc/modprobe.d/ideapadblacklist.conf
To undo...
sudo rm /etc/modprobe.d/ideapadblacklist.conf

Re: Help with WIFI, got to modprobe every power on, Lenovo, Mint 19.2

Posted: Sun Aug 04, 2019 9:05 pm
by amrivas
hahaha you were faster then my, I had the solution but I had it some where in my documents.

Either way. Thanks man!