Mute Button LED's dont light up when muted on ThinkPad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Mon Aug 12, 2019 9:04 pm

Mute Button LED's dont light up when muted on ThinkPad

Post by sgashepp » Mon Aug 12, 2019 9:42 pm

I have a Thinkpad X1 Yoga, The mute LED for the speakers or the microphone does not toggle at all. All hotkeys do work as intended, just the LED's don't.
Here's the thing. They DO work when I install stock Ubuntu. They also worked when I tried a live version of Pop!_OS. They don't on Linux mint.

I have tried several Kernels with no effect.
I have also found several "fixes" on google that involve creating a custom script, however they didn't work either.

Thanks for any assistance!

Code: Select all

  Host: Daedalus Kernel: 5.0.0-23-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
  Type: Convertible System: LENOVO product: 20FRS3D901 
  v: ThinkPad X1 Yoga 1st serial: <filter> 
  Mobo: LENOVO model: 20FRS3D901 v: SDK0J40697 WIN serial: <filter> 
  UEFI: LENOVO v: N1FET68W (1.42 ) date: 03/13/2019 
  ID-1: BAT0 charge: 34.0 Wh condition: 45.9/52.1 Wh (88%) 
  model: SMP 00HW029 status: Unknown 
  Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19968 
  Speed: 510 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 579 2: 567 
  3: 587 4: 584 
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 2560x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: Lenovo type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 1-4.1.4:8 
  Sound Server: ALSA v: k5.0.0-23-generic 
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 
  IF: enp0s31f6 state: down mac: <filter> 
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 04:00.0 
  IF: wlp4s0 state: up mac: <filter> 
  Device-3: Lenovo type: USB driver: cdc_ether bus ID: 2-4.1.3:4 
  IF: enx0050b6d5a574 state: down mac: <filter> 
  Local Storage: total: 238.47 GiB used: 28.46 GiB (11.9%) 
  ID-1: /dev/sda vendor: SanDisk model: SD8TN8U256G1001 size: 238.47 GiB 
  ID-1: / size: 233.24 GiB used: 14.23 GiB (6.1%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3211 
  Processes: 192 Uptime: 14m Memory: 7.52 GiB used: 992.6 MiB (12.9%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Post Reply

Return to “Hardware Support”