<SOLVED> Touchpad is re-activated when screen turns off!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
gregory_opera
Level 1
Level 1
Posts: 26
Joined: Tue Aug 13, 2019 4:56 pm
Contact:

<SOLVED> Touchpad is re-activated when screen turns off!

Post by gregory_opera » Wed Aug 14, 2019 7:50 am

On my ASUS VivoBook X556UV, I disable the touchpad using the relevant keyboard shortcut (i.e. that assigned by ASUS) and Linux Mint briefly shows an on-screen icon indicating that it has been successfully disabled... If I then try to use the touchpad, it (unsurprisingly) does not work.

But when ever my screen turns off, the touchpad is re-activated! :x The same is true when my laptop goes into "standby", though I suspect this is because the screen is turning off (rather than the fact that the laptop is going into "standby"), because I temporarily have "standby" disabled and the issue is still occurring...

Having being a Ubuntu user since almost Day One, I was running Ubuntu 18.04 LTS ("Bionic Beaver") until a few days ago and the touchpad would stay disabled once I disabled it, so it is clearly a Linux Mint issue... I'm just not sure what the specific cause of this issue is.

Any ideas?
Last edited by gregory_opera on Fri Sep 06, 2019 8:49 am, edited 1 time in total.
--

"All our dreams can come true - if we have the courage to pursue them."

Walt Disney. °o°

The Bright Side
Level 2
Level 2
Posts: 63
Joined: Thu Jul 12, 2018 3:09 pm

Re: Touchpad is re-activated when screen turns off!

Post by The Bright Side » Thu Aug 22, 2019 1:48 am

Hey Gregory, are you sure this only happens when you disable your screen or go into standby? How about after reboots?

I've been having a similar problem, but in my case, it re-enables itself completely randomly and unpredictably.

The best way I've found to keep it in check is to install indicator-touchpad from the atareao ppa (sudo add-apt-repository ppa:atareao/atareao). You can set it to autostart, disable the touchpad on launch, disable it when a mouse is plugged in and while you're typing.

I've opened my own thread a few weeks ago and I just noticed another forum user has the same issue, but so far, no response from the devs. It would be nice to know they're aware of this and looking for a solution.

In the meantime, if anybody has any suggestions how to disable the touchpad completely, please chime in. Perhaps there's a driver we can uninstall?

deepakdeshp
Level 15
Level 15
Posts: 5894
Joined: Sun Aug 09, 2015 10:00 am

Re: Touchpad is re-activated when screen turns off!

Post by deepakdeshp » Thu Aug 22, 2019 2:12 am

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 15
Level 15
Posts: 5894
Joined: Sun Aug 09, 2015 10:00 am

Re: Touchpad is re-activated when screen turns off!

Post by deepakdeshp » Thu Aug 22, 2019 2:17 am

Disable touchpad while typing" in Mouse Preference-Touchpad.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

The Bright Side
Level 2
Level 2
Posts: 63
Joined: Thu Jul 12, 2018 3:09 pm

Re: Touchpad is re-activated when screen turns off!

Post by The Bright Side » Thu Aug 22, 2019 2:41 am

Hey Deepak, thanks for your reply. I don't know about the other users, but none of these things work on my end. The touchpad randomly turns itself back on no matter what. This looks like a bug in Mint 19.2. Is there a driver we can uninstall?

Should we open a bug report about it, and if so, where can this be done? I'm not quite sure where the Linux Mint bug tracker is, but I've worked 8 years as a QA tester, so I promise it'll be a well-written bug report :-)

deepakdeshp
Level 15
Level 15
Posts: 5894
Joined: Sun Aug 09, 2015 10:00 am

Re: Touchpad is re-activated when screen turns off!

Post by deepakdeshp » Thu Aug 22, 2019 2:34 pm

Please see. viewtopic.php?t=280175
Good luck.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

The Bright Side
Level 2
Level 2
Posts: 63
Joined: Thu Jul 12, 2018 3:09 pm

Re: Touchpad is re-activated when screen turns off!

Post by The Bright Side » Fri Aug 23, 2019 2:08 am

To anybody reading this, your solution might be:

Code: Select all

sudo chown -Rc $USER:$USER $HOME
After that, turn off the touchpad in Mouse and Touchpad settings, then reboot.

More info in this thread:
viewtopic.php?f=47&t=300339

I think this worked for me! (but I will keep an eye on it for a few days and report back if there are any more shenanigans.)

gregory_opera
Level 1
Level 1
Posts: 26
Joined: Tue Aug 13, 2019 4:56 pm
Contact:

Re: Touchpad is re-activated when screen turns off!

Post by gregory_opera » Fri Sep 06, 2019 8:48 am

Well, I found a fix.

If I disabled my touchpad using my laptop's keyboard shortcut (i.e. FN + F9), it does work - but as per my original post, this setting is reversed (i.e. the touchpad is automatically enabled again) whenever my screen turns off... Interestingly, this seems to specifically be a Linux Mint issue, as I never had this problem under Ubuntu 18.04.x LTS ("Bionic Beaver").

I didn't try changing the relevant setting in my laptop's UEFI settings - though I suspect this might have worked, because my understanding is that the UEFI settings should disable the hardware at a "root" level (so to speak) - but if I changed the respective setting via Linux Mint's Control Center (Menu-->Control Center-->Hardware-->Mouse and Touchpad-->Touchpad-->Disable)(make the switch grey), it disables the touchpad and keeps it disabled until such a time that I re-enable it using the same method...

A strange bug that was seemingly fixed an obvious way - hopefully it works this way for you guys, too.
--

"All our dreams can come true - if we have the courage to pursue them."

Walt Disney. °o°

Post Reply

Return to “Hardware Support”