<SOLVED> S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
taith
Level 1
Level 1
Posts: 25
Joined: Mon Feb 20, 2017 8:13 am

<SOLVED> S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by taith » Thu Aug 15, 2019 5:00 pm

I use TOSLINK to connect my amplifier with PC.
After updating from 19.1 to 19.2 (cinnamon)
And switching to kernel 5.0.0-25-generic from 4.15.0-58
I noticed audio problem
If no sound is played for 6.5s I assume optical port gets turned off (audible sound in speakers)
Using TOSLINK integrated with motherboard
Re-engaging optical connection takes about 1.5s of sound to play, so stuff like discord messages can be completely missed out.

Edit: Issue seem to be solved as of now, thanks!
Last edited by taith on Fri Sep 20, 2019 1:05 pm, edited 1 time in total.

taith
Level 1
Level 1
Posts: 25
Joined: Mon Feb 20, 2017 8:13 am

Re: S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by taith » Fri Aug 23, 2019 2:59 pm

Also, using Alsamixer I disabled auto-mute, nothing changed tho.

taith
Level 1
Level 1
Posts: 25
Joined: Mon Feb 20, 2017 8:13 am

Re: S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by taith » Mon Sep 16, 2019 2:05 pm

Where should I report that issue?
I checked personally, and indeed, light is switched off after 6.5s of silence, turning it on later (it lit up instantly, but amplifier needs few seconds to make any sense of it) causes first few seconds of song/video to be missing after only short period of silence

User avatar
MrEen
Level 13
Level 13
Posts: 4647
Joined: Mon Jun 12, 2017 8:39 pm

Re: S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by MrEen » Mon Sep 16, 2019 4:03 pm

Hi taith. I was away for a bit when you first posted this thread and just now saw this.

This sounds like alsa's powersaving causing this. Here's how to turn it off:

In the terminal enter xed admin:///etc/modprobe.d/alsa-base.conf and when the file opens scroll to the bottom and add this new line:

Code: Select all

options snd_hda_intel power_save=0 power_save_controller=N
Save and close the file, then reboot and test your sound.

Hope that helps.

P.S. You'll get warnings from the terminal when closing the file. Ignore them.

taith
Level 1
Level 1
Posts: 25
Joined: Mon Feb 20, 2017 8:13 am

Re: S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by taith » Tue Sep 17, 2019 8:43 am

EDIT: it's awkward to admit, but it seem to work now, all of the sudden for no reason, will update after some time if fix is permanent or not some freak accident

Thank you for reply!
Your suggestion appear to be miss
Added line, saved, opened again to be sure, restarted PC and problem still occurs

User avatar
MrEen
Level 13
Level 13
Posts: 4647
Joined: Mon Jun 12, 2017 8:39 pm

Re: S/PDIF (optical) sound (light?) turns off after 6.5s of silence

Post by MrEen » Tue Sep 17, 2019 4:54 pm

Odd that it didn't work on the first reboot.

Do keep an eye on it and let us know if the issue returns. Even if it only happens sporadically, let us know and maybe we can check some things to see what might be causing it.

Good luck.

Post Reply

Return to “Hardware Support”