Dual monitor issues Thinkpad Docking station

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
mintMan1234
Level 1
Level 1
Posts: 3
Joined: Wed Sep 04, 2019 12:43 pm

Dual monitor issues Thinkpad Docking station

Post by mintMan1234 » Wed Sep 04, 2019 1:02 pm

The setup
  • T460 thinkpad (Intel HD Graphics) docked with lid closed connected to two external monitors one via DVI and the other via HDMI, Linux Mint 19.1 Tessa
The problem
  • During boot and up until the login screen both monitors work fine. But as soon as I sign in the monitor connected with DVI will go blank about 80% of the time.
  • The issue is isolated with Linux Mint as this machine can dual boot into windows without the described problem
My workaround solutions to fix this problem
  • Going back to the login screen via CTRL + ALT + BACKSPACE and signing in again will almost always fix it.
  • Physically removing/reinserting the cable will almost always fix it.
Behavior
  • When logging in and experiencing the problem, the monitor seems to be recognized as I can move my mouse into its resolution, but the monitor claims cable not connected.
When did the problem occur?
  • After moving and going from three to two monitors as well as reinstalling Linux Mint for luks encryption

----- Additional Info -----

It was suggested to me that I try to install xorg driver xf86-video-intel from source, but I received error after error and it ultimately didn't work.

Code: Select all

    $ lspci -k | grep -EA3 'VGA'
         00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
         Subsystem: Lenovo Skylake GT2 [HD Graphics 520]
         Kernel driver in use: i915
         Kernel modules: i915

Code: Select all

$ cat /var/log/Xorg.0.log | grep -i driver
   [   105.041]     X.Org Video Driver: 23.0
   [   105.041]     X.Org XInput driver : 24.1
   [   105.062] (==) Matched modesetting as autoconfigured driver 0
   [   105.062] (==) Matched fbdev as autoconfigured driver 1
   [   105.062] (==) Matched vesa as autoconfigured driver 2
   [   105.062] (==) Assigned the driver to the xf86ConfigLayout
   [   105.062] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
   [   105.063]     Module class: X.Org Video Driver
   [   105.063]     ABI class: X.Org Video Driver, version 23.0
   [   105.063] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
   [   105.063]     Module class: X.Org Video Driver
   [   105.063]     ABI class: X.Org Video Driver, version 23.0
   [   105.063] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
   [   105.063]     Module class: X.Org Video Driver
   [   105.063]     ABI class: X.Org Video Driver, version 23.0
   [   105.063] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
   [   105.063] (II) FBDEV: driver for framebuffer: fbdev
   [   105.063] (II) VESA: driver for VESA chipsets: vesa
   [   105.079]     ABI class: X.Org Video Driver, version 23.0
   [   105.087] (II) glamor: OpenGL accelerated X.org driver based.
   [   105.946] (II) modeset(0): [DRI2]   DRI driver: i965
   [   105.946] (II) modeset(0): [DRI2]   VDPAU driver: i965
   [   106.020]     Module class: X.Org XInput Driver
   [   106.020]     ABI class: X.Org XInput driver, version 24.1
   
I'm pretty green when it comes to diagnosing graphical problem. I would be happy to paste additional logs, but I'm not sure which ones would be helpful. Please let me know which logs might be worth taking a look at, or any other suggestions you may have!

mintMan1234
Level 1
Level 1
Posts: 3
Joined: Wed Sep 04, 2019 12:43 pm

Re: Dual monitor issues Thinkpad Docking station

Post by mintMan1234 » Fri Sep 06, 2019 8:59 pm

Since I made the post I have also tried upgrading the power supply and running a firmware update on the docking station. Unfortunately the problem persists, might anyone have a suggestion? Is there a document that could guide me in installing an alternative graphics driver?

mintMan1234
Level 1
Level 1
Posts: 3
Joined: Wed Sep 04, 2019 12:43 pm

Re: Dual monitor issues Thinkpad Docking station

Post by mintMan1234 » Mon Sep 09, 2019 10:55 pm

Just ordered some displayport adapters for the docking station, hoping maybe I will have better luck going from displayport to dvi/hdmi. Will update once they arrive, still open to suggestions.

Post Reply

Return to “Hardware Support”