I solved my issue with stutter on Mint 19.2 in a weird way

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
natch_gazziza
Level 1
Level 1
Posts: 18
Joined: Sat Aug 17, 2019 4:46 pm
Location: UK

I solved my issue with stutter on Mint 19.2 in a weird way

Post by natch_gazziza » Sun Sep 08, 2019 8:23 pm

So I've been having this issue with stuttering, doesn't matter what I'm doing, and It's been there since I installed I think. Typing, listening, watching, browsing, every two seconds roughly I would experience stutter for a split second. It's honestly not a lot, but I got annoyed at it and decided that it had to go. My specs are: 2080ti, 9700k, 32gb Corsair 3000Mhz RAM, 2x 1Tb nvme drives, Linux mint 19.2 + Windows 10 (GRUB is in the windows drive), Asus Prime z390-A, AOC Agon 27in 1440p Gsync monitor, which I have "overclocked" to 165hz, cpu and gpu are not overclocked, neither is the RAM which means in reality the RAM is in the low 2000's Mhz, and I haven't tried changing the governor. First I tried switching to Nouveau on driver manager, it forced me to 1080p without any visable option to switch on Display options. Then tried purging Nvidia*, Re-Downloading it with

Code: Select all

sudo apt install nvidia-driver-430
and it solved my issue. Until I ran

Code: Select all

sudo apt install install nvidia-settings
and opened it, without even changing anything, at which point the stuttering would come back at the same frequency. So I purged Nvidia, disabled Nouveau and installed a newer Nvidia driver, 435.21. This didn't run as well, I noticed a little stutter but not as much as before. Purged Nvidia* again, installed with

Code: Select all

sudo ubuntu-drivers autoinstall
and it works fine now. A little screen tearing occasionally but whatever, I think that might be because I haven't enabled Gsync. I don't even know if you can without nvidia-settings. It might also be helpful to add that I have experienced a bug in the past, where I tried the Nouveau drivers and couldn't switch back to Nvidia because both options were grayed out with the option "continue using manual driver" as the currently selected one.I just fixed it by purging Nvidia*. Also might be worth mentioning that as I was trying to fix the stuttering, I was experimenting with and without Gsync in nvidia-settings and Vertical sync in Mint settings. Nothing helped the stuttering. So I haven't installed nvidia-settings and that is how I solved my stuttering problem. If anyone has any idea why, I'd like to discuss it. Otherwise, I hope this helps someone! :D

Nicole

Post Reply

Return to “Hardware Support”